@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > マルチエリアOSPF(仮想リンク設定)

 Amazon

@network Cisco・アライド実機で学ぶ
◆マルチエリアOSPF(仮想リンク設定)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆マルチエリアOSPF(仮想リンク設定)

 OSPFでは、全てのエリアがエリア0と接続しなけらばならないというルールがあります。別のエリアと通信するには、エリア0を経由して通信を行うことになります。

仮想リンクを使えば、エリア0と直接接続できないエリアでもエリア0と接続することができます。


仮想リンクの設定については、アライドテレシス製のレイヤ3スイッチで構築する例も紹介しています。

レイヤ3スイッチでの構築例はこちら → 「OSPF(仮想リンク_その9)

使用するネットワークは、下図のようになります。



◆ルータID(Router_ID)

 ルータIDは、OSPFネットワークにおいて、DR、BDRを選出する際の判断基準となりました。仮想リンクの設定においても、ルータIDは、設定において重要になってきます。

 ルータIDは、アクティブなインタフェースのIPアドレスの内で最も大きいIPアドレスになります。ループバックアドレスが設定された場合は、ループバックアドレスが優先されます。

 ルータIDは、管理者が静的に設定することもできます。ルータIDを静的に設定するには、以下のコマンドを使用します。

Router(config)#router ospf [プロセス番号]
Router(config-router)#router-id [IPアドレス]

今回は、ループバックアドレスを使用します。


◆仮想リンクについて

仮想リンクを設定するには、仮想リンクを張る相手側のルータのルータIDを指定します。


今回、使用するネットワークでは、

・Router_Bが仮想リンク用に、Router_C(相手側)のルータIDである「3.3.3.3」を指定

・Router_Cが仮想リンク用に、Router_B(相手側)のルータIDである「2.2.2.2」を指定

して、お互いに相手のルータIDを指定します。

まずは、仮想リンクを用いないで、OSPFを設定してゆきましょう。

Router_A、Router_CのF0を強制的にUPにするために、「no shutdown」しておきます。

●Rotuer_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0
 ip address 172.16.0.1 255.255.0.0
 speed auto
 no keepalive
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.1 255.255.0.0
 no fair-queue
!
router ospf 1
 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 172.17.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Rotuer_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
 clockrate 64000
!
interface Serial1
 bandwidth 64
 ip address 172.18.0.1 255.255.0.0
 clockrate 64000
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router ospf 1
 network 172.17.0.0 0.0.255.255 area 0
 network 172.18.0.0 0.0.255.255 area 1
!
ip classless
no ip http server
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end

●Rotuer_Cの設定
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_C
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0
 ip address 172.19.0.1 255.255.0.0
 no keepalive
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.18.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 172.18.0.0 0.0.255.255 area 1
 network 172.19.0.0 0.0.255.255 area 2
!
ip classless
no ip http server
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


Router_Aのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
C    172.17.0.0/16 is directly connected, Serial0
C    172.16.0.0/16 is directly connected, FastEthernet0
O IA 172.18.0.0/16 [110/3124] via 172.17.0.2, 00:01:31, Serial0

エリア2の「172.19.0.0」のエントリがありません。それは、エリア2がエリア0と直接つながっていないからです。

Router_Bに接続してみます。


◆仮想リンクの設定

Router_B、Router_Cで仮想リンクの設定を行います。

仮想リンクの設定を行うには以下のコマンドを使用します。

Router(config-router)#area [area_id] virtual-link [router_id]

「area_id」には、仮想リンク上のエリア番号を指定します。


今回指定する、「area_id」は、Router_B、Router_C間のエリア1を指定します。

「Router_id」は、対向ルータのルータIDを指定します。

・Router_B ・・・ 「3.3.3.3」
・Router_C ・・・ 「2.2.2.2」


Router_B、Router_Cで以下の設定を追加します。

Router_B(config)#router ospf 1
Router_B(config-router)#area 1 virtual-link 3.3.3.3

Router_C(config)#router ospf 1
Router_C(config-router)#area 1 virtual-link 2.2.2.2


Router_Aのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
C    172.17.0.0/16 is directly connected, Serial0
C    172.16.0.0/16 is directly connected, FastEthernet0
O IA 172.19.0.0/16 [110/3125] via 172.17.0.2, 00:13:39, Serial0
O IA 172.18.0.0/16 [110/3124] via 172.17.0.2, 00:13:39, Serial0

エリア2の「172.19.0.0」のエントリがあります。

このように、仮想リンクを使えば、エリア0と直接接続できないエリアでもエリア0と接続することができます。

 仮想リンクは、OSPFで構築された企業同士が統合する時などに、一時的に使うものです。例えば、2社が合併する場合を考えてみると、両者ともエリア0を持っていることになります。この場合、統合が完全に完了するまで、暫定的に離れたエリア0と接続するために、仮想リンクを利用します。

仮想リンクは、あくまで、暫定的なものです。積極的に用いる手法ではありません。


 次の「マルチエリアOSPF(集約ルートの設定)」では、エリア内のルートをルート集約してルーティングテーブルのエントリー数を少なくする方法を紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆マルチエリアOSPF

マルチエリアOSPFとは
マルチエリアOSPF(エリアの概念)
マルチエリアOSPF(ABR・ASBRの設定)
マルチエリアOSPF(ABRの設定例)
マルチエリアOSPF(LSAの種類)
マルチエリアOSPF(ネットワークLSA)
マルチエリアOSPF(ASBRサマリーLSA)
マルチエリアOSPF(NSSA外部LSA)
マルチエリアOSPF(エリアの種類)
マルチエリアOSPF(標準エリアとは)
マルチエリアOSPF(トータリースタブエリアとは)
マルチエリアOSPF(トータリーNSSAとは)
マルチエリアOSPF(標準エリア設定)
マルチエリアOSPF(トータリースタブエリア設定)
マルチエリアOSPF(トータリーNSSA設定)
マルチエリアOSPF(集約ルートの設定)
OSPF(確認コマンド)
マルチエリアOSPF(OSPFの問題点)
マルチエリアOSPF(OSPFルータの種類)
マルチエリアOSPF(ASBRの設定例)
マルチエリアOSPF(ABR・ASBR混在設定例)
マルチエリアOSPF(ルータLSA)
マルチエリアOSPF(ネットワークサマリーLSA)
マルチエリアOSPF(AS外部LSA)
マルチエリアOSPF(マルチエリア構成例)
マルチエリアOSPF(バックボーンエリアとは)
マルチエリアOSPF(スタブエリアとは)
マルチエリアOSPF(NSSAとは)
マルチエリアOSPF(OSPF用語まとめ)
マルチエリアOSPF(スタブエリア設定)
マルチエリアOSPF(NSSA設定)
マルチエリアOSPF(仮想リンク設定)
OSPF(show ip ospf database)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.