@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > マルチエリアOSPF(ABR・ASBR混在の設定例)

 Amazon

@network Cisco・アライド実機で学ぶ
◆マルチエリアOSPF(ABR・ASBR混在の設定例)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆マルチエリアOSPF(ABR・ASBR混在の設定例)

 ここでは、ABR、ASBRの設定を行い、複数のエリア間、非OSPFネットワーク間の接続を行うネットワークを構築します。

ネットワークは、下の設定例で紹介したネットワークを再利用します。

マルチエリアOSPF(ASBRの設定例)
マルチエリアOSPF(ABRの設定例)

 ネットワーク構成は、「マルチエリアOSPF(ASBRの設定例)」「マルチエリアOSPF(ABRの設定例)」で使用したネットワークを「172.19.0.0/16」ネットワークで接続したものになります。


◆ASBRルータの設定(Router_B)

●RIPルートの再配送

RIPで学習したルートをOSPFへ再配送するように以下のように設定します。
※設定を省略した場合でも、デフォルトのシードメトリック値である「20」が使われるので、再配送は行われます。

Router_B(config)#router ospf 1
Router_B(config-router)#redistribute rip metric 100 subnets
Router_B(config-router)#network 172.18.0.0 0.0.255.255 area 0

 「redistribute rip metric 100 subnets」と指定することで、シードメトリック値に「100」を設定しています。「subnets」は、クラスレスルートを再配送させるためのオプションです。このオプションを指定することで、サブネット化された経路情報を再配送できるようになります。

OSPFネットワークへ再配送する際には、「subnets」を指定しておきます。

●OSPFルートの再配送

OSPFで学習したルートをRIPへ再配送するように以下のように設定します。

Router_B(config)#router rip
Router_B(config-rouiter)#redistribute ospf 1 metric 10
Router_B(config-router)#network 172.17.0.0

「redistribute ospf 1 metric 10」と指定することで、シードメトリック値を「10」に設定します。


◆ABRルータの設定(Router_E)

OSPFを起動させるには、グローバル設定モードで「router ospf」コマンドを入力します。

Router(config)#router ospf [プロセス番号]
Router(config-router)#network [network] [wildcard] area 0
Router(config-router)#network [network] [wildcard] area [area-id]

プロセス番号: 1〜65535

 ABRは、バックボーンエリアと接続するわけですから、networkコマンドで、「area 0」の指定は必須です。後は、接続するエリアを追加してゆくだけです。

 プロセス番号は、OSPFプロセスを管理する番号で、各ルータで合わせておく必要はありません。プロセス番号は、OSPFプロセスを管理するためのものです。IGRPやEIGRPのAS番号とは違います。また、エリア番号と合わせる要もありません。

Router_Bは、エリア0とエリア1の両方のトポロジデータベースを構築し、エリア間の通信を行います。

●Router_Eの設定

Router_E(config)#router ospf 1
Router_E(config-router)#network 172.20.0.0 0.0.255.255 area 0
Router_E(config-router)#network 172.21.0.0 0.0.255.255 area 1

Router_AのF0にPCを接続するのは、少々面倒です。
 強制的にインタフェースをUPさせるために、F0インタフェースで「no keepalive」コマンドを設定しておきます。


●Router_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface FastEthernet0
 ip address 172.16.0.1 255.255.0.0
 speed auto
 no keepalive
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
 no fair-queue
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
logging buffered 4096 debugging
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 bandwidth 64
 ip address 172.18.0.1 255.255.0.0
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router ospf 1
 redistribute rip metric 100 subnets
 network 172.18.0.0 0.0.255.255 area 0
!
router rip
 redistribute ospf 1 metric 10
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Cの設定
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_C
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface FastEthernet0
 ip address 172.19.0.1 255.255.0.0
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.18.0.2 255.255.0.0
 no fair-queue
 clockrate 64000
!
router ospf 1
 log-adjacency-changes
 network 172.18.0.0 0.0.255.255 area 0
 network 172.19.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end

●Router_Dの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_D
!
enable password cisco
!
interface Ethernet0
 ip address 172.19.0.2 255.255.0.0
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 ip address 172.20.0.1 255.255.0.0
 bandwidth 64
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router ospf 1
 network 172.19.0.0 0.0.255.255 area 0
 network 172.20.0.0 0.0.255.255 area 0
!
no ip classless
!
line con 0
line aux 0

line vty 0 4
 password cisco
 login
!
end

●Router_Eの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_E
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 172.21.0.1 255.255.0.0
!
interface Serial0
 ip address 172.20.0.2 255.255.0.0
 bandwidth 64
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router ospf 1
 network 172.20.0.0 0.0.255.255 area 0
 network 172.21.0.0 0.0.255.255 area 1
!
ip classless
logging buffered
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Fの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_F
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 172.21.0.2 255.255.0.0
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
!
router ospf 1
 network 172.21.0.0 0.0.255.255 area 1
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_Fでルーティングテーブルを確認をしてみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

O IA 172.20.0.0/16 [110/1572] via 172.21.0.1, 00:10:54, Ethernet0
C    172.21.0.0/16 is directly connected, Ethernet0
O E2 172.16.0.0/16 [110/100] via 172.21.0.1, 00:10:54, Ethernet0
O E2 172.17.0.0/16 [110/100] via 172.21.0.1, 00:10:54, Ethernet0
O IA 172.18.0.0/16 [110/3144] via 172.21.0.1, 00:10:54, Ethernet0
O IA 172.19.0.0/16 [110/1582] via 172.21.0.1, 00:10:54, Ethernet0

 黄色の網掛けのルートは、「IA」と表示されていることから、OSPFによるルートで、他エリアの経路情報であることが分かります。

 また、水色の網掛けのルートは、「E2」と表示されていることから、外部ネットワークの経路情報であることが分かります。

 次の「マルチエリアOSPF(LSAの種類)」では、OSPFネットワーク内でやり取りされるLSAの種類について紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆マルチエリアOSPF

マルチエリアOSPFとは
マルチエリアOSPF(エリアの概念)
マルチエリアOSPF(ABR・ASBRの設定)
マルチエリアOSPF(ABRの設定例)
マルチエリアOSPF(LSAの種類)
マルチエリアOSPF(ネットワークLSA)
マルチエリアOSPF(ASBRサマリーLSA)
マルチエリアOSPF(NSSA外部LSA)
マルチエリアOSPF(エリアの種類)
マルチエリアOSPF(標準エリアとは)
マルチエリアOSPF(トータリースタブエリアとは)
マルチエリアOSPF(トータリーNSSAとは)
マルチエリアOSPF(標準エリア設定)
マルチエリアOSPF(トータリースタブエリア設定)
マルチエリアOSPF(トータリーNSSA設定)
マルチエリアOSPF(集約ルートの設定)
OSPF(確認コマンド)
マルチエリアOSPF(OSPFの問題点)
マルチエリアOSPF(OSPFルータの種類)
マルチエリアOSPF(ASBRの設定例)
マルチエリアOSPF(ABR・ASBR混在設定例)
マルチエリアOSPF(ルータLSA)
マルチエリアOSPF(ネットワークサマリーLSA)
マルチエリアOSPF(AS外部LSA)
マルチエリアOSPF(マルチエリア構成例)
マルチエリアOSPF(バックボーンエリアとは)
マルチエリアOSPF(スタブエリアとは)
マルチエリアOSPF(NSSAとは)
マルチエリアOSPF(OSPF用語まとめ)
マルチエリアOSPF(スタブエリア設定)
マルチエリアOSPF(NSSA設定)
マルチエリアOSPF(仮想リンク設定)
OSPF(show ip ospf database)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.