@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > マルチエリアOSPF(AS外部LSA:LSAタイプ5)

 Amazon

@network Cisco・アライド実機で学ぶ
◆マルチエリアOSPF(AS外部LSA:LSAタイプ5)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆LSAタイプ5(AS外部LSA)

 LSAタイプ5は、AS外部LSAとも言い、ASBRが生成します。ASBRは、非OSPFネットワークと接続するOSPFルータです。ASBRは、LSAタイプ5(AS外部LSA)を使って非OSPFネットワークの経路情報をOSPFドメインに通知します。

 LSAタイプ5で通知される情報は、非OSPFネットワークのネットワークアドレス、サブネットマスク、メトリック、転送アドレスです。ASBRは、OSPFと非OSPFを接続することになりますから、再配送の設定を行います。その際、シードメトリックを指定します。このシードメトリックがメトリックになります。

再配送に関しては、以下のコンテンツで紹介しています。

ルート再配送(シードメトリック)

 AS外部ルートのメトリックは、固定で通知することも、増加させて通知させることもできます。デフォルトでは固定で通知されます。固定で通知されるルートには「E2」が、増加させて通知されるルートには「E1」とマークされます。再配送でメトリックのタイプを指定できます。

LSAタイプ5は、スタブエリアを除いて、OSPFドメイン全体に通知されます。

スタブエリアとは、外部ネットワークがデフォルトルートとして通知されるエリアのことです。

スタブエリアでは、LSAタイプ4、LSAタイプ5をブロックします。

つまり、スタブエリアでは、

LSAタイプ4 : ASBRへの経路
LSAタイプ5 : AS外部の経路

がブロックされます。

 LSAタイプ5で通知される情報は、非OSPFネットワークのネットワークアドレス、サブネットマスク、メトリック、転送アドレスです。 転送アドレス(Forward Address)には、「0.0.0.0」もしくは、転送先のネクストホップアドレスになります。



転送アドレスは、別のルータのIPアドレスを指定することで余計な追加ホップを避ることができます。

 ルータが、宛先の同じLSAタイプ5を受信した時、フォワーディングアドレスへのメトリックに基づいて比較を行います。小さいメトリックのフォワーディングアドレスを持つLSAがルーティング テーブルの中に追加されます

 転送アドレス(Forward Address)がどのように決定されるのかは、複数の条件から成り立ちます。詳細については、Ciscoのサイトで調べてみて下さい。


◆LSAタイプ5を確認する(その1)

LSAタイプ5のネットワークLSAを確認するには、「show ip ospf database external」で確認できます。

Router#show ip ospf database external

マルチエリアOSPF(ABR・ASBR混在設定例)」で構築したネットワークを利用して確認してみます。

LSAタイプ5をRouter_Fで確認してみます。



Router_F上で「show ip ospf database external」コマンドを実行します。

●Router_F上での「show ip ospf database external」コマンドの実行結果
Router_F#show ip ospf database external

       OSPF Router with ID (172.21.0.2) (Process ID 1)


                AS External Link States

  Routing Bit Set on this LSA
  LS age: 86
  Options: (No TOS-capability)
  LS Type: AS External Link
  Link State ID: 172.16.0.0 (External Network Number )
  Advertising Router: 172.18.0.1
  LS Seq Number: 80000001
  Checksum: 0xDCF6
  Length: 36
  Network Mask: /16
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 100
        Forward Address: 0.0.0.0
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 74
  Options: (No TOS-capability)
  LS Type: AS External Link
  Link State ID: 172.17.0.0 (External Network Number )
  Advertising Router: 172.18.0.1
  LS Seq Number: 80000001
  Checksum: 0xD002
  Length: 36
  Network Mask: /16
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 100
        Forward Address: 0.0.0.0
        External Route Tag: 0

上の出力を見れば分かるように、ASBRのルータIDとASBRへのメトリック、転送アドレスが確認できます。

黄色の網掛け部分に注目してみて下さい。

Forward Address: 0.0.0.0

転送アドレスが、「0.0.0.0」になっています。


◆LSAタイプ5を確認する(その2)

 次に、下の図のようなネットワークを構築してみます。先ほどとの違いは、通知される転送アドレスが、転送先のネクストホップアドレスになるとところです。


 上の図のようなネットワーク構成にするため、下の図のようにネットワークを再構築しなおします。変更するのは、Router_AとRouter_Bだけです。

<Router_Aの変更>
・S0の設定を削除してLoopback0にIPアドレスを設定します。
・F0をRouter_BのF0と接続します。
・RIPの設定を削除します。
・デフォルトルートを追加します。

<Router_Bの変更>
・S0の設定を削除して換わりにF0にIPアドレスを設定します。
・スタティックルートの再配送の設定を行います。
・RIPの設定を削除します。



●Router_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 172.16.0.1 255.255.0.0
!
interface FastEthernet0
 ip address 172.17.0.1 255.255.0.0
 speed auto
 no keepalive
!
interface Serial0
 bandwidth 64
 no ip address
 shutdown
 clockrate 64000
 no fair-queue
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.0.2
no ip http server
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
logging buffered 4096 debugging
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 bandwidth 64
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 bandwidth 64
 ip address 172.18.0.1 255.255.0.0
!
interface FastEthernet0
 ip address 172.17.0.2 255.255.0.0
 speed auto
!
router ospf 1
 redistribute static subnets
 network 172.17.0.0 0.0.255.255 area 0
 network 172.18.0.0 0.0.255.255 area 0
!
ip classless
ip route 172.16.0.0 255.255.0.0 172.17.0.1
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end


Router_F上で「show ip ospf database external」コマンドを実行します。

●Router_F上での「show ip ospf database external」コマンドの実行結果
Router_F#show ip ospf database external

       OSPF Router with ID (172.21.0.2) (Process ID 1)


                AS External Link States

  Routing Bit Set on this LSA
  LS age: 1414
  Options: (No TOS-capability)
  LS Type: AS External Link
  Link State ID: 172.16.0.0 (External Network Number )
  Advertising Router: 172.18.0.1
  LS Seq Number: 80000002
  Checksum: 0xFD66
  Length: 36
  Network Mask: /16
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 172.17.0.1
        External Route Tag: 0

上の出力を見れば分かるように、ASBRのルータIDとASBRへのメトリック、転送アドレスが確認できます。

黄色の網掛け部分に注目してみて下さい。

Forward Address: 172.17.0.1

転送アドレスが、「172.17.0.1」になっています。転送先のネクストホップアドレスになっています。

次の「マルチエリアOSPF(NSSA外部LSA」では、LSAタイプ7について説明します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆マルチエリアOSPF

マルチエリアOSPFとは
マルチエリアOSPF(エリアの概念)
マルチエリアOSPF(ABR・ASBRの設定)
マルチエリアOSPF(ABRの設定例)
マルチエリアOSPF(LSAの種類)
マルチエリアOSPF(ネットワークLSA)
マルチエリアOSPF(ASBRサマリーLSA)
マルチエリアOSPF(NSSA外部LSA)
マルチエリアOSPF(エリアの種類)
マルチエリアOSPF(標準エリアとは)
マルチエリアOSPF(トータリースタブエリアとは)
マルチエリアOSPF(トータリーNSSAとは)
マルチエリアOSPF(標準エリア設定)
マルチエリアOSPF(トータリースタブエリア設定)
マルチエリアOSPF(トータリーNSSA設定)
マルチエリアOSPF(集約ルートの設定)
OSPF(確認コマンド)
マルチエリアOSPF(OSPFの問題点)
マルチエリアOSPF(OSPFルータの種類)
マルチエリアOSPF(ASBRの設定例)
マルチエリアOSPF(ABR・ASBR混在設定例)
マルチエリアOSPF(ルータLSA)
マルチエリアOSPF(ネットワークサマリーLSA)
マルチエリアOSPF(AS外部LSA)
マルチエリアOSPF(マルチエリア構成例)
マルチエリアOSPF(バックボーンエリアとは)
マルチエリアOSPF(スタブエリアとは)
マルチエリアOSPF(NSSAとは)
マルチエリアOSPF(OSPF用語まとめ)
マルチエリアOSPF(スタブエリア設定)
マルチエリアOSPF(NSSA設定)
マルチエリアOSPF(仮想リンク設定)
OSPF(show ip ospf database)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.