@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > マルチエリアOSPF(NSSA設定)

 Amazon

@network Cisco・アライド実機で学ぶ
◆マルチエリアOSPF(NSSA設定)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆マルチエリアOSPF(NSSA設定)

 ここで、使用するネットワークは、「マルチエリアOSPF(マルチエリア構成例)」で構築したネットワークを拡張して追加の設定を行ってゆきます。

まずは、以下のネットワークを構築します。

エリアをNSSAで構築する際は、注意が必要です。

ルータの種類とIOSバージョンの組み合わせ次第で、NSSAがサポートされていない場合があります。

ちなみに、管理人が所有するCisco2500とIOSの組み合わせでは、NSSAが構築できませんでした。

 そこで、Router_EとRouter_FをCisco2600と交換します。NSSAがサポートされていれば、交換する必要はありません。

※ちなみに、後ほど、IOSを「c2500-d-l.112-4.bin」にアップグレードしたところ、Cisco2500シリーズのルータでNSSAがサポートされていることが確認できました。

ルータの設定はこちらで紹介しています。 → 「マルチエリアOSPF(マルチエリア構成例)


ルータの設定は、以下のリンク先で確認して下さい。

マルチエリアOSPF(マルチエリア構成例)




Router_EとRouter_Fを交換した場合、ルータのコンフィグは、以下のようになります。

●Router_Eの設定
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_E
!
logging buffered 4096 debugging
enable password cisco
!
ip subnet-zero
!
interface Ethernet0/0
 ip address 172.21.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Serial0/0
 bandwidth 64
 ip address 172.20.0.2 255.255.0.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 172.20.0.0 0.0.255.255 area 0
 network 172.21.0.0 0.0.255.255 area 1
!
ip classless
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end

●Router_Fの設定
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_F
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0/0
 ip address 172.21.0.2 255.255.0.0
 no ip directed-broadcast
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 172.21.0.0 0.0.255.255 area 1
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


そして、エリア1にRIPネットワークを接続します。ネットワークの構成は、下の図のようになります。


●Router_Fの追加設定

LoopBack0にIPアドレスを割り当てます。

Router_F(config)#int loopback 0
Router_F(config-if)#ip address 192.168.65.1 255.255.255.0


Router_Fで再配送の設定とRIPの設定を行います。

Router_F(config)#router ospf 1
Router_F(config-router)#redistribute rip metric 100 subnets
Router_F(config-router)#exit
Router_F(config)#router rip
Router_F(config-router)#network 192.168.65.0
Router_F(config-router)#exit


◆NSSAの設定

エリア1をNSSAにするにはには、以下のように設定します。

Router(config)#router ospf [プロセス番号]
Router(config-router)#area [area-id] nssa


エリア1をNSSAとして設定してゆきます。

Router_Eで、エリア1をNSSAに指定します。

Router_E(config)#router ospf 1
Router_E(config-router)#area 1 nssa

Router_Fで、エリア1をNSSAに指定します。

Router_F(config)#router ospf 1
Router_F(config-router)#area 1 nssa


Router_Eのルーティングテーブルを確認してみます。

●Router_Eのルーティングテーブル
Gateway of last resort is not set

O E2 172.17.0.0/16 [110/100] via 172.20.0.1, 00:00:53, Serial0/0
O    172.19.0.0/16 [110/1572] via 172.20.0.1, 00:00:53, Serial0/0
O    172.18.0.0/16 [110/3134] via 172.20.0.1, 00:00:53, Serial0/0
C    172.21.0.0/16 is directly connected, Ethernet0/0
C    172.20.0.0/16 is directly connected, Serial0/0
O E2 192.168.4.0/24 [110/100] via 172.20.0.1, 00:00:53, Serial0/0
O N2 192.168.65.0/24 [110/100] via 172.21.0.2, 00:00:53, Ethernet0/0
     192.168.36.0/32 is subnetted, 1 subnets
O IA    192.168.36.1 [110/1563] via 172.20.0.1, 00:00:53, Serial0/0
     192.168.34.0/32 is subnetted, 1 subnets
O IA    192.168.34.1 [110/1563] via 172.20.0.1, 00:00:54, Serial0/0
     192.168.35.0/32 is subnetted, 1 subnets
O IA    192.168.35.1 [110/1563] via 172.20.0.1, 00:00:54, Serial0/0
O E2 192.168.1.0/24 [110/100] via 172.20.0.1, 00:00:54, Serial0/0
O E2 192.168.2.0/24 [110/100] via 172.20.0.1, 00:00:55, Serial0/0
O E2 192.168.3.0/24 [110/100] via 172.20.0.1, 00:00:55, Serial0/0
     192.168.33.0/32 is subnetted, 1 subnets
O IA    192.168.33.1 [110/1563] via 172.20.0.1, 00:00:55, Serial0/00

「N2」は、NSSAの経路情報であることを示しています。

NSSAがどんなエリアだったのか、思い出してみましょう。

NSSAは、外部ネットワークを接続できるようにしたスタブエリアのことです。

 スタブエリア内には、ASBRを配置できないという制限があるため、スタブエリアにASBRを配置できるようにしたのがNSSAです。

 NSSA内に配置されたASBRは、LSAタイプ5ではなく、LSAタイプ7を送信します。LSAタイプ7は、別のエリアには、流れません。

そこで、NSSA内のABRは、

LSAタイプ7 → LSAタイプ5
       (変換)
LSAタイプ7をLSAタイプ5に変換してフラッディングします。


◆LSDBの確認

それでは、Rotuer_EでLSDBを表示して確認します。

●Rotuer_Eのトポロジデータベース
Router_E#show ip ospf database

       OSPF Router with ID (172.21.0.1) (Process ID 1)


                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
172.18.0.1      172.18.0.1      471         0x80000003 0xCD54   2
172.19.0.1      172.19.0.1      443         0x80000004 0xF39A   3
172.21.0.1      172.21.0.1      488         0x80000002 0x63E5   2
192.168.36.1    192.168.36.1    443         0x80000005 0x4799   3

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.19.0.2      192.168.36.1    443         0x80000001 0xB8F

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.21.0.0      172.21.0.1      439         0x80000003 0x6745
192.168.33.1    192.168.36.1    504         0x80000001 0x5CC5
192.168.34.1    192.168.36.1    494         0x80000001 0x51CF
192.168.35.1    192.168.36.1    494         0x80000001 0x46D9
192.168.36.1    192.168.36.1    495         0x80000001 0x3BE3

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
172.21.0.1      172.21.0.1      450         0x80000002 0x9084   1
192.168.65.1    192.168.65.1    451         0x80000002 0xC37F   1

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
172.21.0.1      172.21.0.1      450         0x80000001 0xB28D

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
172.18.0.0      172.21.0.1      436         0x80000001 0xABBF
172.19.0.0      172.21.0.1      431         0x80000003 0x6028
172.20.0.0      172.21.0.1      486         0x80000001 0xF39F
192.168.33.1    172.21.0.1      486         0x80000001 0x8B3C
192.168.34.1    172.21.0.1      486         0x80000001 0x8046
192.168.35.1    172.21.0.1      486         0x80000001 0x7550
192.168.36.1    172.21.0.1      487         0x80000001 0x6A5A

                Type-7 AS External Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.65.0    192.168.65.1    465         0x80000001 0xA08B   0

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
172.17.0.0      172.18.0.1      514         0x80000001 0xD002   0
192.168.1.0     172.18.0.1      470         0x80000001 0xA580   0
192.168.2.0     172.18.0.1      470         0x80000001 0x9A8A   0
192.168.3.0     172.18.0.1      470         0x80000001 0x8F94   0
192.168.4.0     172.18.0.1      470         0x80000001 0x849E   0
192.168.65.0    172.21.0.1      437         0x80000001 0x4FCF   0

上の黄色と水色の網掛けを見て下さい。

「192.168.65.0」が、LSAタイプ7とLSAタイプ5の経路情報して存在します。

つまり、Router_Eで、LSAタイプ7をLSAタイプ5に変換していることが分かります。

Rotuer_Dでルーティングテーブルを表示してみます。

●Rotuer_Dのルーティングテーブル
Gateway of last resort is not set

O E2 192.168.65.0/24 [110/100] via 172.20.0.2, 00:16:15, Serial0
C    192.168.33.0/24 is directly connected, Loopback0
C    192.168.34.0/24 is directly connected, Loopback1
C    192.168.35.0/24 is directly connected, Loopback2
C    192.168.36.0/24 is directly connected, Loopback3
O E2 192.168.1.0/24 [110/100] via 172.19.0.1, 00:16:15, Ethernet0
O E2 192.168.2.0/24 [110/100] via 172.19.0.1, 00:16:15, Ethernet0
O E2 192.168.3.0/24 [110/100] via 172.19.0.1, 00:16:15, Ethernet0
O E2 192.168.4.0/24 [110/100] via 172.19.0.1, 00:16:15, Ethernet0
C    172.20.0.0/16 is directly connected, Serial0
O IA 172.21.0.0/16 [110/1572] via 172.20.0.2, 00:16:15, Serial0
O E2 172.17.0.0/16 [110/100] via 172.19.0.1, 00:16:15, Ethernet0
O    172.18.0.0/16 [110/1572] via 172.19.0.1, 00:16:15, Ethernet0
C    172.19.0.0/16 is directly connected, Ethernet0

 Router_Dで、「192.168.65.0」は、「E2」で表示されています。つまり、OSPF外部の経路情報であることを表しています。

ところが、

Router_Fでルーティングテーブルを確認してみます。

●Rotuer_Fのルーティングテーブル
Gateway of last resort is not set

O IA 172.19.0.0/16 [110/1582] via 172.21.0.1, 00:18:52, Ethernet0/0
O IA 172.18.0.0/16 [110/3144] via 172.21.0.1, 00:18:57, Ethernet0/0
C    172.21.0.0/16 is directly connected, Ethernet0/0
O IA 172.20.0.0/16 [110/1572] via 172.21.0.1, 00:19:05, Ethernet0/0
C    192.168.65.0/24 is directly connected, Loopback0
     192.168.36.0/32 is subnetted, 1 subnets
O IA    192.168.36.1 [110/1573] via 172.21.0.1, 00:19:05, Ethernet0/0
     192.168.34.0/32 is subnetted, 1 subnets
O IA    192.168.34.1 [110/1573] via 172.21.0.1, 00:19:05, Ethernet0/0
     192.168.35.0/32 is subnetted, 1 subnets
O IA    192.168.35.1 [110/1573] via 172.21.0.1, 00:19:05, Ethernet0/0
     192.168.33.0/32 is subnetted, 1 subnets
O IA    192.168.33.1 [110/1573] via 172.21.0.1, 00:19:05, Ethernet0/0

 「192.168.1.0/24」、「192.168.2.0/24」、「192.168.3.0/24」、「192.168.4.0/24」のルートがありません。他の外部エリアにある外部ネットワーク(非OSPFネットワーク)の経路情報がありません。

NSSAでは、自分の外部ネットワークの情報は、

LSAタイプ7 → LSAタイプ5
       (変換)
LSAタイプ7をLSAタイプ5に変換してフラッディングします。

 NSSAでは、自分のエリアの外部経路情報の通知を行いますが、他の外部ネットワークの経路情報は、ブロックします。外部からのLSAタイプ5はブロックしてしまうのです。

 外部ネットワークの経路情報をNSSA内に通知するには、NSSA内のABRにデフォルトルートを通知するように設定を行う必要があります。


◆デフォルトルートの通知

Router_Eに外部ネットワークの経路情報をデフォルトルートで通知するように設定を行います。

 「area [area-id] nssa default-information-originate」コマンドで自分のエリア内でない外部の経路情報をLSAタイプ7で通知できるようになります。

●Router_Eの設定

Router_E(config)#router ospf 1
Router_E(config-router)#area 1 nssa default-information-originate


Router_Fでルーティングテーブルを確認してみます。

●Rotuer_Fのルーティングテーブル
Gateway of last resort is 172.21.0.1 to network 0.0.0.0

O IA 172.19.0.0/16 [110/1582] via 172.21.0.1, 00:00:13, Ethernet0/0
O IA 172.18.0.0/16 [110/3144] via 172.21.0.1, 00:00:13, Ethernet0/0
C    172.21.0.0/16 is directly connected, Ethernet0/0
O IA 172.20.0.0/16 [110/1572] via 172.21.0.1, 00:00:13, Ethernet0/0
C    192.168.65.0/24 is directly connected, Loopback0
     192.168.36.0/32 is subnetted, 1 subnets
O IA    192.168.36.1 [110/1573] via 172.21.0.1, 00:00:13, Ethernet0/0
     192.168.34.0/32 is subnetted, 1 subnets
O IA    192.168.34.1 [110/1573] via 172.21.0.1, 00:00:13, Ethernet0/0
     192.168.35.0/32 is subnetted, 1 subnets
O IA    192.168.35.1 [110/1573] via 172.21.0.1, 00:00:13, Ethernet0/0
     192.168.33.0/32 is subnetted, 1 subnets
O IA    192.168.33.1 [110/1573] via 172.21.0.1, 00:00:13, Ethernet0/0
O*N2 0.0.0.0/0 [110/1] via 172.21.0.1, 00:00:13, Ethernet0/0

黄色の網掛けから分かるように、デフォルトルートを受け取っています。

Rotuer_FでLSDBを表示して確認します。

●Rotuer_Fのトポロジデータベース
Router_F#show ip ospf database

       OSPF Router with ID (192.168.65.1) (Process ID 1)


                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
172.21.0.1      172.21.0.1      136         0x80000004 0x967B   1
192.168.65.1    192.168.65.1    132         0x80000004 0xC976   1

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
172.21.0.2      192.168.65.1    136         0x80000001 0xEA6B

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
172.18.0.0      172.21.0.1      1830        0x80000001 0xABBF
172.19.0.0      172.21.0.1      1824        0x80000003 0x6028
172.20.0.0      172.21.0.1      1879        0x80000001 0xF39F
192.168.33.1    172.21.0.1      1879        0x80000001 0x8B3C
192.168.34.1    172.21.0.1      1879        0x80000001 0x8046
192.168.35.1    172.21.0.1      1879        0x80000001 0x7550
192.168.36.1    172.21.0.1      1880        0x80000001 0x6A5A

                Type-7 AS External Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         172.21.0.1      146         0x80000001 0x4CA2   0
192.168.65.0    192.168.65.1    1858        0x80000001 0xA08B   0

上の黄色の網掛けを見れば分かるように、「0.0.0.0」の経路情報をLSAタイプ7で受け取っていることが分かります。

 つまり、NSSA内のABRで「default-information-originate」コマンドを使うことで、外部宛のデフォルトルートがLSAタイプ7で通知されるようになります。

LSAタイプ5(OSPFドメインから) → LSAタイプ7(NSSA内へ)
                    (変換)



Router_FがNSSAに所属しているかどうかは、「show ip ospf」コマンドで確認することができます。

●Rotuer_Fの所属するエリアの確認
Router_F#show ip ospf
 Routing Process "ospf 1" with ID 192.168.65.1
 Supports only single TOS(TOS0) routes
 It is an autonomous system boundary router
 Redistributing External Routes from,
    rip with metric mapped to 100, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 1. 0 normal 0 stub 1 nssa
    Area 1
        Number of interfaces in this area is 1
        It is a NSSA area
        Area has no authentication
        SPF algorithm executed 5 times
        Area ranges are
        Number of LSA 12. Checksum Sum 0x71243
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0

黄色の網掛けから分かるように、Router_Fは、NSSAに所属していることが分かります。


次の「マルチエリアOSPF(トータリースタブNSSA設定)」では、トータリースタブNSSAの設定例を紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆マルチエリアOSPF

マルチエリアOSPFとは
マルチエリアOSPF(エリアの概念)
マルチエリアOSPF(ABR・ASBRの設定)
マルチエリアOSPF(ABRの設定例)
マルチエリアOSPF(LSAの種類)
マルチエリアOSPF(ネットワークLSA)
マルチエリアOSPF(ASBRサマリーLSA)
マルチエリアOSPF(NSSA外部LSA)
マルチエリアOSPF(エリアの種類)
マルチエリアOSPF(標準エリアとは)
マルチエリアOSPF(トータリースタブエリアとは)
マルチエリアOSPF(トータリーNSSAとは)
マルチエリアOSPF(標準エリア設定)
マルチエリアOSPF(トータリースタブエリア設定)
マルチエリアOSPF(トータリーNSSA設定)
マルチエリアOSPF(集約ルートの設定)
OSPF(確認コマンド)
マルチエリアOSPF(OSPFの問題点)
マルチエリアOSPF(OSPFルータの種類)
マルチエリアOSPF(ASBRの設定例)
マルチエリアOSPF(ABR・ASBR混在設定例)
マルチエリアOSPF(ルータLSA)
マルチエリアOSPF(ネットワークサマリーLSA)
マルチエリアOSPF(AS外部LSA)
マルチエリアOSPF(マルチエリア構成例)
マルチエリアOSPF(バックボーンエリアとは)
マルチエリアOSPF(スタブエリアとは)
マルチエリアOSPF(NSSAとは)
マルチエリアOSPF(OSPF用語まとめ)
マルチエリアOSPF(スタブエリア設定)
マルチエリアOSPF(NSSA設定)
マルチエリアOSPF(仮想リンク設定)
OSPF(show ip ospf database)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.