@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > マルチエリアOSPF(集約ルートの設定)

 Amazon

@network Cisco・アライド実機で学ぶ
◆マルチエリアOSPF(集約ルートの設定)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆マルチエリアOSPF(集約ルートの設定)

 ここでは、OSPFネットワークにおけるルート集約の設定を紹介します。ルーと集約によってルーティングテーブルのエントリ数を減らして、ルータの負荷を軽減させることができます。

使用するネットワークは、下図のようになります。


まずは、ルート集約を行わないで、上図のネットワークをOSPFで設定してゆきます。

Router_CのF0は、「no keepalive」で強制的にUPさせておきます。

ルータの設定は、以下のようになります。

●Rotuer_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.3.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.1 255.255.0.0
 no fair-queue
!
router ospf 1
 log-adjacency-changes
 network 172.17.0.0 0.0.255.255 area 1
 network 192.168.1.0 0.0.0.255 area 1
 network 192.168.2.0 0.0.0.255 area 1
 network 192.168.3.0 0.0.0.255 area 1
 network 192.168.4.0 0.0.0.255 area 1
!
ip classless
no ip http server
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Rotuer_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
 clockrate 64000
!
interface Serial1
 bandwidth 64
 ip address 172.18.0.1 255.255.0.0
 clockrate 64000
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router ospf 1
 network 172.17.0.0 0.0.255.255 area 1
 network 172.18.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Rotuer_Cの設定
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_C
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Loopback0
 no ip address
!
interface FastEthernet0
 ip address 172.19.0.1 255.255.0.0
 no keepalive
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.18.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 172.18.0.0 0.0.255.255 area 0
 network 172.19.0.0 0.0.255.255 area 2
!
ip classless
no ip http server
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


Router_Cのルーティングテーブルを表示します。

●Router_Cのルーティングテーブル
Gateway of last resort is not set

O IA 172.17.0.0/16 [110/3124] via 172.18.0.1, 00:02:34, Serial0
C    172.19.0.0/16 is directly connected, FastEthernet0
C    172.18.0.0/16 is directly connected, Serial0
     192.168.4.0/32 is subnetted, 1 subnets
O IA    192.168.4.1 [110/3125] via 172.18.0.1, 00:02:34, Serial0
     192.168.1.0/32 is subnetted, 1 subnets
O IA    192.168.1.1 [110/3125] via 172.18.0.1, 00:02:34, Serial0
     192.168.2.0/32 is subnetted, 1 subnets
O IA    192.168.2.1 [110/3125] via 172.18.0.1, 00:02:34, Serial0
     192.168.3.0/32 is subnetted, 1 subnets
O IA    192.168.3.1 [110/3125] via 172.18.0.1, 00:02:34, Serial0

 上の黄色の網掛けから分かるように、「192.168.1.0」、「192.168.2.0」、「192.168.3.0」、「192.168.4.0」の経路情報が、流れてきています。

 そこで、「192.168.1.0」、「192.168.2.0」、「192.168.3.0」、「192.168.4.0」の経路情報を「192.168.0.0」の集約経路で流すように変更してゆきます。


◆集約経路の設定

 特定のエリア内にある経路を集約するには、「area area_id range」コマンドを使ってIPアドレスの範囲を指定します。

Router(config)#router ospf [プロセス番号]
Router(config-router)#area [area_id] range [IPアドレス] [サブネットマスク]]


●Router_Bの設定

Router_B上で、集約ルートの設定を行います。

 「192.168.1.0」、「192.168.2.0」、「192.168.3.0」、「192.168.4.0」の経路情報を「192.168.0.0」の集約経路で流すように設定を行います。

outer(config)#router ospf [プロセス番号]
Router(config-router)#area 1 range 192.168.0.0 255.255.0.0


Router_Cのルーティングテーブルを表示します。

●Router_Cのルーティングテーブル
Gateway of last resort is not set

O IA 172.17.0.0/16 [110/3124] via 172.18.0.1, 00:35:06, Serial0
C    172.19.0.0/16 is directly connected, FastEthernet0
C    172.18.0.0/16 is directly connected, Serial0
O IA 192.168.0.0/16 [110/3125] via 172.18.0.1, 00:00:29, Serial0

 上の黄色の網掛けから分かるように、「192.168.1.0」、「192.168.2.0」、「192.168.3.0」、「192.168.4.0」の経路情報が、「192.168.0.0/16」として流れてきているのが分かります。


 次の「OSPF(show ip ospf database)」では、OSPFのLSDBを表示して、データベース内にある情報について確認します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆マルチエリアOSPF

マルチエリアOSPFとは
マルチエリアOSPF(エリアの概念)
マルチエリアOSPF(ABR・ASBRの設定)
マルチエリアOSPF(ABRの設定例)
マルチエリアOSPF(LSAの種類)
マルチエリアOSPF(ネットワークLSA)
マルチエリアOSPF(ASBRサマリーLSA)
マルチエリアOSPF(NSSA外部LSA)
マルチエリアOSPF(エリアの種類)
マルチエリアOSPF(標準エリアとは)
マルチエリアOSPF(トータリースタブエリアとは)
マルチエリアOSPF(トータリーNSSAとは)
マルチエリアOSPF(標準エリア設定)
マルチエリアOSPF(トータリースタブエリア設定)
マルチエリアOSPF(トータリーNSSA設定)
マルチエリアOSPF(集約ルートの設定)
OSPF(確認コマンド)
マルチエリアOSPF(OSPFの問題点)
マルチエリアOSPF(OSPFルータの種類)
マルチエリアOSPF(ASBRの設定例)
マルチエリアOSPF(ABR・ASBR混在設定例)
マルチエリアOSPF(ルータLSA)
マルチエリアOSPF(ネットワークサマリーLSA)
マルチエリアOSPF(AS外部LSA)
マルチエリアOSPF(マルチエリア構成例)
マルチエリアOSPF(バックボーンエリアとは)
マルチエリアOSPF(スタブエリアとは)
マルチエリアOSPF(NSSAとは)
マルチエリアOSPF(OSPF用語まとめ)
マルチエリアOSPF(スタブエリア設定)
マルチエリアOSPF(NSSA設定)
マルチエリアOSPF(仮想リンク設定)
OSPF(show ip ospf database)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.