@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > ルート再配送(connected)

 Amazon

@network Cisco・アライド実機で学ぶ
◆ルート再配送(connected)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆ルート再配送(connected)

下の図のRIP、OSPFで構成されたネットワークで再配送の設定を行い、通信できるようにします。



まずは、RIP、OSPF間でルーティングができるように設定してゆきます。

●Router_Aのルーティングの設定

Router_A(config)#router rip
Router_A(config-router)#network 172.17.0.0

●Router_Bのルーティングの設定

・RIPルートの再配送
RIPで学習したルートをOSPFへ再配送するように以下のように設定します。
※設定を省略した場合でも、デフォルトのシードメトリック値である「20」が使われるので、再配送は行われます。

Router_B(config)#router ospf 1
Router_B(config-router)#redistribute rip metric 100 subnets
Router_B(config-router)#network 172.18.0.0 0.0.255.255 area 0

 「redistribute rip metric 100 subnets」と指定することで、シードメトリック値に「100」を設定しています。「subnets」は、クラスレスルートを再配送させるためのオプションです。このオプションを指定することで、サブネット化された経路情報を再配送できるようになります。

OSPFネットワークへ再配送する際には、「subnets」を指定しておきます。

・OSPFルートの再配送
OSPFで学習したルートをRIPへ再配送するように以下のように設定します。

Router_B(config)#router rip
Router_B(config-rouiter)#redistribute ospf 1 metric 10
Router_B(config-router)#network 172.17.0.0

「redistribute ospf 1 metric 10」と指定することで、シードメトリック値を「10」に設定します。

●Router_Cのルーティングの設定

Router_C(config)#router ospf 1
Router_C(config-router)#network 172.18.0.0 0.0.255.255 area 0
Router_C(config-router)#network 172.19.0.0 0.0.255.255 area 0

Router_A、Router_CのF0にPCを接続するのは、少々面倒です。
 強制的にインタフェースをUPさせるために、F0インタフェースで「no keepalive」コマンドを設定しておきます。


●Router_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface FastEthernet0
 ip address 172.16.0.1 255.255.0.0
 speed auto
 no keepalive
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
 no fair-queue
!
router rip
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
logging buffered 4096 debugging
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 bandwidth 64
 ip address 172.18.0.1 255.255.0.0
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router ospf 1
 redistribute rip metric 100 subnets
 network 172.18.0.0 0.0.255.255 area 0
!
router rip
 redistribute ospf 1 metric 10
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Cの設定
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_C
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface FastEthernet0
 ip address 172.19.0.1 255.255.0.0
 no keepalive
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.18.0.2 255.255.0.0
 no fair-queue
 clockrate 64000
!
router ospf 1
 log-adjacency-changes
 network 172.18.0.0 0.0.255.255 area 0
 network 172.19.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


各ルータのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
C    172.16.0.0/16 is directly connected, FastEthernet0
R    172.19.0.0/16 [120/10] via 172.17.0.2, 00:00:12, Serial0
R    172.18.0.0/16 [120/10] via 172.17.0.2, 00:00:12, Serial0

OSPFネットワークの「172.18.0.0/16」、「172.19.0.0/16」ルートを学習しています。

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
O    172.19.0.0/16 [110/1563] via 172.18.0.2, 00:56:01, Serial1
C    172.18.0.0/16 is directly connected, Serial1

 当然ですが、「172.16.0.0/16」ルートがありません。「172.16.0.0/16」は、RIPネットワーク上にないからです。RIPルートの再配送を行っても、そもそも「172.16.0.0/16」は、RIPネットワークに存在しないわけです。

●Router_Cのルーティングテーブル
Gateway of last resort is not set

O E2 172.17.0.0/16 [110/100] via 172.18.0.1, 00:57:56, Serial0
C    172.19.0.0/16 is directly connected, FastEthernet0
C    172.18.0.0/16 is directly connected, Serial0

 Router_Bに「172.16.0.0/16」ルートがないわけですから、Router_Cのルーティングテーブルにも、「172.16.0.0/16」ルートは、存在しません。


◆「connected」オプションの指定

 そもそも、「172.16.0.0/16」ルートは、RIPネットワークに存在しないわけですから、Router_BもRouter_Cもこのネットワークの存在を知りようがありまえん。

 「172.16.0.0/16」ルートの存在を確認できるのは、Router_Aだけです。なぜならば、「172.16.0.0/16」ルートは、Router_Aに直接接続されているからです。

Route_Aのルーティングテーブルで「172.16.0.0/16」ルートを確認します。

C 172.16.0.0/16 is directly connected, FastEthernet0

「connected」となっているところに注目して下さい。

この直接接続されたルートをRIPで再配送します。

Router_B(config)#router rip
Router_B(config-rouiter)#redistribute connected

「connected」オプションを指定すると直接接続のルートを再配送するようになります。

各ルータのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
C    172.16.0.0/16 is directly connected, FastEthernet0
R    172.19.0.0/16 [120/10] via 172.17.0.2, 00:00:10, Serial0
R    172.18.0.0/16 [120/10] via 172.17.0.2, 00:00:10, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:25, Serial0
O    172.19.0.0/16 [110/1563] via 172.18.0.2, 01:24:42, Serial1
C    172.18.0.0/16 is directly connected, Serial1

「172.16.0.0/16」ルートを学習しています。

配送元が「connected」の場合、シードメトリック値は、1になっています。

R 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:25, Serial0

「connected」の場合、シードメトリック値の設定は、省略できます。

●Router_Cのルーティングテーブル
Gateway of last resort is not set

O E2 172.17.0.0/16 [110/100] via 172.18.0.1, 01:26:33, Serial0
O E2 172.16.0.0/16 [110/100] via 172.18.0.1, 00:03:23, Serial0
C    172.19.0.0/16 is directly connected, FastEthernet0
C    172.18.0.0/16 is directly connected, Serial0

「172.16.0.0/16」ルートを学習しています。

今回は、

Router_B(config-rouiter)#redistribute connected

 「subnets」オプションを指定しませんでしたが、クラスレスルーティングを行う場合は、「subnets」オプションの指定も忘れずに行っておく必要があります。

その際の指定は、下のようになります。
Router_B(config-rouiter)#redistribute connected (subnets)



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ルート再配送(redistribute)
ルート再配送(再配送の設定)
ルート再配送(シードメトリック)
ルート再配送(RIPとOSPF)
ルート再配送(ループバック活用例)
ルート再配送(connected)
ルート再配送(RIPとIGRP)
ルート再配送(RIPとEIGRP)
ルート再配送(IGRPとEIGRP)
ルート再配送(ルートマップ route-map)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.