@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > ルート再配送(再配送の設定)

 Amazon

@network Cisco・アライド実機で学ぶ
◆ルート再配送(再配送の設定)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆ルート再配送(再配送の設定)

引き続き、「ルート再配送(redistribute)」で使用したネットワーク構成図を使います。


ルート再配送の設定を行うには「redistribute」コマンドを使用します。

●redistributeコマンド

ルータコンフィグレーションモードで入力します。コマンドの構文は以下のようになります。

 再配送の設定は、非常に癖が強いので、お手持ちの実機とIOSのバージョンによって異なる動作をするかもしれません。管理人が所有するCisco2500とCisco1700では、異なる動作をしました。オプションの指定の省略時のデフォルトの動作についても注意が必要です。

ちなみに、今回の実機確認においては、Cisco1720とCisco1721を使用しております。

Router(config)#router [protocol1]
Router(config-router)#redistribute [protocol2]

protocol1 : 再配送先(再配送に使うプロトコル)
protocol2 : 再配送元

「protocol2」で取得したルートを「protocol1」で再配送する。

※ルーティングプロトコルによって「protocol1」「protocol2」の後の指定の仕方が変わってきます。

上のネットワーク構成の場合は、下の図のようになります。


●Router_Bの再配布の設定

Router_B(config)#router ospf 1
Router_B(config-router)#redistribute rip
Router_B(config-router)#network 172.18.0.0 0.0.255.255 area 0
Router_B(config-router)#exit
Router_B(config)#router rip
Router_B(config-router)#redistribute ospf 1
Router_B(config-router)#network 172.17.0.0


再配布の設定が分かったところで、ルータを設定してゆきましょう!

Router_A、Router_CのF0にPCを接続するのは、少々面倒です。
 強制的にインタフェースをUPさせるために、F0インタフェースで「no keepalive」コマンドを設定しておきます。


●Router_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface FastEthernet0
 ip address 172.16.0.1 255.255.0.0
 speed auto
 no keepalive
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
 no fair-queue
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
logging buffered 4096 debugging
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 bandwidth 64
 ip address 172.18.0.1 255.255.0.0
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router ospf 1
 redistribute rip
 network 172.18.0.0 0.0.255.255 area 0
!
router rip
 redistribute ospf 1
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


●Router_Cの設定
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_C
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface FastEthernet0
 ip address 172.19.0.1 255.255.0.0
 no keepalive
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.18.0.2 255.255.0.0
 no fair-queue
 clockrate 64000
!
router ospf 1
 log-adjacency-changes
 network 172.18.0.0 0.0.255.255 area 0
 network 172.19.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


これで、再配布の設定ができたような気がしますが、実は落とし穴があります。

各ルータのルーティングテーブルを確認してみましょう!

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:02, Serial0
O    172.19.0.0/16 [110/1563] via 172.18.0.2, 00:17:12, Serial1
C    172.18.0.0/16 is directly connected, Serial1

全てのルートがルーティングテーブルに格納されています。


●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
C    172.16.0.0/16 is directly connected, FastEthernet0

 あれ!Router_Bで再配布の設定を行っているのに、OSPFネットワークのエントリー「172.18.0.0」、「172.19.0.0」がありません。

●Router_Cのルーティングテーブル

Gateway of last resort is not set

O E2 172.17.0.0/16 [110/20] via 172.18.0.1, 00:17:43, Serial0
O E2 172.16.0.0/16 [110/20] via 172.18.0.1, 00:17:43, Serial0
C    172.19.0.0/16 is directly connected, FastEthernet0
C    172.18.0.0/16 is directly connected, Serial0

 RIPネットワークのエントリー「172.16.0.0」、「172.17.0.0」が登録されています。「E2」とマークされていることからOSPFの外部ルートであることが分かります。

 ルート再配送を行う上で注意しなければならないのは、異なるルーティングプロトコルでは、メトリックに互換性がないということです!

 再配送を行うには、メトリックを与えておく必要があります。この再配送時に与えるメトリックのことを「シードメトリック」と言います。

ここで、Router_Bの再配布の設定を思い出してみましょう!

!
router rip (再配送に使うプロトコル)
 network 172.17.0.0
 redistribute ospf 1
!
router ospf 1 (再配送に使うプロトコル)
 network 172.18.0.0 0.0.255.255 area 0
 redistribute rip
!

・「OSPF」で取得したルートを「RIP」で再配送しています。
・「RIP」で取得したルートを「OSPF」で再配送しています。


●「RIP」で取得したルートの「OSPF」での再配送

RIPのデフォルトのシードメトリックの値は、「無限大」になっています。

つまり、再配送するルートは無限大のルートということになり、到達不能なルートとして扱われてしまうのです。


RIPにより再配布されるOSPFのルートは

「172.18.0.0/16」のルート・・・メトリック『無限大』
「172.19.0.0/16」のルート・・・メトリック『無限大』

となってしまい、Router_Aで到達不能なルートとして扱われてしますのです。


●「OSPF」で取得したルートの「RIP」での再配送

OSPFのデフォルトのシードメトリックの値は、「20」になっています。

OSPFにより再配布されるRIPのルートは

「172.16.0.0/16」のルート・・・メトリック『20』
「172.17.0.0/16」のルート・・・メトリック『20』

Router_Cのルーティングテーブルを確認するとメトリック『20』になっていることが確認できます。

O E2 172.17.0.0/16 [110/20] via 172.18.0.1, 00:17:43, Serial0
O E2 172.16.0.0/16 [110/20] via 172.18.0.1, 00:17:43, Serial0

 再配布の設定は、再配布する向きと再配送先のルーティングプロトコル、再配送元のルーティングプロトコルの指定の仕方がややこしいので、注意しましょう。

 このままでは、再配布の設定が不十分です。再配布の設定は、シードメトリック値の指定も不可欠です。シードメトリックについては、次の「ルートの再配布(シードメトリック)」で紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ルート再配送(redistribute)
ルート再配送(再配送の設定)
ルート再配送(シードメトリック)
ルート再配送(RIPとOSPF)
ルート再配送(ループバック活用例)
ルート再配送(connected)
ルート再配送(RIPとIGRP)
ルート再配送(RIPとEIGRP)
ルート再配送(IGRPとEIGRP)
ルート再配送(ルートマップ route-map)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.