@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > ルート再配送(ループバックインタフェース活用例)

 Amazon

@network Cisco・アライド実機で学ぶ
◆ルート再配送(ループバックインタフェース活用例)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆ルート再配送(ループバックインタフェース活用例)

 先ほど紹介した「ルート再配送(RIPとOSPF)」をループバックインタフェースを使った構成で、再配送の設定をしてゆきます。

先ほど紹介した「ルート再配送(RIPとOSPF)」では、下のようなネットワークで、RIP、OSPFで構成されたネットワークで再配送の設定を行い、通信させました。


今度は、上のネットワーク構成をループバックインタフェースを使って以下のように変更します。

PC_A、PC_Bに接続していたF0インタフェースをループバックインタフェースで代用します。


 ネットワークのある程度、規模が大きい演習を実機で行うとなるとルータにたくさんのインタフェースが必要になってきたり、ルータ本体の台数もそれなりに必要になってきます。

WIC-1T= WIC-2T=

 特にルーティングの演習を行うとなると、たくさんのネットワークが必要になりますから、たくさんのinterfaceを用意しなければなりません。

 ループバックインタフェースを使って、ネットワーク構成を工夫すれば、使用するルータのインタフェース、ルータの台数を節約することができます。

工夫次第で、少ないルータとインタフェースで大規模な演習を行うことも可能です。

ルーティングの検証を行いたい場合などにループバックインタフェースは、大変重宝します。

それでは、各ルータを設定してゆきます。

RIPとOSPFの再配布の設定方法については、「ルート再配送(RIPとOSPF)を参考にして下さい。」

●Router_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 172.16.0.1 255.255.0.0
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
 no fair-queue
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
logging buffered 4096 debugging
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 bandwidth 64
 ip address 172.18.0.1 255.255.0.0
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router ospf 1
 redistribute rip metric 100 subnets
 network 172.18.0.0 0.0.255.255 area 0
!
router rip
 redistribute ospf 1 metric 10
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Cの設定
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_C
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Loopback0
 ip address 172.19.0.1 255.255.0.0
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.18.0.2 255.255.0.0
 no fair-queue
 clockrate 64000
!
router ospf 1
 log-adjacency-changes
 network 172.18.0.0 0.0.255.255 area 0
 network 172.19.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


各ルータのルーティングテーブルを確認してみましょう!

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
C    172.16.0.0/16 is directly connected, Loopback0
R    172.19.0.0/16 [120/10] via 172.17.0.2, 00:00:00, Serial0
R    172.18.0.0/16 [120/10] via 172.17.0.2, 00:00:00, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:22, Serial0
     172.19.0.0/32 is subnetted, 1 subnets
O       172.19.0.1 [110/1563] via 172.18.0.2, 00:13:49, Serial1
C    172.18.0.0/16 is directly connected, Serial1

●Router_Cのルーティングテーブル
Gateway of last resort is not set

O E2 172.17.0.0/16 [110/100] via 172.18.0.1, 00:04:08, Serial0
O E2 172.16.0.0/16 [110/100] via 172.18.0.1, 00:04:08, Serial0
C    172.19.0.0/16 is directly connected, Loopback0
C    172.18.0.0/16 is directly connected, Serial0

 ループバックインタフェースが所属するネットワークアドレスが各ルータのルーティングテーブルに反映されていることが確認できます。

 ループバックインタフェースが所属するネットワークアドレスも実インタフェースが所属するネットワークアドレスと同様に、ルーティングプロトコルによって伝播されていることが分かります。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ルート再配送(redistribute)
ルート再配送(再配送の設定)
ルート再配送(シードメトリック)
ルート再配送(RIPとOSPF)
ルート再配送(ループバック活用例)
ルート再配送(connected)
ルート再配送(RIPとIGRP)
ルート再配送(RIPとEIGRP)
ルート再配送(IGRPとEIGRP)
ルート再配送(ルートマップ route-map)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.