@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > ルート再配送(RIPとIGRP)

 Amazon

@network Cisco・アライド実機で学ぶ
◆ルート再配送(RIPとIGRP)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆ルート再配送(RIPとIGRP)

下の図のRIP、IGRPで構成されたネットワークで再配送の設定を行い、通信できるようにします。

 配送の設定は、非常に癖が強いので、お手持ちの実機とIOSのバージョンによって異なる動作をするかもしれません。

ちなみに、今回の実機確認においては、Cisco1720とCisco1721を使用しております。


 「ルート再配送(再配送の設定)」で説明したように、シードメトリック値を管理者が指定しない場合、再配送は、うまくゆきません。

 RIP、IGRPのデフォルトのシードメトリック値は、無限大になっています。つまり、シードメトリック値を省略すると到達不能のルートとして扱われてしまいます。

まずは、シードメトリック値のオプション指定を省略してRouter_A〜Router_Cを設定してゆきます。



◆Router_Bの再配送の設定

 このネットワークでは、Router_Bが、RIP、IGRPの境界に位置するルータになるので、このルータで再配布の設定します。

●RIPルートの再配送

RIPで学習したルートをIGRPのAS100へ再配送するように以下のように設定します。

※シードメトリックの指定を省略しますので、デフォルトのシードメトリック値である「無限大」が使われることになり、ルートが再配送されても、到達不能なルートと扱われます。

Router_B(config)#router igrp 100
Router_B(config-router)#redistribute rip
Router_B(config-router)#network 172.18.0.0

●IGRPルートの再配送

OSPFで学習したルートをRIPへ再配送するように以下のように設定します。

Router_B(config)#router rip
Router_B(config-router)#redistribute igrp 100
Router_B(config-router)#network 172.17.0.0

※シードメトリックの指定を省略しますので、デフォルトのシードメトリック値である「無限大」が使われることになり、ルートが再配送されても、到達不能なルートと扱われます。

それでは、ルータを設定してゆきます。

Router_A、Router_CのF0にPCを接続するのは、少々面倒です。
 強制的にインタフェースをUPさせるために、F0インタフェースで「no keepalive」コマンドを設定しておきます。


●Router_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface FastEthernet0
 ip address 172.16.0.1 255.255.0.0
 speed auto
 no keepalive
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
 no fair-queue
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
logging buffered 4096 debugging
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 bandwidth 64
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 bandwidth 64
 ip address 172.18.0.1 255.255.0.0
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router rip
 redistribute igrp 100
 network 172.17.0.0
!
router igrp 100
 redistribute rip
 network 172.18.0.0
!
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Cの設定
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_C
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface FastEthernet0
 ip address 172.19.0.1 255.255.0.0
 no keepalive
 speed auto
!
interface Serial0
 bandwidth 64
 ip address 172.18.0.2 255.255.0.0
 no fair-queue
 clockrate 64000
!
router igrp 100
 network 172.18.0.0
 network 172.19.0.0
!
ip classless
no ip http server
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


各ルータのルーティングテーブルを確認してみましょう!

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
C    172.16.0.0/16 is directly connected, FastEthernet0

 「172.18.0.0」、「172.19.0.0」のルートがありません。これは、デフォルトのシードメトリック値が「無限大」なので、再配送されたルートが無視されたためです。

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:23, Serial0
I    172.19.0.0/16 [100/158260] via 172.18.0.2, 00:00:16, Serial1
C    172.18.0.0/16 is directly connected, Serial1

●Router_Cのルーティングテーブル
Gateway of last resort is not set

C    172.19.0.0/16 is directly connected, FastEthernet0
C    172.18.0.0/16 is directly connected, Serial0

 「172.16.0.0」、「172.17.0.0」のルートがありません。これは、デフォルトのシードメトリック値が「無限大」なので、再配送されたルートが無視されたためです。


◆シードメトリック値の指定

ルート再配送を行うRouter_Bの再配布の設定にシードメトリックの指定を加えます。

●RIPルートの再配送



メトリックの指定の仕方は、「?」機能で確認すると、どんな項目を入力すればよいのか教えてくれます。

Router_B(config-router)#redistribute rip metric ?
<1-4294967295> Bandwidth metric in Kbits per second

Router_B(config-router)#redistribute rip metric 10000 ?
<0-4294967295> IGRP delay metric, in 10 microsecond units

Router_B(config-router)#redistribute rip metric 10000 100 ?
<0-255> IGRP reliability metric where 255 is 100% reliable

Router_B(config-router)#redistribute rip metric 10000 100 255 ?
<1-255> IGRP Effective bandwidth metric (Loading) where 255 is 100% loaded

Router_B(config-router)#redistribute rip metric 10000 100 255 1 ?
<1-4294967295> IGRP MTU of the path

Router_B(config-router)#redistribute rip metric 10000 100 255 1 1500


●IGRPルートの再配送

IGRPで学習したルートをRIPへ再配送するように再配布の設定にシードメトリックの指定を加えます。

Router_B(config)#router rip
Router_B(config-router)#redistribute igrp 100 metric 10

「redistribute igrp 100 metric 10」と指定することで、シードメトリック値を「10」に設定します。


■シード メトリックのデフォルト値
ルート再配送先のルーティングプロトコル シードメトリックのデフォルト値
RIP 無限大
IGRP/EIGRP 無限大
OSPF 20、BGPの場合は1


シードメトリックの設定が完了したところで、各ルータのルーティングテーブルを確認してみましょう!

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
C    172.16.0.0/16 is directly connected, FastEthernet0
R    172.19.0.0/16 [120/10] via 172.17.0.2, 00:00:06, Serial0
R    172.18.0.0/16 [120/10] via 172.17.0.2, 00:00:06, Serial0

 RIPのエントリーが2つ現れています。これは、デフォルトの「無限大」のシードメトリックではなく、「10」が使われたからです。

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0
R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:19, Serial0
I    172.19.0.0/16 [100/158260] via 172.18.0.2, 00:00:05, Serial1
C    172.18.0.0/16 is directly connected, Serial1

●Router_Cのルーティングテーブル
Gateway of last resort is not set

I    172.17.0.0/16 [100/160250] via 172.18.0.1, 00:00:25, Serial0
I    172.16.0.0/16 [100/158350] via 172.18.0.1, 00:00:25, Serial0
C    172.19.0.0/16 is directly connected, FastEthernet0
C    172.18.0.0/16 is directly connected, Serial0

 IGRPのエントリーが2つ現れています。これはデフォルトの「無限大」のシードメトリックではなく、指定したシードメトリックが使われたからです。

 「172.16.0.0/16」、「172.17.0.0/16」のメトリックを見るとRouter_Cにとって近いはずの「172.17.0.0/16」が「172.17.0.0/16」より遠いことになっています。この辺りが再配送の設定の難しさです。

 再配送の設定は、調整が難しいのでシードメトリックの上手に指定する必要があります。また、再配送を指定する方法には、「ルート再配送(ルートマップ route-map)」で紹介するルートマップで指定する方法もあります。

 再配送の設定は、ルーティングプロトコルごとに指定の仕方が、変わってきます。コマンドの続きに「?」を指定して、次のオプションの指定の仕方を確認しながら設定してゆきましょう。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ルート再配送(redistribute)
ルート再配送(再配送の設定)
ルート再配送(シードメトリック)
ルート再配送(RIPとOSPF)
ルート再配送(ループバック活用例)
ルート再配送(connected)
ルート再配送(RIPとIGRP)
ルート再配送(RIPとEIGRP)
ルート再配送(IGRPとEIGRP)
ルート再配送(ルートマップ route-map)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.