@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > Fast Ether Channel(PAgP その1)

 Amazon
@network Cisco・アライド実機で学ぶ
◆Fast Ether Channel(PAgP その1)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆Fast Ether Channel(PAgP その1)

FEC には、次の3つのチャネルモードがあります。

●ON固定
●LACP(IEEE802.3ad)
●PAgP(Cisco独自)

ここでは、PAgP(Cisco独自)で、EtherChannelを設定する方法を紹介してゆきます。

 「PAgP」は、対向装置とポート速度、全二重/半二重、VLAN番号、トランクなどを判断し、ネゴシエーションを行うCisco独自のプロトコルです。

 検証に使用するスイッチは、Catalyst2950を使用します。どのチャネルモードをサポートしているかは、スイッチによって異なりますので、注意して下さい。例えば、Catalyst2900XL、Catalyst3500シリーズでは、「PAgP」や「LACP」は、サポートされていません。

それでは、下のネットワークを使用して、EtherChannel(PAgP)を設定してゆきます。


 ※チャネルが構成される前では、スイッチ間は、ループ構造になってしまいます。ループは、衝突など障害の原因になるので、チャネル設定ごに物理接続を行います。


◆Fast Ether Channel(PAgP)の設定

 EtherChannelを設定するには、インタフェースに対して、チャネルグループ番号を指定します。例えば、上の構成図のように、Fa/9とFa/10に対して、チャネルグループ番号1を割り当てるには、次のように指定します。

連続したインタフェースをまとめて設定する場合、「range」を指定すると便利です。

「channel-group」を指定する際に、モードの指定には、「desirable」もしくは、「auto」を指定します。

●PAgPのモード

・desirable ・・・ 自らLACPネゴシエーションのパケットを送る。
・auto ・・・ 自らLACPネゴシエーションのパケットを送らないが、要求が来たら受け付ける。

EtherChannelが成立する組み合わせは、以下のようになります。

・desirable ⇔ desirable : 両方共にdesirable
・desirable ⇔ auto : 片方がdesirable、もう片方がauto

IEEE標準のPAgPの設定も似ています。

channel-groupのモードの指定をまとめると次のようになります。

モード 組合せ
ON固定 共にON
LACP(IEEE802.3ad) active ⇔ active
active ⇔ passive 
PAgP(Cisco独自) desirable ⇔ desirable
auto ⇔ desirable 

今回のPAgPの設定では、共にdesirableを指定します。

Switch(config)#interface range fastEthernet 0/9 - 10
Switch(config-if-range)#channel-group 1 mode desirable

すると次のメッセージが表示されます。

Creating a port-channel interface Port-channel 1

コマンドを実行すると、「fa0/9」、「fa0/10」は、Port-channel1というインタフェースに割り当てられます。


◆Switch_Aの設定

●初期設定

Switch>en
Switch#conf t
Switch(config)#hostname Switch_A
Switch_A(config)#int vlan1
Switch_A(config-if)#ip address 192.168.1.1 255.255.255.0
Switch_A(config-if)#no shutdown
Switch_A(config-if)#exit

●ON固定の設定

Switch_A(config)#interface range fastEthernet 0/9 - 10
Switch_A(config-if-range)#channel-group 1 mode desirable


◆Switch_Bの設定

●初期設定

Switch>en
Switch#conf t
Switch(config)#hostname Switch_B
Switch_B(config)#int vlan1
Switch_B(config-if)#ip address 192.168.1.2 255.255.255.0
Switch_B(config-if)#no shutdown
Switch_B(config-if)#exit

●ON固定の設定

Switch_B(config)#interface range fastEthernet 0/9 - 10
Switch_B(config-if-range)#channel-group 1 mode desirable


各スイッチの設定は、次のようになります。

●Switch_Aの設定
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch_A
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
vtp domain hosei-lib-uadm
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface Port-channel1
 flowcontrol send off
!
interface FastEthernet0/9
 channel-group 1 mode desirable
!
interface FastEthernet0/10
 channel-group 1 mode desirable
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 no ip route-cache
!
ip http server
!
line con 0
line vty 5 15
!
end


●Switch_Bの設定
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch_B
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface Port-channel1
 flowcontrol send off
!
interface FastEthernet0/9
 channel-group 1 mode desirable
!
interface FastEthernet0/10
 channel-group 1 mode desirable
!
interface Vlan1
 ip address 192.168.1.2 255.255.255.0
 no ip route-cache
!
ip http server
!
line con 0
line vty 5 15
!
end


 これで、PAgPによるEtherChannelを設定は、完了です。設定が完了したところで、Switch_Aの「fa0/9」とSwitch_Bの「fa0/9」、Switch_Aの「fa0/10」とSwitch_Bの「fa0/10」への物理接続を行います。

※ケーブルの接続は、コンフィグ後に行うのが鉄則です。順序を間違えないようにして下さい。

次の「Fast Ether Channel(PAgP その2)」で、このネットワークを検証してゆきます。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP) Switch演習  

Fast Ether Channel とは その1
Fast Ether Channel(固定 その1)
Fast Ether Channel(固定 その3)
Fast Ether Channel(LACP その1)
Fast Ether Channel(LACP その3)
Fast Ether Channel(PAgP その1)
Fast Ether Channel(PAgP その3)
SPAN(ミラーリング その1)
SPAN(ミラーリング その3)
Fast Ether Channel とは その2
Fast Ether Channel(固定 その2
Fast Ether Channel(固定 その4)
Fast Ether Channel(LACP その2)
Fast Ether Channel(LACP その4)
Fast Ether Channel(PAgP その2)
Fast Ether Channel(PAgP その4)
SPAN(ミラーリング その2)
SPAN(ミラーリング その4)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.