@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > VPN(DMVPN その3)

 Amazon
@network Cisco・アライド実機で学ぶ
◆VPN(DMVPN その3)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆VPN(DMVPN その3)

VPN(DMVPN その2)」の続きです。

ここでは、Router_BとRouter_Cの設定を行ってゆきます。

Router_B、Router_CのE0は、「no keepalive」し、強制的にUPさせます。

※実際には、支店側では、ISPから動的にIPアドレスを取得することになりますが、ここでは、固定でIPアドレスを振っています。

◆Router_B (支社:拠点B)の設定

本来であれば、ISPより動的にIPアドレスを取得しますが、ここでは、固定でIPアドレスを振ります。

●初期設定

Rouer#conf t
Router(config)#hostname Router_B
Router_B(config)#enable password cisco
Router_B(config)#line vty 0 4
Router_B(config-line)#password cisco
Router_B(config-line)#login
Router_B(config-line)#exit
Router_B(config)#int e0
Router_B(config-if)#ip address 172.17.0.1 255.255.0.0
Router_B(config-if)#no shutdown
Router_B(config-if)#no keepalive
Router_B(config-if)#exit
Router_B(config)#int f0
Router_B(config-if)#ip address 20.0.0.2 255.0.0.0
Router_B(config-if)#no shutdown
Router_B(config-if)#exit

●IKEのポリシーを定義

Router_B(config)#crypto isakmp policy 1
Router_B(config-isakmp)#authentication pre-share
Router_B(config-isakmp)#exit

●共通鍵とIPアドレスの関連付け

Router_B(config)#crypto isakmp key cisco address 0.0.0.0 0.0.0.0

●トランスフォームセットの定義

Router_B(config)#crypto ipsec transform-set TS-IPSEC esp-3des esp-sha-hmac
Router_B(cfg-crypto-trans)#mode transport
Router_B(cfg-crypto-trans)#exit

●IPSec プロファイルの作成

Router_B(config)#crypto ipsec profile DMVPN-PROFILE
Router_B(ipsec-profile)#set transform-set TS-IPSEC

●トンネルインタフェースの作成と設定

Router_B(config)#interface tunnel 0
Router_B(config-if)#ip address 192.168.1.2 255.255.255.0
Router_B(config-if)#ip nhrp authentication cisco
-----------------------------------------------------------------------
HUBルータとの設定の違いはここの点線内の部分になります。
 SPOKEとHUB間でダイナミックルーティングプロトコルを有効にしてHUBルータにマルチキャストを送信するようにします。

Router_B(config-if)#ip nhrp map multicast 20.0.0.1

宛先のHUBルータのトンネルアドレスとグローバル固定IPアドレスをマッピングします。

Router_B(config-if)#ip nhrp map 192.168.1.1 20.0.0.1

「ip nhrp nhs」コマンドには、HUBルータのトンネルインタフェースのIPアドレスを指定します。

Router_B(config-if)#ip nhrp nhs 192.168.1.1
------------------------------------------------------------------------
Router_B(config-if)#ip nhrp network-id 1000
Router_B(config-if)#ip ospf network broadcast
Router_B(config-if)#ip ospf priority 0
Router_B(config-if)#tunnel source fastEthernet 0
Router_B(config-if)#tunnel mode gre multipoint
Router_B(config-if)#tunnel protection ipsec profile DMVPN-PROFILE
Router_B(config)#router ospf 1
Router_B(config-router)#network 172.17.0.0 0.0.255.255 area 0
Router_B(config-router)#network 192.168.1.0 0.0.0.255 area 0


◆Router_C (支社:拠点C)の設定

本来であれば、ISPより動的にIPアドレスを取得しますが、ここでは、固定でIPアドレスを振ります。

●初期設定

Rouer#conf t
Router(config)#hostname Router_C
Router_C(config)#enable password cisco
Router_C(config)#line vty 0 4
Router_C(config-line)#password cisco
Router_C(config-line)#login
Router_C(config-line)#exit
Router_C(config)#int e0
Router_C(config-if)#ip address 172.18.0.1 255.255.0.0
Router_C(config-if)#no shutdown
Router_C(config-if)#no keepalive
Router_C(config-if)#exit
Router_C(config)#int f0
Router_C(config-if)#ip address 20.0.0.3 255.0.0.0
Router_C(config-if)#no shutdown
Router_C(config-if)#exit

●IKEのポリシーを定義

Router_C(config)#crypto isakmp policy 1
Router_C(config-isakmp)#authentication pre-share
Router_C(config-isakmp)#exit

●共通鍵とIPアドレスの関連付け

Router_C(config)#crypto isakmp key cisco address 0.0.0.0 0.0.0.0

●トランスフォームセットの定義

Router_C(config)#crypto ipsec transform-set TS-IPSEC esp-3des esp-sha-hmac
Router_C(cfg-crypto-trans)#mode transport
Router_C(cfg-crypto-trans)#exit

●IPSec プロファイルの作成

Router_C(config)#crypto ipsec profile DMVPN-PROFILE
Router_C(ipsec-profile)#set transform-set TS-IPSEC

●トンネルインタフェースの作成と設定

Router_C(config)#interface tunnel 0
Router_C(config-if)#ip address 192.168.1.3 255.255.255.0
Router_C(config-if)#ip nhrp authentication cisco
-----------------------------------------------------------------------
HUBルータとの設定の違いはここの点線内の部分になります。
 SPOKEとHUB間でダイナミックルーティングプロトコルを有効にしてHUBルータにマルチキャストを送信するようにします。

Router_C(config-if)#ip nhrp map multicast 20.0.0.1

宛先のHUBルータのトンネルアドレスとグローバル固定IPアドレスをマッピングします。

Router_C(config-if)#ip nhrp map 192.168.1.1 20.0.0.1

「ip nhrp nhs」コマンドには、HUBルータのトンネルインタフェースのIPアドレスを指定します。

Router_C(config-if)#ip nhrp nhs 192.168.1.1
------------------------------------------------------------------------
Router_C(config-if)#ip nhrp network-id 1000
Router_C(config-if)#ip ospf network broadcast
Router_C(config-if)#ip ospf priority 0
Router_C(config-if)#tunnel source fastEthernet 0
Router_C(config-if)#tunnel mode gre multipoint
Router_C(config-if)#tunnel protection ipsec profile DMVPN-PROFILE
Router_C(config)#router ospf 1
Router_C(config-router)#network 172.18.0.0 0.0.255.255 area 0
Router_C(config-router)#network 192.168.1.0 0.255.255.255 area 0

次の各ルータのコンフィグは、次の「VPN(DMVPN その4)」で紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

VPN(VPNとは)
VPN(IKE・フェーズ1・フェーズ2)
VPN(暗号化・認証アルゴリズム)
VPN(VPNの設定手順 その2)
VPN(基本設定 その1)
VPN(基本設定 その3 検証)
VPN(VPN接続とインターネット その1)
VPN(VPN接続とインターネット その3)
VPN(GREトンネルとルーティングプロトコル 1)
VPN(GREトンネルとルーティングプロトコル 3)
VPN(GREトンネルとルーティングプロトコル 5)
VPN(3拠点のVPN接続 その1)
VPN(3拠点のVPN接続 その3)
VPN(DMVPN その1)
VPN(DMVPN その3)
VPN(DMVPN その5)
VPN(DMVPN その7)
VPN(VPNとNAT その1)
VPN(VPNとNAT その3)
VPN(VPNとNAT その5)
VPN(VPNとNAT その7)
VPN(トンネル・エンドポイント・ディスカバリ 2)
VPN(トンネル・エンドポイント・ディスカバリ 4)
VPN(トンネル・エンドポイント・ディスカバリ 6)
VPN(インターネットVPN・IPsec)
VPN(トランスポートモード・トンネルモード)
VPN(VPNの設定手順 その1)
VPN(VPNの設定手順 まとめ)
VPN(基本設定 その2)
VPN(基本設定 その4 確認)
VPN(VPN接続とインターネット その2)
VPN(VPNとルーティングプロトコル)
VPN(GREトンネルとルーティングプロトコル 2)
VPN(GREトンネルとルーティングプロトコル 4)
VPN(GREトンネルとルーティングプロトコル 6)
VPN(3拠点のVPN接続 その2)
VPN(3拠点のVPN接続 その4)
VPN(DMVPN その2)
VPN(DMVPN その4)
VPN(DMVPN その6)
VPN(DMVPN その8)
VPN(VPNとNAT その2)
VPN(VPNとNAT その4)
VPN(VPNとNAT その6)
VPN(トンネル・エンドポイント・ディスカバリ 1)
VPN(トンネル・エンドポイント・ディスカバリ 3)
VPN(トンネル・エンドポイント・ディスカバリ 5)
VPN(トンネル・エンドポイント・ディスカバリ 7)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.