@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > VPN(DMVPN その7)
@network Cisco・アライド実機で学ぶ
◆VPN(DMVPN その7)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。
 Amazon

◆VPN(DMVPN その7)

 「VPN(DMVPN その1)」〜「VPN(DMVPN その4)」において、DMVPNによる3拠点によるインターネットVPNを構築し、下のネットワークを構築しました。ここでは、さらに1拠点を追加してゆきます。拠点を増やした場合でも、他のルータの設定を変更することなく、VPN接続を確立できるということを確認してゆきます。


上のネットワークに、支社(拠点D)を追加して下の構成にします。



◆Router_D(支社:拠点D)の設定

本来であれば、ISPより動的にIPアドレスを取得しますが、ここでは、固定でIPアドレスを振ります。

●初期設定

Rouer#conf t
Router(config)#hostname Router_D
Router_D(config)#enable password cisco
Router_D(config)#line vty 0 4
Router_D(config-line)#password cisco
Router_D(config-line)#login
Router_D(config-line)#exit
Router_D(config)#int e0
Router_D(config-if)#ip address 172.19.0.1 255.255.0.0
Router_D(config-if)#no shutdown
Router_D(config-if)#no keepalive
Router_D(config-if)#exit
Router_D(config)#int f0
Router_D(config-if)#ip address 20.0.0.4 255.0.0.0
Router_D(config-if)#no shutdown
Router_D(config-if)#exit

●IKEのポリシーを定義

Router_D(config)#crypto isakmp policy 1
Router_D(config-isakmp)#authentication pre-share
Router_D(config-isakmp)#exit

●共通鍵とIPアドレスの関連付け

Router_D(config)#crypto isakmp key cisco address 0.0.0.0 0.0.0.0

●トランスフォームセットの定義

Router_D(config)#crypto ipsec transform-set TS-IPSEC esp-3des esp-sha-hmac
Router_D(cfg-crypto-trans)#mode transport
Router_D(cfg-crypto-trans)#exit

●IPSec プロファイルの作成

Router_D(config)#crypto ipsec profile DMVPN-PROFILE
Router_D(ipsec-profile)#set transform-set TS-IPSEC

●トンネルインタフェースの作成と設定

Router_D(config)#interface tunnel 0
Router_D(config-if)#ip address 192.168.1.4 255.255.255.0
Router_D(config-if)#ip nhrp authentication cisco
-----------------------------------------------------------------------
HUBルータとの設定の違いはここの点線内の部分になります。
SPOKEとHUB間でダイナミックルーティングプロトコルを有効にしてHUBルータにマルチキャストを送信するようにします。

Router_D(config-if)#ip nhrp map multicast 20.0.0.1

宛先のHUBルータのトンネルアドレスとグローバル固定IPアドレスをマッピングします。

Router_D(config-if)#ip nhrp map 192.168.1.1 20.0.0.1

「ip nhrp nhs」コマンドには、HUBルータのトンネルインタフェースのIPアドレスを指定します。

Router_D(config-if)#ip nhrp nhs 192.168.1.1
------------------------------------------------------------------------
Router_D(config-if)#ip nhrp network-id 1000
Router_D(config-if)#ip ospf network broadcast
Router_D(config-if)#ip ospf priority 0
Router_D(config-if)#tunnel source fastEthernet 0
Router_D(config-if)#tunnel mode gre multipoint
Router_D(config-if)#tunnel protection ipsec profile DMVPN-PROFILE
Router_D(config)#router ospf 1
Router_D(config-router)#network 172.19.0.0 0.0.255.255 area 0
Router_D(config-router)#network 192.168.1.0 0.0.0.255 area 0

次の「VPN(DMVPN その8)」で、動作を検証してゆきます。


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

VPN(VPNとは)
VPN(IKE・フェーズ1・フェーズ2)
VPN(暗号化・認証アルゴリズム)
VPN(VPNの設定手順 その2)
VPN(基本設定 その1)
VPN(基本設定 その3 検証)
VPN(VPN接続とインターネット その1)
VPN(VPN接続とインターネット その3)
VPN(GREトンネルとルーティングプロトコル 1)
VPN(GREトンネルとルーティングプロトコル 3)
VPN(GREトンネルとルーティングプロトコル 5)
VPN(3拠点のVPN接続 その1)
VPN(3拠点のVPN接続 その3)
VPN(DMVPN その1)
VPN(DMVPN その3)
VPN(DMVPN その5)
VPN(DMVPN その7)
VPN(VPNとNAT その1)
VPN(VPNとNAT その3)
VPN(VPNとNAT その5)
VPN(VPNとNAT その7)
VPN(トンネル・エンドポイント・ディスカバリ 2)
VPN(トンネル・エンドポイント・ディスカバリ 4)
VPN(トンネル・エンドポイント・ディスカバリ 6)
VPN(インターネットVPN・IPsec)
VPN(トランスポートモード・トンネルモード)
VPN(VPNの設定手順 その1)
VPN(VPNの設定手順 まとめ)
VPN(基本設定 その2)
VPN(基本設定 その4 確認)
VPN(VPN接続とインターネット その2)
VPN(VPNとルーティングプロトコル)
VPN(GREトンネルとルーティングプロトコル 2)
VPN(GREトンネルとルーティングプロトコル 4)
VPN(GREトンネルとルーティングプロトコル 6)
VPN(3拠点のVPN接続 その2)
VPN(3拠点のVPN接続 その4)
VPN(DMVPN その2)
VPN(DMVPN その4)
VPN(DMVPN その6)
VPN(DMVPN その8)
VPN(VPNとNAT その2)
VPN(VPNとNAT その4)
VPN(VPNとNAT その6)
VPN(トンネル・エンドポイント・ディスカバリ 1)
VPN(トンネル・エンドポイント・ディスカバリ 3)
VPN(トンネル・エンドポイント・ディスカバリ 5)
VPN(トンネル・エンドポイント・ディスカバリ 7)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.