@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > VPN(トンネル・エンドポイント・ディスカバリ 5)
@network Cisco・アライド実機で学ぶ
◆VPN(トンネル・エンドポイント・ディスカバリ 5)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。
 Amazon

◆VPN(トンネル・エンドポイント・ディスカバリ 5)

 「VPN(トンネル・エンドポイント・ディスカバリ 4)」の続きです。ここでは、追加する拠点CのRouter_Cを設定してゆきます。

※Router_B、Router_CのE0は、「no keepalive」コマンドで、強制的にUPさせます。



◆Router_Cの設定

●初期設定

Rouer#conf t
Router(config)#hostname Router_C
Router_C(config)#enable password cisco
Router_C(config)#line vty 0 4
Router_C(config-line)#password cisco
Router_C(config-line)#login
Router_C(config-line)#exit
Router_C(config)#int e0
Router_C(config-if)#ip address 172.18.0.1 255.255.0.0
Router_C(config-if)#no keepalive
Router_C(config-if)#no shutdown
Router_C(config-if)#exit
Router_C(config)#int f0
Router_C(config-if)#ip address 20.0.0.3 255.0.0.0
Router_C(config-if)#no shutdown
Router_C(config-if)#exit

●IPsec対象トラフィックの定義

Router_C(config)#access-list 100 permit ip 172.18.0.0 0.0.255.255 172.16.0.0 0.0.255.255
Router_C(config)#access-list 101 permit ip 172.18.0.0 0.0.255.255 172.17.0.0 0.0.255.255


●スタティックルートの設定

Router_C(config)#ip route 172.16.0.0 255.255.0.0 20.0.0.1
Router_C(config)#ip route 172.17.0.0 255.255.0.0 20.0.0.2


●VPNの設定

Router_C(config)#crypto isakmp policy 1
Router_C(config-isakmp)#authentication pre-share
Router_C(config-isakmp)#exit

↓対向ルータのアドレスは「0.0.0.0」を指定します。
Router_C(config)#crypto isakmp key cisco address 0.0.0.0 0.0.0.0

Router_C(config)#crypto ipsec transform-set TS-IPSEC esp-3des esp-sha-hmac
Router_C(cfg-crypto-trans)#mode tunnel
Router_C(cfg-crypto-trans)#exit

↓「crypto dynamic-map」を作成します。
Router_C(config)#crypto dynamic-map MAP-IPSEC 1
Router_C(config-crypto-map)#set transform-set TS-IPSEC
Router_C(config-crypto-map)#match address 100
Router_C(config-crypto-map)#exit

Router_C(config)#crypto dynamic-map MAP-IPSEC 2
Router_C(config-crypto-map)#set transform-set TS-IPSEC
Router_C(config-crypto-map)#match address 101
Router_C(config-crypto-map)#exit

↓「crypto map」で「crypto dynamic-map」を指定します。
Router_C(config)#crypto map TEDTAG 1 ipsec-isakmp dynamic MAP-IPSEC discover

Router_C(config)#interface fastEthernet 0
Router_C(config-if)#crypto map TEDTAG
Router_C(config)#exit

各ルータのコンフィグは、次の「VPN(トンネル・エンドポイント・ディスカバリ 6)」で紹介します。


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

VPN(VPNとは)
VPN(IKE・フェーズ1・フェーズ2)
VPN(暗号化・認証アルゴリズム)
VPN(VPNの設定手順 その2)
VPN(基本設定 その1)
VPN(基本設定 その3 検証)
VPN(VPN接続とインターネット その1)
VPN(VPN接続とインターネット その3)
VPN(GREトンネルとルーティングプロトコル 1)
VPN(GREトンネルとルーティングプロトコル 3)
VPN(GREトンネルとルーティングプロトコル 5)
VPN(3拠点のVPN接続 その1)
VPN(3拠点のVPN接続 その3)
VPN(DMVPN その1)
VPN(DMVPN その3)
VPN(DMVPN その5)
VPN(DMVPN その7)
VPN(VPNとNAT その1)
VPN(VPNとNAT その3)
VPN(VPNとNAT その5)
VPN(VPNとNAT その7)
VPN(トンネル・エンドポイント・ディスカバリ 2)
VPN(トンネル・エンドポイント・ディスカバリ 4)
VPN(トンネル・エンドポイント・ディスカバリ 6)
VPN(インターネットVPN・IPsec)
VPN(トランスポートモード・トンネルモード)
VPN(VPNの設定手順 その1)
VPN(VPNの設定手順 まとめ)
VPN(基本設定 その2)
VPN(基本設定 その4 確認)
VPN(VPN接続とインターネット その2)
VPN(VPNとルーティングプロトコル)
VPN(GREトンネルとルーティングプロトコル 2)
VPN(GREトンネルとルーティングプロトコル 4)
VPN(GREトンネルとルーティングプロトコル 6)
VPN(3拠点のVPN接続 その2)
VPN(3拠点のVPN接続 その4)
VPN(DMVPN その2)
VPN(DMVPN その4)
VPN(DMVPN その6)
VPN(DMVPN その8)
VPN(VPNとNAT その2)
VPN(VPNとNAT その4)
VPN(VPNとNAT その6)
VPN(トンネル・エンドポイント・ディスカバリ 1)
VPN(トンネル・エンドポイント・ディスカバリ 3)
VPN(トンネル・エンドポイント・ディスカバリ 5)
VPN(トンネル・エンドポイント・ディスカバリ 7)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.