@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > フレームリレーの設定

 Amazon

@network Cisco・アライド実機で学ぶ
◆フレームリレーの設定

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆フレームリレーの設定

 ここでは、フレームリレーネットワークを構築してみます。フレームリレー網は、先ほどの、「フレームリレーシミュレータを作る」で作成したフレームリレー交換機使用することで対応します。

VCの設定は、サブインタフェースを使って、ポイントツーポイント接続します。



●フレームリレーカプセル化タイプの設定

 フレームリレーのカプセル化を行うには、インタフェース設定モードで、「encapsulation frame-relay」コマンドを使います。

Router(config-if)#encapsulation frame-relay {cisco | ietf}

 何も指定しない場合は、デフォルトで「cisco」が適用されます。Ciscoルータ同士では、問題ありませんが、Ciscoルータ以外の他ベンダールータを接続する場合には、「ietf」を指定する必要があります。


●フレームリレーLMIの設定

 Cisco IOS11.1以降を使用している場合は、LMIタイプを自動検出してくれますが、それより前のバージョンを使用している場合は、LMIのタイプを指定する必要があります。

Rotuer(config-if)#frame-relay lmi-type {ansi | cisco | q933a}


●物理インタフェースのIPアドレスのIPアドレスの削除する

 物理インタフェースにIPアドレスが設定されている場合は、「no ip address」コマンドを実行してIPアドレスを削除します。


Router(config-if)#no ip address

●サブインタフェースの作成

1つの物理インタフェース上に存在しない仮想インタフェースを作ることができます。

Router(config)#interface <インタフェース名> <インタフェース番号>.<サブインタフェース番号> <point-to-point | multipoint>

Router(config)#interface serial 0.1 point-to-point
Router(config-subif)#


●VCの割り当て

 サブインタフェースを使う場合、ポイントツーポイント接続を設定するには、「frame-relay interface-dlci」コマンドを使ってVCにDLCIを割り当てる必要があります。

Router(config-subif)#frame-relay interface-dlci {DLCI番号}


●フレームリレーマップの設定

 マルチポイントサブインタフェースを設定する際、Inverse ARPがサポートされていない場合は、「frame-relay map」コマンドを使用して手動でフレームリレーマップを作成する必要があります。今回は、ポイントツーポイント接続を行うので設定は行いません。

Router(config-if)#frame-relay map {プロトコル} {アドレス} {DLCI番棒}


◆各ルータのフレームリレーの設定

●Router_Aのフレームリレーの設定

Router(config)#int s0
Router(config-if)#no ip address
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay lmi-type ansi
Router(config-if)#exit

Router(config)#int s0.1 point-to-point
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#frame-relay interface-dlci 100
Router(config-subif)#no shutdown
Router(config-subif)#exit


●Router_Bのフレームリレーの設定

Router(config)#int s0
Router(config-if)#no ip address
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay lmi-type ansi
Router(config-if)#exit

Router(config)#int s0.1 point-to-point
Router(config-subif)#ip address 192.168.1.2 255.255.255.0
Router(config-subif)#frame-relay interface-dlci 200
Router(config-subif)#no shutdown
Router(config-subif)#exit


●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
 bandwidth 64
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 ip address 192.168.1.1 255.255.255.0
 frame-relay interface-dlci 100
!
interface Serial1
 no ip address
 shutdown
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
 bandwidth 64
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 ip address 192.168.1.2 255.255.255.0
 frame-relay interface-dlci 200
!
interface Serial1
 no ip address
 shutdown
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

次の「フレームリレーの検証コマンド」では、フレームリレーの検証コマンドを紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
フレームリレーとは
フレームリレーシミュレータを作る
フレームリレーの設定
フレームリレーの検証コマンド

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.