@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > OSPF(DR・BDRの選出 ルータID)

 Amazon

@network Cisco・アライド実機で学ぶ
◆OSPF(DR・BDRの選出 ルータID)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆OSPF(DR・BDRの選出 ルータID)

ここでは、OSPFネットワークにおけるDR、BDRの選出のされ方について検証してゆきます。

DR、BDRについては、「OSPF(DR・BDRの選出)」で解説しています。

OSPF(DR・BDRの選出)」でも解説したように、DR、BDRの選出については、次の3つの項目に着目します。

1.優先度(PRIORITY)
2.ループバックインタフェースのIPアドレス
3.物理インタフェースのIPアドレス(アクティブなインタフェースで最も大きいもの)


優先度 > ループバックインタフェースのIPアドレス > 物理インタフェースIPアドレス

の順に注目してゆけばどのルータがDR、BDRに選出されるのかが分かります


それでは、下の図のネットワークをOSPFで構築して確認してみます。


 プライオリティ値の設定は、行わないので、Router_A〜Router_Cのプライオリティティは、デフォルトの「1」になります。そうすると、全てのルータのプライオリティ値が同じになるので、今度は、ルータIDの大きさで、決まることになります。

 Router_A〜Router_Cには、ループバックアドレスが設定されていないので各ルータのアクティブなインタフェースのIPアドレスで最大のIPアドレスが、ルータIDになります。

そうすると各ルータのルータIDは次のようになります。

Router_AのルータID ・・・ 192.168.1.1
Router_BのルータID ・・・ 192.168.1.2
Router_CのルータID ・・・ 192.168.1.3

ということは、

Router_A ・・・ DROTHER
Router_B ・・・ BDR
Router_C ・・・ DR

になるはずです。

DR、BDRが、このように選択されるか、各ルータを設定してみましょう!


●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.1.2 255.255.255.0
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 0
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Cの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_C
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.1.3 255.255.255.0
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 0
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


 各ルータの設定が完了したら、各ルータで「copy run start」して設定を保存し、Router_A〜Router_Cの電源を切り、ほぼ同じタイミングで電源を入れます。これは、DR、BDRは、一度、DR、BDRが決定すると、DR、BDRがダウンするまで新しいDR、BDRが選出されないからです。

 設定した順番、もしくは電源を入れた順番でDR、BDRが決定されてしまった場合、後から設定したルータや後から追加したルータは、DR、BDRに選出されません。

「show ip ospf neighbor」コマンドを使って、どのルータがDR、BDRに選出されてか確認してみましょう!

●Router_Aの「show ip ospf neighbor」の出力
Router_A#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.3       1   FULL/DR         00:00:38     192.168.1.3     Ethernet0
192.168.1.2       1   FULL/BDR        00:00:36     192.168.1.2     Ethernet0

●Router_Bの「show ip ospf neighbor」の出力
Router_B#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.1       1   FULL/DROTHER    00:00:33    192.168.1.1     Ethernet0
192.168.1.3       1   FULL/DR         00:00:33    192.168.1.3     Ethernet0

●Router_Cの「show ip ospf neighbor」の出力
Router_C#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.1       1   FULL/DROTHER    00:00:34     192.168.1.1     Ethernet0
192.168.1.2       1   FULL/BDR        00:00:32     192.168.1.2     Ethernet0

 「show ip ospf neighbor」コマンドの出力から分かるように、各ルータは下のようになっていることが確認できます。

Router_A ・・・ DROTHER
Router_B ・・・ BDR
Router_C ・・・ DR

 次の「OSPF(DR・BDRの選出 ループバックアドレス)」では、ルータにループバックアドレスを設定した際のDR、BDRの選出のされ方について検証してみます。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
OSPFの特徴・エリアの概念
OSPF(経路学習プロセス)
OSPF(DR・BDRの選出)
OSPFの設定例
OSPF(Hello間隔・Dead間隔)
OSPF(検証コマンド)
OSPF(debugコマンド)
OSPF認証(ip ospf authentication-key)
OSPF認証(ip ospf message-digest-key)
OSPF(DR・BDRの選出 ルータID)
OSPF(DR・BDRの選出 ループバックアドレス)
OSPF(DR・BDRの選出 プライオリティ)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.