@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > OSPFの設定例1

 Amazon

@network Cisco・アライド実機で学ぶ
◆OSPFの設定例1

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆OSPFの設定例1

ここでは、OSPFの基本設定を紹介します。下の図のネットワークをOSPFで構成してみましょう!


◆OSPFの基本設定

OSPFを起動させるには、グローバル設定モードで「router ospf」コマンドを入力します。

Router(config)#router ospf {プロセス番号}

プロセス番号: 1〜65535

 プロセス番号は、OSPFプロセスを管理する番号で、Router_A、Router_Bとで合わせておく必要はありません。プロセス番号は、OSPFプロセスを管理するためのものです。IGRPやEIGRPのAS番号とは違います。また、エリア番号と合わせる要もありません。


ネットワークとエリアの設定を行います。

 シングルエリアOSPFでは、全てバックボーンエリアに所属することになるので、「area 0」を指定します。RIP、IGRP、EIGRPと異なり、ネットワークを指定するために、ワイルドカードマスクで、ネットワークを指定します。

Router(config-router)#network {ネットワーク} {ワイルドカードマスク} area 0


上の構成図の場合、Router_AのOSPFの設定は、次のようになります。

Router_A(config)#router ospf 1
Router_A(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router_A(config-router)#network 172.16.0.0 0.0.0.3 area 0


 使用しているルータのIOSのバージョンが12.0以降でない場合は、「ip subnet-zero」コマンドが必要です。第0サブネットを使用する場合は注意が必要です。

Router(config)#ip subnet-zero

IOSのバージョンが12.0以降の場合は、デフォルトで「ip subnet-zero」コマンドが有効になっています。


◆帯域幅・コストの設定

 OSPFは、リンクのコストでルートを判断しますので、インタフェースに適切な帯域幅を設定する必要があります。「bandwidth」コマンドの設定を忘れてもデフォルトの帯域幅が使われますが、OSPFを正しく動作させるには、正しい帯域幅の設定が不可欠です。

Router(config)#interface serial 0
Router(config-if)#bandwidth 64


リンクコストは、インタフェース設定モードで次のコマンドを指定することでカスタマイズすることができます。

Router(config-if)#ip ospf cost {コスト値}
※コスト値: 1〜65,535

 OSPFのリンクのコストは、「108/帯域幅」で求められる値が使われます。つまり、100Mbpsのリンクの場合、コストは1になります。100Mbpsイーサネットと、ギガイーサーネットが混在する環境では、リンクのコストをカスタマイズしなければ、うまく機能しなくなります。


●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.255.252
 bandwidth 64
 clockrate 64000
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.0.3 area 0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.3.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.2 255.255.255.252
 bandwidth 64
!
router ospf 1
 network 192.168.3.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.0.3 area 0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


Router_A、Router_Bのルーティングテーブルを確認します。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Ethernet0
O    192.168.3.0/24 [110/1572] via 172.16.0.2, 00:01:27, Serial0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

O    192.168.1.0/24 [110/1572] via 172.16.0.1, 00:00:06, Serial0
C    192.168.3.0/24 is directly connected, Ethernet0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, Serial0


Router_Aのルーティングテーブルを確認すると以下のように表示されています。

O 192.168.3.0/24 [110/1572] via 172.16.0.2, 00:01:27, Serial0

「O」は、OSPFによって学習したことを意味しています。

アドミニストレーティブディスタンスは、「110」であることが分かります。

メトリックは、各リンクの「108/帯域幅」の累計ですから計算式は、以下のようになります。

(108 / 64,000) + (108 /10 ×106)= 1562.5 + 10 = 1572.5

計算式から求められるとおり、「1572」になっています。

 次の「OSPF(Hello間隔・Dead間隔)」では、隣接ルータにおいてのHello間隔・Dead間隔の関係について紹介します。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
OSPFの特徴・エリアの概念
OSPF(経路学習プロセス)
OSPF(DR・BDRの選出)
OSPFの設定例
OSPF(Hello間隔・Dead間隔)
OSPF(検証コマンド)
OSPF(debugコマンド)
OSPF認証(ip ospf authentication-key)
OSPF認証(ip ospf message-digest-key)
OSPF(DR・BDRの選出 ルータID)
OSPF(DR・BDRの選出 ループバックアドレス)
OSPF(DR・BDRの選出 プライオリティ)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.