@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > 配布リスト EIGRP(ACL・prefix-list)

 Amazon
@network Cisco・アライド実機で学ぶ
◆配布リスト EIGRP(ACL・prefix-list)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。



配布リスト IGRP(ACL・prefix-list)     
前へ  次へ
配布リスト OSPF(ACL・prefix-list)

◆配布リスト EIGRP(ACL・prefix-list)

ここでは、EIGRPネットワークで以下の設定を行いルートフィルタリングの検証を行います。

●ACLを使用した配布リストの設定
●プレフィックスリストを使用した配布リストの設定

まずは、下のネットワークをEIGRPで構築します。


検証には、IOS12.0を搭載するCisco2611を使用しています。

各ルータの設定は、以下のようになります。

●Router_Aの設定
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 10.0.0.1 255.0.0.0
!
interface Loopback1
 ip address 20.0.0.1 255.0.0.0
!
interface Ethernet0/0
 ip address 172.16.0.1 255.255.0.0
!
router eigrp 100
 network 10.0.0.0
 network 20.0.0.0
 network 172.16.0.0
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


●Router_Bの設定
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0/0
 ip address 172.16.0.2 255.255.0.0
!
router eigrp 100
 network 172.16.0.0
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end

 ルータの設定が完了したら、「copy run start」して保存しておきます。後ほど、この設定状態から、再設定できるようにしておきます。

Router_Bに「10.10.10.0/24」の経路情報をアドバタイズしないようにルートフィルタリングの設定をしてゆきます。


◆ACLを使用した配布リストの設定

Router_Aに次の設定を追加します。

Router_A(config)#access-list 1 deny 10.0.0.0 0.255.255.255
Router_A(config)#access-list 1 permit any
Router_A(config)#router eigrp 100
Router_A(config-router)#distribute-list 1 out ethernet 0/0

Router_Bのルーティングテーブルをクリアします。

Router_B#clear ip route *

Router_Bのルーティングテーブルを確認します。

●Router_Bのルーティングテーブル
Gateway of last resort is not set

D    20.0.0.0/8 [90/409600] via 172.16.0.1, 00:00:02, Ethernet0/0
C    172.16.0.0/16 is directly connected, Ethernet0/0

Router_Aから「10.10.10.0/24」の経路情報が伝播されていないことが確認できます。

次に、プレフィックスリストを使用した配布リストの設定を行います。

Router_Aをリロードします。

Router_A#reload


◆プレフィックスリストを使用した配布リストの設定

Router_Aに次の設定を追加します。

Router_A(config)#ip prefix-list net-filter seq 10 deny 10.0.0.0/8
Router_A(config)#ip prefix-list net-filter seq 15 permit 0.0.0.0/0 le 32
Router_A(config)#router eigrp 100
Router_A(config-router)#distribute-list prefix net-filter out ethernet 0/0

Router_Bのルーティングテーブルをクリアします。

Router_B#clear ip route *

Router_Bのルーティングテーブルを確認します。

●Router_Bのルーティングテーブル
Gateway of last resort is not set

D    20.0.0.0/8 [90/409600] via 172.16.0.1, 00:00:02, Ethernet0/0
C    172.16.0.0/16 is directly connected, Ethernet0/0

Router_Aから「10.10.10.0/24」の経路情報が伝播されていないことが確認できます。

次の「配布リスト OSPF(ACL・prefix-list)」では、OSPFにおける配布リストの設定を紹介します。


配布リスト IGRP(ACL・prefix-list)     
前へ  次へ
配布リスト OSPF(ACL・prefix-list)

<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
配布リスト(ルートフィルタリングの種類)
配布リストの設定
配布リスト RIP(ACL・prefix-list)
配布リスト IGRP(ACL・prefix-list)
配布リスト EIGRP(ACL・prefix-list)
配布リスト OSPF(ACL・prefix-list)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.