@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > IGRP(不等コストロードバランシング)

 Amazon

@network Cisco・アライド実機で学ぶ
◆IGRP(不等コストロードバランシング)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆IGRP(不等コストロードバランシング)

◆不等ロードバランシングの設定

ここでは、IGRPのロードバランシングについて紹介します。RIPと同様、等コストロードバランシングが行えます。

 IGRPでは、デフォルトで4つまでの経路で等コストバランシングが行えます。下のコマンドを使えば最大で6つまでの経路で等コストロードバランシングを行うことができます。

Router(config-router)#maximum-paths {等コストパスの数}

 IGRPでは、等コストロードバランシングに加えて、不等コストロードバランシングが行えます。不等コストロードバランシングを行うには、「variance」コマンドを使います。

Router(config-router)#variance {変数}

この変数の値は、デフォルトで1になっています。0は、指定できません。1〜128までの範囲で指定します。

不等ロードバランシングの設定を理解しやすくするために下の図を見て下さい。


Router_AからRouter_Dまでの経路は

Router_A → Router_B → Router_D ・・・ コスト40

Router_A → Router_C → Router_D ・・・ コスト60

の2つあります。

 デフォルトで、varianceの変数の値は、1になっているので最小コストの40に1を乗算した経路が最適経路として選択します。その結果、コスト40の「Router_A→Router_B→Router_D」が選択されます。

 ここで、残ったコスト60の「Router_A→Router_C→Router_D」経路も使いたい場合、varianceの変数の値を変更するのです。

varianceの変数の値を2にすると

Router(config-router)#variance 2

50×2 = 100

100以下のコストの経路が不等コストロードバランシングに使用されるようになります。

つまり、コスト60の「Router_A→Router_C→Router_D」経路も選択されるようになります。

●「traffic-share」コマンド

等コストバランシングを行うか、不等コストロードバランシングを行うかは、「traffic-share」コマンドで指定します。

Router(config-router)#traffic-share {min | balanced}

 「min」を指定した場合は、複数候補の経路があったとしても等コストバランシングになります。「balanced」を選択した場合、経路のコストに比例して不等コストバランシングが行われます。

 IGRPでは、デフォルトで「balanced」が指定されていますが、varianceの変数の値は、1になっているのでvarianceの変数の値を変更しない限り、等コストバランシングになるので注意して下さい。

 それでは、IGRPで不等コストロードバランシングを構築してみましょう!ネットワーク構成図は、下の図のようになります。


 不等コストロードバランシングを検証するために、プロセススイッチングを設定します。プロセススイッチングにすることで、パケット単位でロードバランシングするようになります。ほとんどのシスコ ルータでは、デフォルトでファーストスイッチングがインターフェイスに対して有効化されています。

●プロセススイッチングを有効化する

今回は、プロセススイッチングでロードバランシングを行うので、次のコマンドを設定しておく必要があります。

Router(config-if)#no ip route-cash

 「bandwitdh」コマンドの設定も忘れないようにして下さい。IGRPの設定では、帯域幅を見ますので、この設定を忘れると等コストバランシングが行われます。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.1 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 bandwidth 64
 clockrate 64000
!
interface Serial1
 ip address 172.16.3.1 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 bandwidth 125
 clockrate 125000
!
router igrp 1
 variance 2
 network 172.16.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.2 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 bandwidth 64
!
interface Serial1
 ip address 172.16.3.2 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 bandwidth 125
!
router igrp 1
 variance 2
 network 172.16.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_Aで、拡張Pingを行い、宛先IPアドレス172.16.4.1へ向けて、100回Pingパケットを送信します。

●Router_AからのPing
Router_A#ping
Protocol [ip]:
Target IP address: 172.16.4.1
Repeat count [5]: 200
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 200, 100-byte ICMP Echoes to 172.16.4.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

直ぐに、Router_Bに切り替えて、「debug ip packet」の出力を確認します。

●Router_Bの「debug ip packet」の出力
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial0), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial0), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending
IP: s=172.16.1.1 (Serial1), d=172.16.4.1, len 104, rcvd 4
IP: s=172.16.4.1 (local), d=172.16.1.1 (Serial1), len 104, sending

 Serial0、Serial1が切り替わっています。不等コストロードバランシングが行われていることが確認できます。また、帯域幅の広い、Serial1がよく使われていることが確認できます。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
IGRPの特徴
IGRPの設定例1
IGRP(検証コマンド)
IGRP(debugコマンド)
IGRPの設定例2
IGRPとRIPの混在時
IGRP(不等コストロードバランシング)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.