@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > IGRP(デフォルトルートの伝播)

 Amazon

@network Cisco・アライド実機で学ぶ
◆IGRP(デフォルトルートの伝播)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆IGRP(デフォルトルートの伝播)

IGRPのデフォルトルートの伝播について紹介します。

 デフォルトルートの設定は、ルーティングプロトコル、IOSのバージョンによってコマンドの解釈のされ方や、ルータの振る舞い方が違うので、いろいろ試してみることをオススメします。

下の図のネットワークを使用します。

 インターネットをシミュレートするために、ISPルータにループバックアドレス、Lo1、lo2を設定します。このループバックアドレスを仮のインターネット宛てのIPアドレスとして代用します。


 上のネットワークの構成では、Router_A、Router_Bにおいて、宛先ネットワークがインターネット向けのルートをデフォルトルートを設定することでルータのルーティングテーブルの小さくすることができます。

 そのデフォルトルートですが、Router_A、Router_Bにおいて、それぞれ静的なデフォルトルート「ip route 0.0.0.0 0.0.0.0」を指定することでもできますし、インターネットへの境界ルータであるRouter_Aで指定したルートを他のIGRPルータに伝播させることもできます。

 IGRPでは 「0.0.0.0」へのルートが分からないので、「ip route 0.0.0.0 0.0.0.0」で指定されてデフォルトルートを伝搬(再配布)することができません。その為、IGRPでは、「ip default-network」コマンドを使用して、デフォルトルートを伝搬する必要があります。

「ip default-network」コマンドを使うと、IGRPネットワーク内にデフォルトルートを伝播させることができます。

Router(config)#ip default-network {ネットワーク番号}

 「ip default-network」コマンドで指定したネットワークへのルートがデフォルトルートになります。指定したネットワークへ到達する為のネクストホップルータのIPドレスが「Gateway of last resort」になります。

※ただし、デフォルトゲートウェイへの境界ルータのインタフェースがUPしていなければなりません。上の図の場合、Router_AのS0インタフェースがUPしている必要があります。

●Router_Aにて

Router_A(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.1
Router_A(config)#ip default-network 172.16.0.0

 「ip route 0.0.0.0 0.0.0.0 172.16.1.1」と設定していますが、Router_A自身のデフォルトルートが必要な為、ここでは設定しています。

Router_A(config)#rotuer igrp 1
Router_A(config-router)#network 172.16.0.0
Router_A(config-router)#network 172.17.0.0

 ここでは、IGRPは、「ip route 0.0.0.0 0.0.0.0」を伝播しないため、「network 172.16.0.0」コマンドを使用しています。

●Router_Bにて

Router_Bでは、デフォルトルートの設定は必要ありません。Router_Aから伝播してきます。

●ISPの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname ISP
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 10.0.0.1 255.0.0.0
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.1.1 255.255.0.0
 bandwidth 64
 clockrate 64000
!
ip classless
ip route 172.17.0.0 255.255.255.0 172.16.1.2
ip route 172.18.0.0 255.255.255.0 172.16.1.2
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Serial0
 ip address 172.16.1.2 255.255.0.0
 bandwidth 64
 no fair-queue
!
interface Serial1
 ip address 172.17.1.1 255.255.0.0
 bandwidth 64
 clockrate 64000
!
router igrp 1
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
ip default-network 172.16.0.0
ip route 0.0.0.0 0.0.0.0 172.16.1.1
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 172.18.1.1 255.255.0.0
!
interface Serial0
 ip address 172.17.1.2 255.255.0.0
 bandwidth 64
!
router igrp 1
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、RouterBのルーティングテーブルを確認します。

●Router_Aの「show ip route」の出力
Gateway of last resort is 172.16.1.1 to network 0.0.0.0

C*   172.16.0.0/16 is directly connected, Serial0
C    172.17.0.0/16 is directly connected, Serial1
I    172.18.0.0/16 [100/158350] via 172.17.1.2, 00:00:40, Serial1
S*   0.0.0.0/0 [1/0] via 172.16.1.1

「ip default-network 172.16.0.0」で指定したネットワークには「*」でマークが付けられています。

●Router_Bの「show ip router」の出力
Gateway of last resort is 172.17.1.1 to network 172.16.0.0

I*   172.16.0.0/16 [100/160250] via 172.17.1.1, 00:00:15, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

IGRPによってRouter_Aからデフォルトルートが伝播されてきたことが確認できます。

Router_Bからpingを打って動作確認してみます。

●Router_Bの「ping」の出力
Router_B#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/58/64 ms
Router_B#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/58/64 ms

次の「EIGRP(デフォルトルートの伝播)」では、EIGRPのデフォルトルートの伝播について紹介します。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
RIP(デフォルトルートの伝播)
IGRP(デフォルトルートの伝播)
EIGRP(デフォルトルートの伝播)
OSPF(デフォルトルートの伝播)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.