@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > RIPv2(平文認証)その1

 Amazon
@network Cisco・アライド実機で学ぶ
◆RIPv2(平文認証)その1

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆RIPv2(平文認証)その1

 RIPv1では、認証をサポートしていませんが、RIPv2では、認証をサポートしています。アップデートを交換する際に認証を行うことができます。認証は、EIGRPやOSPFなどでもサポートされています。

 この認証を行うことで、不正なルータからのアップデートの偽造や改ざんによるネットワークの混乱を防御することができます。認証の設定をしているルータ同士のみがアップデートを交換するようになります。

RIPv2の認証方法には、2通りあります。

・平文認証
・MD5認証

ここでは、RIPv2の平文認証を設定し、検証して行きます。

 平文による認証は、認証で使用する鍵が暗号化されずにクリアテキスト(平文)のままで送信されてしまいます。そのため、盗聴される危険性があります。

まずは、下図のネットワークをRIPv2で設定します。


各ルータの設定は下の通りです。

●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0/0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0/0
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
router rip
 version 2
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0/0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0/0
 ip address 172.17.0.2 255.255.0.0
!
router rip
 version 2
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end

Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0/0
C    172.16.0.0/16 is directly connected, Ethernet0/0
R    172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:09, Serial0/0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0/0
R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:17, Serial0/0
C    172.18.0.0/16 is directly connected, Ethernet0/0

正しく、Router_A、Router_Bにおいて、経路情報が交換されていることが確認できます。

続きは、次の「RIPv2(平文認証)その2」で平文認証を設定して行きます。

RIP V1、RIP V2の混在時」 ← 前項 | 次項 → 「RIPv2(平文認証)その2





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.