@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > RIP V1、RIP V2の混在時

 Amazon
@network Cisco・アライド実機で学ぶ
◆RIP V1、RIP V2の混在時

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆RIP V1、RIP V2の混在時

RIPv1、RIPv2が混在するネットワークでは、どんな状況になるのかを検証してみます。

ネットワーク構成図は、下の図を使用します。


Router_Aを、RIPv2で設定します。

Router_Bは、RIPv1で設定します。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router rip
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, Ethernet0
C    172.17.0.0/16 is directly connected, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:13, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

すると、Router_Aでは、RIPルートがないのに対して、Router_Bでは、RIPルートが存在します。

 デフォルトでは、Cisco IOSソフトウェアはRIPv1とRIPv2のパケットを受信しますが、送信するのはRIPv1パケットだけです。

 ネットワーク管理者は、ルータがRIPv1パケットだけを送受信するように設定したり、あるいはRIPv2パケットだけを送信するように設定したりすることができます。ルータが1つのバージョンのパケットだけを送受信するように設定するには、

「degub ip rip」コマンドをRouter_A、Router_B上で開始させます。

Router#degub ip rip

●Router_Aの「degub ip rip」の出力
Router_A#debug ip rip
RIP protocol debugging is on
Router_A#
RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.0.1)
     172.17.0.0/16 -> 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0 (172.17.0.1)
     172.16.0.0/16 -> 0.0.0.0, metric 1, tag 0
RIP: ignored v1 packet from 172.17.0.2 (illegal version)
RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.0.1)
     172.17.0.0/16 -> 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0 (172.17.0.1)
     172.16.0.0/16 -> 0.0.0.0, metric 1, tag 0
RIP: ignored v1 packet from 172.17.0.2 (illegal version)
RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.0.1)
     172.17.0.0/16 -> 0.0.0.0, metric 1, tag 0

Router_A上では

RIPv1のアップデートが、無視されているのが分かります。

●Router_Bの「degub ip rip」の出力
Router_B#debug ip rip
RIP protocol debugging is on
Router_B#
RIP: received v2 update from 172.17.0.1 on Serial0
     172.16.0.0/16 -> 0.0.0.0 in 1 hops
RIP: sending v1 update to 255.255.255.255 via Ethernet0 (172.18.0.1)
     network 172.16.0.0, metric 2
     network 172.17.0.0, metric 1
RIP: sending v1 update to 255.255.255.255 via Serial0 (172.17.0.2)
     network 172.18.0.0, metric 1
RIP: received v2 update from 172.17.0.1 on Serial0
     172.16.0.0/16 -> 0.0.0.0 in 1 hops
RIP: sending v1 update to 255.255.255.255 via Ethernet0 (172.18.0.1)
     network 172.16.0.0, metric 2
     network 172.17.0.0, metric 1

Router_B上では、RIPv2パケットが受信できていることが分かります。

 デフォルトで、RIPv1が設定されたCiscoルータは、RIPv1とRIPv2のパケットを受信し、RIP v1パケットだけ送信するみたいです。


◆インタフェースでの送受信の制御

インタフェースで送受信するパケットをどのように処理するかは、以下のコマンドにより制御できます。

router(config-if)ip rip send version {1|2|1 2}

router(config-if)ip rip receive version {1|2|1 2}

 Router_A、には、RIPルートがありませんから、Router_Aから「172.18.0.0/16」ネットワークへ対してのPingは、もちろん失敗します。

 当然と言えば、当然なのですが、RIPのバージョンが違うとルーティングを行うことができません。RIPv1、RIPv2でネットワークを構築する際には、バージョンを統一しておく必要があります。

RIPv2の設定」 ← 前項 | 次項 → 「RIPv2(平文認証)その1





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.