@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > デフォルトルートとは

 Amazon
@network Cisco・アライド実機で学ぶ
◆デフォルトルートとは

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆デフォルトルートとは

 スタティックルーティングでは、全てのネットワークへの経路を漏れなく設定する必要があります。ネットワークが小さければ、負担も小さいものとなりますが、規模が大きなネットワークともなると管理者の負担は大きなものとなります。

 そこで、デフォルトルートという特別なスタティックルートが用意されています。デフォルトルートは、「0.0.0.0/0」が全てのネットワークを表し、ルーティングテーブルの中に該当するエントリが見つからない場合に使用されます。

●デフォルトルートの設定

 デフォルトルートを指定するには、特別なネットワークアドレスと特別なサブネットマスクを使って設定します。「0.0.0.0/0」ネットワークを指定するのは、0ビット目まで一致するかチェックすることを意味しています。

 0ビット目まで一致するのかということは、言い換えると1ビットも見ないということです。つまり、無条件で全てのIPアドレスが、デフォルトルートのエントリーに一致することになります。

Router(config)#ip route 0.0.0.0 0.0.0.0 {ネクストホップ}

 「ip classless」を設定がないと、デフォルトルートが使われないのかを検証してゆくので、Cisco IOS 11.3以降を搭載しているルータを使う場合には、グローバル設定モードで「no ip classless」コマンドを入力ておいて下さい。

●デフォルトルートを無効化する

Router(config)#no ip classless

 デフォルトルートを使用する際は、「ip classless」コマンドを設定しておく必要があります。このコマンドを設定しておかないと未知のネットワークを宛先とするパケットをデフォルトルートに転送することができません。

 「ip classless」コマンドの設定がないと、例え、デフォルトルートが存在したとしても、そのパケットは、廃棄されてしまいます。

 Cisco IOS 11.3以降を搭載しているCiscoルータでは、デフォルトで、このコマンドが、設定されています。Cisco IOS 11.3より古いIOSを使用している場合は、このコマンドを設定しないとクラスレスルーティングやデフォルトルートを使うことができません。

 それでは、前の「スタティックルーティングの設定(その2)」で構築したネットワークを利用して、下の図のネットワークを構築し、「ip classless」を設定がないと、デフォルトルートが使われないのかを検証してゆきます。

デフォルトルートを無効にする「no ip classless」を忘れずに設定しておいて下さい。


各ルータで定義しなければならないルートの向きは、下のようになります。

 Router_A、Router_Cのルートの向きにに注目して下さい。全てのルートが一方通行です。上のネットワークは、小さなネットワークでルートの数が少なくて済みますが、規模が大きくなってくると、スタティックルートのエントリーが増えてきます。その際、全てのネットワークのエントリーを定義してゆくのは、とても面倒です。

そんな時に役立つのがデフォルトルートなのです!

Router_A Router_B Router_C
172.16.3.0/24 → ← 172.16.1.0/24   ← 172.16.1.0/24
172.16.3.0/24 →   172.16.4.0/24 → ← 172.16.2.0/24


 デフォルトルートは、主に上の図のように、インターネットに接続するルータで定義します。インターネット上の経路は、非常にたくさんあり、数万とも10万とも言われています。

 そのインターネット上の全てのルートを把握するのは、事実上、困難ですし、絶えず変化するネットワークにあわせてルータのルーティングテーブルをメンテナンスするのは神業です。

 また、インターネット上の全てのルートをルータのルーティングテーブルに載せるだけのルータのメモリもCPUパワーも不足します。仮に全部ルートを乗せれたとしても、膨大な負荷がルータにかかってしまうことになります。

●デフォルトルートの設定

デフォルトルートを指定するには、特別なネットワークアドレスと特別なサブネットマスクを使って設定します。

Router(config)#ip route 0.0.0.0 0.0.0.0 {ネクストホップ}

 「ip classless」を設定がないと、デフォルトルートが使われないのかを検証してみるので、Cisco IOS 11.3以降を搭載しているルータを使う場合には、グローバル設定モードで「no ip classless」コマンドを入力ておいて下さい。

●デフォルトルートを無効化する

Router(config)#no ip classless

●Router_Aのコンフィグ
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.2.1 255.255.255.0
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
no ip classless
ip route 0.0.0.0 0.0.0.0 172.16.2.2
!
line con 0
line aux 0
line vty 0 4
 login
!
end

●Router_Bのコンフィグ
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.2.2 255.255.255.0
 no fair-queue
!
interface Serial1
 ip address 172.16.3.1 255.255.255.0
 clockrate 64000
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.2.1
ip route 172.16.4.0 255.255.255.0 172.16.3.2
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

●Router_Cのコンフィグ
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_C
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.3.2 255.255.255.0
!
interface Serial1
 no ip address
 shutdown
!
no ip classless
ip route 0.0.0.0 0.0.0.0 172.16.3.1
!
line con 0
line aux 0
line vty 0 4
 login
!
end

PC_AからPC_BにPingしてみましょう!Pingが失敗します。

デフォルトルートが、使われるようにデフォルトルートを有効化しましょう!

●デフォルトルートを有効化する

Router(config)#ip classless

PC_AからPC_BにPingしてみましょう!こんどは、Pingが成功するはずです。

デフォルトルートを使用する際は、「ip classless」が設定されているか確認しておきましょう!

スタティックルーティングの設定(その2)」 ← 前項 | 次項 → 「ダイナミックルーティングとは





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.