@network Cisco・アライド実機で学ぶ > ICND2実機で学ぶ > NAT(ダイナミックNAT)

 Amazon
@network Cisco・アライド実機で学ぶ
◆NAT(ダイナミックNAT)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。



◆NAT(ダイナミックNAT)

ここでは、ダイナミックNATの設定を紹介します。

ネットワーク構成は、下図のようになります。

ちなみにルータは、以下のもの使用しています。

Router_A ・・・ Cisco 1720(Cisco 1721)
Router_B ・・・ Cisco 2501


 LAN内部のPC1、PC2をダイナミックNATによって内部グローバルアドレス200.1.1.1〜200.1.1.10に変換させます。

●ダイナミックNATの設定

 ダイナミックNATで内部ローカルアドレスと内部グローバルアドレスの変換を行うには、「ip nat pool」コマンドで指定します。使用する内部グローバルアドレスの範囲に名前を付けます。この名前をプールと呼びます。

Router(config)#ip nat pool {プール名} {開始IPアドレス} {終了IPアドレス} netmask {サブネットマスク}

●アクセスリストの設定

 「ip nat pool」コマンドで指定した内部グローバルアドレスを使用することを許可する送信元アドレスをアクセスリストで指定します。

Router(config)#access-list {番号} permit {送信元IPアドレス} {ワイルドカードマスク}

●ダイナミックNATとアクセスリストをマッピングする

Router(config)#ip nat inside source list {番号} pool {プール名}

●内部ローカルネットワークの設定

 LAN側に接続されているルータのインタフェースに、「ip nat inside」コマンドを使ってスタティックNATを有効にします。

Router(config-if)#ip nat inside

●内部グローバルネットワークの設定

 インターネット側に接続されているルータのインタフェースに、「ip nat outside」コマンドを使ってスタティックNATを有効にします。

Router(config-if)#ip nat outside


ルータの設定

Router_A、Router_Bで次の設定を行います。

●Router_A

Router_A(config)#ip nat pool DNAT 200.1.1.1 200.1.1.10 netmask 255.255.255.0
Router_A(config)#access-list 1 permit 172.16.1.0 0.0.0.255
Router_A(config)#ip nat inside source list 1 pool DNAT

Router_A(config)#int f0
Router_A(config-if)#ip nat inside

Router_A(config)#int s0
Router_A(config-if)#ip nat outside

●Router_B

Router_A(config)#ip route 200.1.1.0 255.255.255.0

●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Serial0
 ip address 10.1.1.1 255.255.255.0
 ip nat outside
 clockrate 64000
!
interface FastEthernet0
 ip address 172.16.1.1 255.255.0.0
 ip nat inside
 speed auto
!
ip nat pool DNAT 200.1.1.1 200.1.1.10 netmask 255.255.255.0
ip nat inside source list 1 pool DNAT
ip classless
no ip http server
!
access-list 1 permit 172.16.1.0 0.0.0.255
!
line vty 0 4
 password cisco
 login
!

●Router_Bの設定
!
hostname Router_B
!
enable password cisco
!
interface Serial0
 ip address 10.1.1.2 255.255.255.0
 no fair-queue
!
ip classless
ip route 200.1.1.0 255.255.255.0 10.1.1.0
logging buffered
!
line vty 0 4
 password cisco
 login
!

●NATテーブルの確認

現在のNATテーブルを確認するには「show ip nat translations」コマンドを使います。

Router#show ip nat translations

それでは、NATテーブルを確認するために、PC1、PC2から、Router_BへPingを行います。

Router_Aで「show ip nat translations」コマンドを入力します。

●「show ip nat translations」コマンドの出力
Router_A#show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
--- 200.1.1.1          172.16.1.2         ---                ---
--- 200.1.1.2          172.16.1.3         ---                ---

NAT(スタティックNAT)」 ← 前項 | 次項 → 「NAT(PAT オーバーローディング)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
ICND2実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.