@network Cisco・アライド実機で学ぶ > ICND2実機で学ぶ > OSPF(DR・BDRの選出 プライオリティ)

 Amazon
@network Cisco・アライド実機で学ぶ
◆OSPF(DR・BDRの選出 プライオリティ)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。



◆OSPF(DR・BDRの選出 プライオリティ)

 ここでは、OSPFルータに優先度(PRIORITY)を設定した際にDR、BDRの選出において、どのように影響されるかを検証してゆきます。

DR、BDRについては、「OSPF(DR・BDRの選出)」で解説しています。

OSPF(DR・BDRの選出)」でも解説したように、DR、BDRの選出については、次の3つの項目に着目します。

1.優先度(PRIORITY)
2.ループバックインタフェースのIPアドレス
3.物理インタフェースのIPアドレス(アクティブなインタフェースで最も大きいもの)


優先度 > ループバックインタフェースのIPアドレス > 物理インタフェースIPアドレス

の順に注目してゆけばどのルータがDR、BDRに選出されるのかが分かります


それでは、下の図のネットワークをOSPFで構築して確認してみます。


 Router_Aでプライオリティ値を設定しています。Router_B、Router_Cのプライオリティティは、デフォルトの「1」になるので、Router_Aのプライオリティ値が最も高いことになります。DRは、Router_Aが選択されるはずです。

 残りのRouter_B、Router_Cは、プライオリティ値が同じになるので、ルータIDの大きさで決まることになります。Router_Bには、ループバックアドレスが設定されています。Router_Cは、ループバックアドレスが設定されていないのでアクティブなインタフェースのIPアドレスで最大のIPアドレスが、ルータIDになります。

そうすると各ルータのルータIDは次のようになります。

Router_AのルータID ・・・ 192.168.1.1(プライオリティ50)
Router_BのルータID ・・・ 200.200.200.200
Router_CのルータID ・・・ 192.168.1.3

ということは、

Router_A ・・・ DR
Router_B ・・・ BDR
Router_C ・・・ DROTHER

になるはずです。

DR、BDRが、このように選択されるか、各ルータを設定してみましょう!

●プライオリティの設定

 OSPFで、プライオリティをデフォルト値の「1」から変更するには、インタフェースのインタフェース設定モードで「 ip ospf priority」コマンドを使います。

Router(config-if)#ip ospf priority {プライオリティ値}

プライオリティ値は、0〜255の間で設定できます。プライオリティ値を「0」にすると、DR、BDRに選出されないようになります。

●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip ospf priority 50
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 0
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 200.200.200.200 255.255.255.255
!
interface Ethernet0
 ip address 192.168.1.2 255.255.255.0
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 0
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end

●Router_Cの設定
!
hostname Router_C
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.1.3 255.255.255.0
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 0
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end

 各ルータの設定が完了したら、各ルータで「copy run start」して設定を保存し、Router_A〜Router_Cの電源を切り、ほぼ同じタイミングで電源を入れます。これは、DR、BDRは、一度、DR、BDRが決定すると、DR、BDRがダウンするまで新しいDR、BDRが選出されないからです。

 設定した順番、もしくは電源を入れた順番でDR、BDRが決定されてしまった場合、後から設定したルータや後から追加したルータは、DR、BDRに選出されません。

「show ip ospf neighbor」コマンドを使って、どのルータがDR、BDRに選出されてか確認してみましょう!

●Router_Aの「show ip ospf neighbor」の出力
Router_A#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.3       1   FULL/DROTHER    00:00:34     192.168.1.3     Ethernet0
200.200.200.200   1   FULL/BDR        00:00:33     192.168.1.2     Ethernet0

●Router_Bの「show ip ospf neighbor」の出力
Router_B#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.1      50   FULL/DR         00:00:35    192.168.1.1     Ethernet0
192.168.1.3       1   FULL/DROTHER    00:00:33    192.168.1.3     Ethernet0

●Router_Cの「show ip ospf neighbor」の出力
Router_C#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
200.200.200.200   1   FULL/BDR        00:00:37     192.168.1.2     Ethernet0
192.168.1.1      50   FULL/DR         00:00:30     192.168.1.1     Ethernet0

 「show ip ospf neighbor」コマンドの出力から分かるように、各ルータは下のようになっていることが確認できます。

Router_A ・・・ DR
Router_B ・・・ BDR
Router_C ・・・ DROTHER

OSPF(DR・BDRの選出 ループバックアドレス)」 ← 前項 |





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
ICND2実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.