@network Cisco・アライド実機で学ぶ > ICND2実機で学ぶ > OSPF認証(ip ospf authentication-key)

 Amazon
@network Cisco・アライド実機で学ぶ
◆OSPF認証(ip ospf authentication-key)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。



◆OSPF認証(ip ospf authentication-key)

 「OSPFの設定例1」で構築した下のネットワークをそのまま使います。ここでは、OSPFの認証について紹介します。Ciscoルータは、特定のエリア内のルータ同士を認証するように設定することができます。

認証を設定するには、2つの方法があります。

●パスワードをクリアテキストで送る方法
●パスワードをメッセージダイジェスト(MD)で送る方法

ここでは、「パスワードをクリアテキストで送る方法」について紹介します。

まずは、下の図のようにネットワークを構築してみましょう!


●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.255.252
 bandwidth 64
 clockrate 64000
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.0.3 area 0
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 192.168.3.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.2 255.255.255.252
 bandwidth 64
!
router ospf 1
 network 192.168.3.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.0.3 area 0
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end


クリアテキストによるパスワード認証

クリアテキストによるパスワード認証を行うためには、以下のコマンドを設定します。

Router(config-if)#ip ospf authentication-key {パスワード}

※パスワード長さは、最大8文字です。

次に、設定したパスワードで認証するように、認証を有効にします。

Router(config)#router ospf {プロセス番号}
Router(config-router)#area {エリア番号} authentication


Router_Aにおいて

それでは、Router_Aで認証を設定してみます。

Router_A(config)#int s0
Router_A(config-if)#ip ospf authentication-key CCNA
Router_A(config-if)#exit
Router_A(config)#router ospf 1
Router_A(config-router)#area 0 authentication


しばらく、経過してから、Router_A、Router_Bのルーティングテーブルを確認します。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Ethernet0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    192.168.3.0/24 is directly connected, Ethernet0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, Serial0

 OSPFのルートが消えています。それは、Router_Bに認証の設定が、まだ、されていないからです。そのため、認証で失敗しています。


Router_Bにおいて

Router_Bで認証を設定します。

Router_B(config)#int s0
Router_B(config-if)#ip ospf authentication-key CCNA
Router_B(config-if)#exit
Router_B(config)#router ospf 1
Router_B(config-router)#area 0 authentication

しばらく、経過してから、Router_A、Router_Bのルーティングテーブルを確認します。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Ethernet0
O    192.168.3.0/24 [110/1572] via 172.16.0.2, 00:00:33, Serial0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

O    192.168.1.0/24 [110/1572] via 172.16.0.1, 00:00:03, Serial0
C    192.168.3.0/24 is directly connected, Ethernet0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, Serial0

Router_A、Router_Bのお互い同士で、認証されるので、OSPFのルートが追加されます。

 「ip ospf authentication-key」による認証の設定は、クリアテキストによるパスワード認証です。パスワードは、パケットキャプチャで読み取られてしまう恐れがあります。

 次の「OSPF認証(ip ospf message-digest-key)」では、MD5による暗号化したパスワードの認証を紹介します。

OSPF(debugコマンド)」 ← 前項 | 次項 → 「OSPF認証(ip ospf message-digest-key)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
ICND2実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.