@network Cisco・アライド実機で学ぶ > ICND2実機で学ぶ > ACL(ICMP)

 Amazon
@network Cisco・アライド実機で学ぶ
◆ACL(ICMP)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。



◆ACL(ICMP)

拡張IPアクセスリストを使用すれば、ICMP通信を制御することができます。

拡張IPアクセスリストの構文は以下のようになります。

 Router(config)#access-list {番号} {permit | deny} {プロトコル} {送信元IP} {送信元ワイルドカードマスク} {宛先IP} {宛先ワイルドカードマスク} [オプション]

プロトコルのところで「icmp」を指定します。


 宛先が「192.168.1.0/24」ネットワークへのICMPエコー要求を禁止し、その他のトラフィックは通す設定を行ってみます。

●Router_Aのアクセスリストの設定

Router_A(config)#access-list 100 deny icmp any 192.168.1.0 0.0.0.255 echo
Router_A(config)#access-list 100 permit ip any any

Router_A(config)#int e0
Router_A(config-if)#ip access-group 100 out

●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip access-group 100 out
!
interface Ethernet1
 ip address 192.168.2.1 255.255.255.0
!
ip classless
access-list 100 deny   icmp any 192.168.1.0 0.0.0.255 echo
access-list 100 permit ip any any
!
line vty 0 4
 password cisco
 login
!
end

 PC2からPC1へPingをすると失敗します。それは、拡張IPアクセスリストによって、ICMPエコー要求がブロックされているからです。

それでは、Router_AからPC1にPingを行った場合は、どうなるでしょうか?

 続きは、次の「ACL(ルータの発行コマンド時の注意)」でルータから発行するコマンドにおける注意点について説明します。

ACL アクセスクラス(access-class)」 ← 前項 | 次項 → 「ACL(ルータの発行コマンド時の注意)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
ICND2実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.