@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > BGP(経路情報流入による過負荷を防ぐ1)

 Amazon
@network Cisco・アライド実機で学ぶ
◆BGP(経路情報流入による過負荷を防ぐ1)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆BGP(経路情報流入による過負荷を防ぐ1)

 今日のインターネットで最も一般的に使用されているEGPは、BGPです。自律システムの大半で使用されており、推定で、約95%がBGPを使用されていると言われています。

 インターネットのルーティングを実現するためには、インターネット上の大量の経路情報を扱う必要があります。そのため、BGPでは、大量の経路情報を扱います。つまり、BGPを扱うルータには、それなりのリソースが求められる訳です。ルータのCPUやメモリなどが十分でなければ、ルータは過負荷状態となってしまいます。

 インターネット上の経路は、数十万ルートとも言われており、BGPを扱うことで、それら大量の経路情報がルータに流入した場合、どうでしょうか。

たちまち、大量の経路情報が流入したルータでは、メルトダウン状態となってしまいます。

 下のネットワーク構成図を見て下さい。ISP1、ISP2ではBGPを使用しています。ISP1に接続する企業AのRouter_AにBGPの大量の経路情報が流入した場合を考えてみます。

 企業Aのルータは、企業内Aのトラフィックを処理できる能力があれば良いため、企業Aは、インターネット上のルーティングに耐えうる性能を持ったルータをわざわざ用意する必要はありません。

 そこそこの性能のRouter_AにISP1から大量のBGPの経路情報が流入した場合、たちまち、Router_Aはメルトダウンしてしまいかねません。そもそも企業Aのルータは、インターネット上の大量の経路情報を扱ったり、インターネット上に流れている大量のトラフィックを処理しなければならない義務はありません。

そこで、企業AのRouter_Aには、BGPの設定を行わず、ISP1へのデフォルトルートを設定することになります。

それでは、下図のネットワークを構築してゆきましょう。


●Router_Aの設定

ISP1へのデフォルトルートを設定します。

Router_A(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.2

●ISP1の設定

ISP1で、顧客である企業Aのネットワークへのスタティックルートを設定します。

ISP1(config)#ip route 192.168.1.0 255.255.255.0 172.16.0.1

ISP1にBGPの設定を行います。

・AS100内の「192.168.1.0/24」のルートをAS200に通知する。
・AS100内の「192.168.100.0/24」のルートをAS200に通知する。

ISP1(config)#router bgp 100
ISP1(config-router)#neighbor 10.10.10.2 remote-as 200
ISP1(config-router)#network 192.168.1.0
ISP1(config-router)#network 192.168.100.0
ISP1(config-router)#no synchronization
ISP1(config-router)#no auto-summary

●ISP2の設定

ISP2にBGPの設定を行います。

・AS200内の「192.168.200.0/24」のルートをAS200に通知する。

ISP2(config)#router bgp 200
ISP2(config-router)#neighbor 10.10.10.1 remote-as 100
ISP2(config-router)#network 192.168.200.0
ISP2(config-router)#no synchronization
ISP2(config-router)#no auto-summary

●各ルータの設定

それでは、ルータを設定してゆきます。各ルータの設定は、下のようになります。

 強制的にインタフェースをUPさせるために、Router_AのE0インタフェースで「no keepalive」コマンドを設定しておきます。

●Router_Aの設定
!
version 11.2
!
hostname Router_A
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.0.1 255.255.0.0
 clockrate 64000
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.2
!
end

●ISP1の設定
!
version 11.2
!
hostname ISP1
!
interface Ethernet0
 ip address 192.168.100.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.0.2 255.255.0.0
!
interface Serial1
 ip address 10.10.10.1 255.255.255.0
 clockrate 64000
!
router bgp 100
 no synchronization
 network 192.168.1.0
 network 192.168.100.0
 neighbor 10.10.10.2 remote-as 200
 no auto-summary
!
ip classless
ip route 192.168.1.0 255.255.255.0 172.16.0.1
!
end

●ISP2の設定
!
version 11.2
!
hostname ISP2
!
interface Ethernet0
 ip address 192.168.200.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 200
 no synchronization
 network 192.168.200.0
 neighbor 10.10.10.1 remote-as 100
 no auto-summary
!
ip classless
!
end

この続きは、「BGP(経路情報流入による過負荷を防ぐ1)」で、設定した内容を検証してゆきます。

BGP(トランジットトラフィック)」 ← 前項 | 次項 → 「BGP(経路情報流入による過負荷を防ぐ1)





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.