@network Cisco・アライド実機で学ぶ > CCENT(ICND1)実機で学ぶ > ログインバナー(banner login)その1

 Amazon
@network Cisco・アライド実機で学ぶ
◆ログインバナー(banner login)その1

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆ログインバナー(banner login)その1

Ciscoルータには、各種の「バナー」を設定を行うことができます。

@MOTDバナー(Message of the Day)
 こちらは、一般的に利用されるバナーです。コンソールポート、補助ポート、Telnetを介して
ルータに接続した際に表示されます。

バナーメッセージ・インタフェースの説明文」で紹介しています。こちらを参考にしてみて下さい。

A ログインバナー
 パスワード認証プロンプトの前に表示されるメッセージです。

このメッセージは、ユーザに、ルータへのアクセス権限や注意事項を通知するのに使用されます。

Router(config)#banner login {区切り文字} <メッセージ> {区切り文字}

「区切り文字」は、何でもいいのですが、一般的には「#」を使います。

それでは、ログインバナーの設定を行ってゆきます。

使用するネットワークは、下図になります。


◆基本設定

Router#conf t
Router(config)#hostname Router_A
Router_A(config)#int f0
Router_A(config-if)#ip address 192.168.1.1 255.255.255.0
Router_A(config-if)#no shutdown
Router_A(config-if)#exit
Router_A(config)#line vty 0 4
Router_A(config-line)#password cisco
Router_A(config-line)#login
Router_A(config-line)#exit
Router_A(config)#enable password cisco


◆ログインバナーの設定

ログインバナーに、「Please do not access this router excluding the manager.」を設定します。

Router_A(config)#banner login # Please do not access this router excluding
$ do not access this router excluding the manager. #

※「$」は、入力コマンドが長い為、左にスクロールしたことを意味します。

これで、Router_Aの設定は完了です。

●Router_Aの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
interface Ethernet0
 no ip address
 shutdown
 half-duplex
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
banner login ^C Please do not access this router excluding the manager. ^C
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

設定の検証は、次の「ログインバナー(banner login)その2」で行ってゆきます。

バナーメッセージ・インタフェースの説明文」 ← 前項 | 次項 → 「ログインバナー(banner login)その2





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
CCENT(ICND1)実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
CCENT・CCNA無線実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール
PLCでホームネットワーク構築

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.