@network Cisco・アライド実機で学ぶ > SDMで設定する(Cisco実機で学ぶ) > URLリストのインポート(その8)

 Amazon
@network Cisco・アライド実機で学ぶ
◆URLリストのインポート(その8)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆URLリストのインポート(その8)

 「URLリストのインポート(その1)」から「URLリストのインポート(その7)」で、URLリストをインポートすることでURLフィルタリングの設定と検証を行いました。

ここでは、URLリストの管理についてとRouter_Aのコンフィグを紹介します。

 URLリストのインポートで説明している内容の多くは、「URLフィルタリング(その1)」〜「URLフィルタリング(その8)」で説明している内容と同じです。

 既に「URLフィルタリング(その1)」〜「URLフィルタリング(その8)」を閲覧されている方は、読み飛ばしながらページを進めて行って下さい。

ネットワークの構成は、下図の通りです。

※ブロードバンドルータには、IPマスカレードの設定をしておきます。


◆URLリストの管理について

URLリストは、Excelなどの表計算ソフトで管理をすると運用が楽です。

URLリストを追加したり、編集することが容易だからです。

 また、「csv形式のファイル」で保存することで、SDMを使用すれば簡単にルータにURLリストを取り込むこともできます。


アクセスを許可するサイト、拒否するサイトは、ずっと固定して運用するようには、ならないと思います。

 アクセスを許可する許可しないかは、社内のセキュリティポリシーの変更に伴って変更することもあるでしょうし、業務に関係のないサイトへのアクセスを監視して、それをURLフィルタリングに反映させることもあるからです。


◆Router_Aの設定

Router_Aの設定は、以下の通りです。

●Router_Aの設定
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 25
!
ip cef
ip inspect name URL_FILTER http urlfilter
ip urlfilter allow-mode on
ip urlfilter exclusive-domain deny www.goo.ne.jp
ip urlfilter exclusive-domain deny www.yahoo.co.jp
!
crypto pki trustpoint TP-self-signed-2739943660
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2739943660
 revocation-check none
 rsakeypair TP-self-signed-2739943660
!
crypto pki certificate chain TP-self-signed-2739943660
 certificate self-signed 01
  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32373339 39343336 3630301E 170D3032 30333031 30303032
  30395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37333939
  34333636 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100E450 534A3F93 AC9E211C 4E5767B7 9082B456 07F68302 5A03B6DB 966BAEAA
  738F9405 430AB362 9529C2BE E9A53687 F4A1CD55 7B403BEB 4AB2DE30 00768B05
  62FE8C13 72F57882 FD08767E 5055BE83 EC2264B6 E0D53E3A 0E726229 6ACDF1D2
  8F7BDAEA FB7D84B4 EECEB4E6 22947723 DD025C90 B6DFAF4B E294ED0E 867310E7
  0C030203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603
  551D1104 0C300A82 08526F75 7465725F 41301F06 03551D23 04183016 80147C20
  0C94D62F B5B0D917 7CED41A8 73C928FC E2CF301D 0603551D 0E041604 147C200C
  94D62FB5 B0D9177C ED41A873 C928FCE2 CF300D06 092A8648 86F70D01 01040500
  03818100 D54341F5 CCB82C1C F4E481BA B3329F7F 14DECFD5 FF9ADCA6 09F08AE7
  1A11B27B 0DD9E01E 73AF9F73 1B42EE2B D839B97A 20248CA4 77C2DA4F 809575D6
  286E4ED9 0EF2E73F 92E19B5C B221A896 829200BE 76E80342 E1D03F4F 5F3C9BB6
  A44F0B09 5581551A 6F66E7CC C08043E9 A645D164 ECF84CC0 1766F1D5 CB0C6508 77829C17
  quit
username ccnaccnp privilege 15 secret 5 ccnaccnp
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 half-duplex
!
interface FastEthernet0
 ip address 192.168.2.1 255.255.255.0
 ip inspect URL_FILTER in
 speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip http server
ip http authentication local
ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
!
end

最後に、URLフィルタリングは、IOSが対応していなければ、設定することはできません。



スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連コンテンツ>
URLリストのインポート(その1)
URLリストのインポート(その2)
URLリストのインポート(その3)
URLリストのインポート(その4)
URLリストのインポート(その5)
URLリストのインポート(その6)
URLリストのインポート(その7)
URLリストのインポート(その8)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.