@network Cisco・アライド実機で学ぶ > SDMで設定する(Cisco実機で学ぶ) > NAT(その4)

 Amazon
@network Cisco・アライド実機で学ぶ
◆NAT(その4)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆NAT(その4)

NATの設定と検証を「NAT(その1)」〜「NAT(その3)」で行いました。

ここでは、各ルータのコンフィグを紹介します。

設定したネットワークは、以下の通りです。


●Router_Aの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
crypto pki trustpoint TP-self-signed-2739943660
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2739943660
 revocation-check none
 rsakeypair TP-self-signed-2739943660
!
crypto pki certificate chain TP-self-signed-2739943660
 certificate self-signed 01
  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32373339 39343336 3630301E 170D3032 30333031 31363139
  32375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37333939
  34333636 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BC4A 0528D3AC 16211608 A647D349 70E7DEBB 97640F6D 96849B6C 271E048D
  C4B75A96 0667039F E980E37F 951F490C 45BE8019 FD578424 5C82F063 22CF60F9
  2CA90997 2B19A8F0 CD45F198 57BE15AB 9B8813D7 79373EF4 CC0CD6E8 6AB82C15
  0CFC1D5E 03E0E5C1 DBF7CC5E 53ABB231 6EB8045F DFF97264 06378273 3783883D
  23630203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603
  551D1104 0C300A82 08526F75 7465725F 41301F06 03551D23 04183016 8014C04E
  ED17B8F7 E234694B FDAEBB92 7C789BB3 ED6A301D 0603551D 0E041604 14C04EED
  17B8F7E2 34694BFD AEBB927C 789BB3ED 6A300D06 092A8648 86F70D01 01040500
  03818100 A5B33C38 84F00E07 5C922C94 A18DCA48 69983B8C 2D192BC8 FE1909CA
  66759014 31EC174C 42384838 760F54F8 219024B3 5D061D4E ACB851E6 5421BAC6
  B498A6B7 58508C9A F1EC1B26 EB686F7E E8762F5D 0970311D 91CAFF98 114C2DCC
  F51AE734 ECE408FC 588CCB29 EB4B6484 15A10E55 E15A450C 35A099CB 42BD54EA E3DB771C
  quit
username ccnaccnp privilege 15 secret 5 ccnaccnp
!
interface Ethernet0
 description $ETH-LAN$
 ip address 200.200.200.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 half-duplex
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 speed auto
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 1 interface Ethernet0 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
!
end


●Router_Bの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_B
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
crypto pki trustpoint TP-self-signed-3359589021
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3359589021
 revocation-check none
 rsakeypair TP-self-signed-3359589021
!
crypto pki certificate chain TP-self-signed-3359589021
 certificate self-signed 01
  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33333539 35383930 3231301E 170D3032 30333031 31303333
  33395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 33353935
  38393032 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100D397 56C899D6 975D8A81 8A7C5368 9D059263 2D3E6D13 F779C311 30A46984
  5C899D4B 5F1B8DDA EFDE6A0F 37C7DE54 60E5B0C0 FAC89345 AEE45841 373AF772
  AAE7506C E6801C33 5D93280F 445FEED5 8CD3BDC8 534BB86B 7A54F2D5 B9A14F12
  155CD017 E957B4FC 9BF36423 63BFDCF2 09233636 3E1A634A C52F303F 07AF0FF8
  1DB30203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603
  551D1104 0C300A82 08526F75 7465725F 42301F06 03551D23 04183016 8014506B
  CA631E77 2652A981 A64E9334 CE9C0EA5 128F301D 0603551D 0E041604 14506BCA
  631E7726 52A981A6 4E9334CE 9C0EA512 8F300D06 092A8648 86F70D01 01040500
  03818100 1FC82CE2 2EB28AE4 E1D60B33 B99E45AF BBC2DD33 5490D87B F3E1C703
  7E0219B0 B4AF9C7C 83AE9C40 E57C3B7F E80A8D79 8DB676E5 FDE744B5 1CC92F7F
  F3C7C69E D90A4AB9 F48C634F AA0F310E 7B848A2B 9726C476 97CD13A4 839EA434
  9FDB10D5 515F9402 97746319 5D031C99 9515DB02 606D7819 B355901A 12184BA7 99413D0D
  quit
username ccnaccnp privilege 15 secret 5 ccnaccnp
!
interface Ethernet0
 description $ETH-LAN$
 ip address 200.200.200.2 255.255.255.0
 half-duplex
!
interface FastEthernet0
 ip address 192.168.3.1 255.255.255.0
 speed auto
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
!
end

●コンフィグの解説

Router_Aのコンフィグの説明を行います。

 詳しくは、CLIにおけるNATの設定についての「NATの概要」〜「NATの検証コマンド」で説明しています。こちらを参考にして下さい。

・ip nat inside

変換元になります。外部からは「200.200.200.1」として見えます。

・ip nat outside

変換先になります。内部(Inside)と指定されたセグメントは、「Outside」側のIPアドレスに変換されます。

・ip nat inside source list 1 interface Ethernet0 overload

PATの設定です。Ethernet0をオーバーロードします。ポート番号までが変換対象となります。

・access-list 1 permit 192.168.1.0 0.0.0.255

NATの対象となる変換元のIPアドレスの範囲の指定です。

以上で、NATの設定と検証の解説を終わります。



スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
ARP・RARP・Proxy ARP(12項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連コンテンツ>
NAT(その1)
NAT(その2)
NAT(その3)
NAT(その4)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
SDMで設定する(Cisco実機で学ぶ)
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.