@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > PPPoE(設定例2 その4)

 Amazon
@network Cisco・アライド実機で学ぶ
◆PPPoE(設定例2 その4)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆PPPoE(設定例2 その4)

PPPoE(設定例2 その3)」の続きです。

ここでは、Router_Dを設定してゆきます。

※ネットワークの構成としては、NTTのフレッツADSL、B-Flet's経由でISPに接続する構成を想定しています。



◆Router_C-Router_D間のPPPoE認証の設定

Router_C-Router_D間のPPPoE認証の設定は、次の通りです。

PPPoE認証: chap
PPPoE認証ID: client2
PPPoE認証パスワード: cisco


◆Router_Aの設定

●初期設定

Router(config)#hostname Router_D
Router_D(config)#enable password cisco
Router_D(config)#line vty 0 4
Router_D(config-line)#password cisco
Router_D(config-line)#login
Router_D(config-line)#exit

●PPPoEを有効にする

まず、PPPoEを有効にします。

※vpdnコマンドは、IOS12.3以前とIOS12.4では、異なります。ここで、紹介するvpdnコマンドは、IOS12.3以前のものです。入力後、IOS12.4のコマンドに変換されます。

Router_D(config)#vpdn enable
Router_D(config)#vpdn-group PPPOE
Router_D(config-vpdn)#request-dialin
Router_D(config-vpdn-req-in)#protocol pppoe

●LAN側インタフェースの設定

Router_D(config)#interface fastEthernet 0
Router_D(config-if)#description LAN
Router_D(config-if)#ip address 192.168.1.254 255.255.255.0
Router_D(config-if)#ip tcp adjust-mss 1414
Router_D(config-if)#ip nat inside
Router_D(config-if)#no shutdown

●Internet側インタフェースの設定

 Internet側のインタフェースは、ISPからの払い出しでダイナミックに割り当てられるためIPアドレスを設定しません。

Router_D(config)#interface ethernet 0
Router_D(config-if)#description Internet
Router_D(config-if)#pppoe enable
Router_D(config-if)#pppoe-client dial-pool-number 1
Router_D(config-if)#no shutdown

●Dialerインタフェースの設定

論理インタフェースであるDialerインタフェースを作成し設定します。

PPPoE認証: chap
PPPoE認証ID: client2
PPPoE認証パスワード: cisco

Router_D(config)#interface dialer 1
Router_D(config-if)#ip address negotiated
Router_D(config-if)#ip mtu 1454
Router_D(config-if)#ip access-group 100 in
Router_D(config-if)#ip nat outside
Router_D(config-if)#dialer pool 1
Router_D(config-if)#dialer idle-timeout 0
Router_D(config-if)#dialer-group 1
Router_D(config-if)#encapsulation ppp
Router_D(config-if)#ppp authentication chap callin
Router_D(config-if)#ppp chap hostname client2
Router_D(config-if)#ppp chap password cisco
Router_D(config-if)#no shutdown

●NAT・dialer-list・デフォルトルート・アクセスリストの設定

NAT、dialer-list、デフォルトルート、アクセスリストの設定を行います。

 NATの設定については、静的NATの設定を行い、「192.168.1.1」→「Dialer1」インタフェースのIPアドレスに1対1で変換します。

Router_D(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router_D(config)#ip nat inside source static 192.168.1.1 interface dialer 1
Router_D(config)#dialer-list 1 protocol ip permit
Router_D(config)#ip route 0.0.0.0 0.0.0.0 dialer 1 permanent

●ファイアウォールの設定

●ACLによるIPスプーフィング対策
Router_D(config)#access-list 100 deny ip 0.0.0.0 0.255.255.255 any
Router_D(config)#access-list 100 deny ip 10.0.0.0 0.255.255.255 any
Router_D(config)#access-list 100 deny ip 127.0.0.0 0.255.255.255 any
Router_D(config)#access-list 100 deny ip 169.254.0.0 0.0.255.255 any
Router_D(config)#access-list 100 deny ip 172.16.0.0 0.15.255.255 any
Router_D(config)#access-list 100 deny ip 192.0.2.0 0.0.0.255 any
Router_D(config)#access-list 100 deny ip 192.168.0.0 0.0.0.255 any
Router_D(config)#access-list 100 deny ip 224.0.0.0 15.255.255.255 any
Router_D(config)#access-list 100 deny ip 240.0.0.0 15.255.255.255 any

 さらに、NETBIOS(ポート137〜139)、Windows共有サービス(SMB:ポート445)、TELNETを規制しておきます。

●ACLによるNETBIOS・Windows共有サービスのブロック
Router_D(config)#access-list 100 deny tcp any any range 137 139
Router_D(config)#access-list 100 deny tcp any range 137 139 any
Router_D(config)#access-list 100 deny udp any any range netbios-ns netbios-ss
Router_D(config)#access-list 100 deny udp any range netbios-ns netbios-ss any
Router_D(config)#access-list 100 deny tcp any any eq 445
Router_D(config)#access-list 100 deny tcp any eq 445 any
Router_D(config)#access-list 100 deny udp any any eq 445
Router_D(config)#access-list 100 deny udp any eq 445 any
Router_D(config)#access-list 100 deny tcp any any eq telnet
Router_D(config)#access-list 100 permit ip any any

各ルータのコンフィグは、次の「PPPoE(設定例2 その2)」で紹介します。




<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)


<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.