@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > PPPoE(設定例2 その2)

 Amazon
@network Cisco・アライド実機で学ぶ
◆PPPoE(設定例2 その2)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆PPPoE(設定例2 その2)

PPPoE(設定例2 その1)」の続きです。

ここでは、Router_Bを設定してゆきます。

※ネットワークの構成としては、NTTのフレッツADSL、B-Flet's経由でISPに接続する構成を想定しています。


◆Router_A-Router_B間のPPPoE認証の設定

Router_A-Router_B間のPPPoE認証の設定は、次の通りです。

PPPoE認証: chap
PPPoE認証ID: client1
PPPoE認証パスワード: cisco

◆Router_Bの設定

●初期設定

Router(config)#hostname Router_B
Router_B(config)#enable password cisco
Router_B(config)#line vty 0 4
Router_B(config-line)#password cisco
Router_B(config-line)#login
Router_B(config-line)#exit

●PPPoEクライアント認証の設定

Router_B(config)#username client1 password cisco

●PPPoEを有効にする

まず、PPPoEを有効にします。

※vpdnコマンドは、IOS12.3以前とIOS12.4では、異なります。ここで、紹介するvpdnコマンドは、IOS12.3以前のものです。入力後、IOS12.4のコマンドに変換されます。

Router_B(config)#vpdn enable
Router_B(config)#vpdn-group PPPOE
Router_B(config-vpdn)#accept-dialin
Router_B(config-vpdn-req-in)#protocol pppoe
Router_B(config-vpdn-acc-in)#virtual-template 1
Router_B(config-vpdn-acc-in)#local name client1
Router_B(config-vpdn)#

クライアントからのPPPoEネゴシエートを受け付けるように「accept-dialin」を指定します。

Router_B(config-vpdn)#accept-dialin

仮想インタフェース(virtual-template 1)とVPDNを関連付けます。

Router_B(config-vpdn-acc-in)#virtual-template 1

ユーザ名として、PPPoEの認証で使用する認証IDを指定します。

Router_B(config-vpdn)#local name client1

●Ethernet 0 インタフェースの設定

Router_B(config)#interface ethernet 0
Router_B(config-if)#ip address 200.200.200.1 255.255.255.0
Router_B(config-if)#pppoe enable
Router_B(config-if)#no shutdown

●fastEthernet 0 インタフェースの設定

Router_B(config)#interface fastEthernet 0
Router_B(config-if)#ip address 40.40.40.1 255.255.255.0
Router_B(config-if)#no shutdown

●loopback 0 インタフェースの設定

Router_B(config)#interface loopback 0
Router_B(config-if)#ip address 20.20.20.1 255.255.255.0
Router_B(config-if)#exit
Router_B(config)#interface loopback 1
Router_B(config-if)#ip address 30.30.30.1 255.255.255.0
Router_B(config-if)#exit

●仮想インタフェース(virtual-template)の設定

仮想インタフェースであるvirtual-templateインタフェースを作成し設定します。

Router_B(config)#ip local pool client1-pool 200.200.200.2
Router_B(config)#interface virtual-template 1
Router_B(config-if)#mtu 1454
Router_B(config-if)#ip unnumbered ethernet 0
Router_B(config-if)#peer default ip address pool client1-pool
Router_B(config-if)#ppp authentication chap
Router_B(config-if)#exit

PPPoEクライアントに付与するIPアドレスを指定します。付与するIPアドレスは、pool名と関連付けます。

プールするIPアドレスは、範囲を指定することもできます。

Router_B(config)#ip local pool client1-pool 200.200.200.2

仮想インタフェースのIPアドレスをE0インタフェースと兼用させるため「ip unnumbered」コマンドを使用します。

Router_B(config-if)#ip unnumbered ethernet 0

PPPoEクライアントに付与するIPアドレスのプールを指定します。

Router_B(config-if)#peer default ip address pool client1-pool

●BGP の設定

Router_B(config)#router bgp 100
Router_B(config-router)#no synchronization
Router_B(config-router)#neighbor 40.40.40.2 remote-as 200
Router_B(config-router)#network 20.20.20.0 mask 255.255.255.0
Router_B(config-router)#network 30.30.30.0 mask 255.255.255.0
Router_B(config-router)#network 40.40.40.0 mask 255.255.255.0
Router_B(config-router)#network 200.200.200.0 mask 255.255.255.0
Router_B(config-router)#exit

●再起動

 PPPoEサーバとなるRouter_Bを再起動させます。再起動しないとPPPoEサーバとして機能しない場合があります。

Router_B(config-if)#reload

Router_Cの設定は、次の「PPPoE(設定例2 その3)」で紹介します。




<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

PPPoEとは
PPPoE(ADSL・FTTH 基本設定 その2)
PPPoE(ADSL・FTTH 基本設定 その4)
PPPoE(設定例1 その1)
PPPoE(設定例1 その3)
PPPoE(設定例2 その1)
PPPoE(設定例2 その3)
PPPoE(設定例2 その5)
PPPoE(ADSL・FTTH 基本設定 その1)
PPPoE(ADSL・FTTH 基本設定 その3)
PPPoE(ADSL・FTTH 基本設定 その5)
PPPoE(設定例1 その2)
PPPoE(設定例1 その4)
PPPoE(設定例2 その2)
PPPoE(設定例2 その4)
PPPoE(設定例2 その6)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.