@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > PPPoE(ADSL・FTTH 基本設定 その3)

 Amazon
@network Cisco・アライド実機で学ぶ
◆PPPoE(ADSL・FTTH 基本設定 その3)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆PPPoE(ADSL・FTTH 基本設定 その3)

PPPoE(ADSL・FTTH 基本設定 その2)」の続きです。引き続き、PPPoEを設定してゆきます。


◆Router_Aの設定(続き)

●Dialerインタフェースの設定

論理インタフェースであるDialerインタフェースを作成し設定します。

Router_A(config)#interface dialer 1
Router_A(config-if)#ip address negotiated
Router_A(config-if)#ip mtu 1454
Router_A(config-if)#ip access-group 100 in
Router_A(config-if)#ip nat outside
Router_A(config-if)#dialer pool 1
Router_A(config-if)#dialer idle-timeout 0
Router_A(config-if)#dialer-group 1
Router_A(config-if)#encapsulation ppp
Router_A(config-if)#ppp authentication chap callin
Router_A(config-if)#ppp chap hostname user-id@isp-id
Router_A(config-if)#ppp chap password cisco
Router_A(config-if)#no shutdown

各コマンドの意味は、次のようになります。

ISPからの払い出しでダイナミックに割り当てられるため「negotiated」を指定します。

Router_A(config-if)#ip address negotiated

MTUは、「1454」を指定します。

Router_A(config-if)#ip mtu 1454


 

NTTのFlet'sでは、一般的に、「MTU=1454」、「MSS=1414」にします。

ネットワーク MTU MSS
Ethernet 1500 1460
RFC2516(PPPoE) 1492 1452
Flet's網(PPPoE) 1454 1414

 Dialer1インタフェースにアクセスリストを適用します。アクセスリスト100を「IN」に適用するには、「ip access-group」コマンドを使用します。

Router_A(config-if)#ip access-group 100 in

NAT(PAT)の設定を行います。インターネット側なので、「Outside」を指定します。

Router_A(config-if)#ip nat outside

物理インタフェース(Ethernet0)をDialerインタフェースにマッピングします。

Router_A(config-if)#dialer pool 1

常時接続のため、タイムアウト時間を「0」に設定します。

Router_A(config-if)#dialer idle-timeout 0

PPPoEを開始するトラフィックを指定します。「dialer list」と同じ番号を指定します。

Router_A(config-if)#dialer-group 1

PPPoEを使用するので、データリンク層のカプセル化には、PPPを指定します。

Router_A(config-if)#encapsulation ppp

PPPoE認証の設定を行います。ISPから支給されるユーザIDとパスワードを設定します。

Router_A(config-if)#ppp authentication chap callin
Router_A(config-if)#ppp chap hostname user-id@isp-id
Router_A(config-if)#ppp chap password cisco


●NAT・dialer-list・デフォルトルート・アクセスリストの設定

NAT、dialer-list、デフォルトルート、アクセスリストの設定を行います。

Router_A(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router_A(config)#ip nat inside source list 1 interface dialer 1 overload
Router_A(config)#dialer-list 1 protocol ip permit
Router_A(config)#ip route 0.0.0.0 0.0.0.0 dialer 1 permanent

各コマンドの意味は、次の通りです。

 NAT(PAT)の設定を行います。Dialer1インタフェースを「overload」するように指示します。NAT(PAT)を許可するセグメントには、LANセグメントを指定します。

Router_A(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router_A(config)#ip nat inside source list 1 interface dialer 1 overload

PPPoE通信のきっかけとなるパケットを指定します。ここでは、IPによる通信全てを対象にしておきます。

Router_A(config)#dialer-list 1 protocol ip permit

 インターネット向けのトラフィックは、全てDialer1を出力インタフェースとします。オプションの「permanent」は、常時このルートを指定するというオプションです。

Router_A(config)#ip route 0.0.0.0 0.0.0.0 dialer 1 permanent

続きの設定は、次の「PPPoE(ADSL・FTTH 基本設定 その4)」で紹介してゆきます。




<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)

<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

PPPoEとは
PPPoE(ADSL・FTTH 基本設定 その2)
PPPoE(ADSL・FTTH 基本設定 その4)
PPPoE(設定例1 その1)
PPPoE(設定例1 その3)
PPPoE(設定例2 その1)
PPPoE(設定例2 その3)
PPPoE(設定例2 その5)
PPPoE(ADSL・FTTH 基本設定 その1)
PPPoE(ADSL・FTTH 基本設定 その3)
PPPoE(ADSL・FTTH 基本設定 その5)
PPPoE(設定例1 その2)
PPPoE(設定例1 その4)
PPPoE(設定例2 その2)
PPPoE(設定例2 その4)
PPPoE(設定例2 その6)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.