@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > IEEE802.1X(SwimRadius編 その1)

 Amazon
@network Cisco・アライド実機で学ぶ
◆IEEE802.1X(SwimRadius編 その1)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。


◆IEEE802.1X(SwimRadius編 その1)

RADIUSを利用するには、以下のような方法があります。

●サーバOSを利用する方法

 LinuxやWindows Server 2003にRADIUSサービスプログラムをインストールして利用する方法です。詳しくは、「LinuxでRADIUSサーバを構築(FreeRADIUS)」「Server2003でRADIUSサーバ(その1)」で紹介しています。

●RADIUS機能を内蔵したネットワーク危機を利用する方法

 簡易RADIUSサーバを内蔵している製品があります。認証モードが限定されるなど、機能は限定されます。小規模オフィス向けです。

●RADIUSソフトウェアを利用する方法

 LinuxやWindows Server 2003にRADIUSサービスプログラムをインストールしてRADIUSサーバにしなくとも専用のソフトウェアを利用する方法があります。サーバOSが手元にない場合でも利用でき、簡単な操作でRADIUSサーバの本格的な機能が利用できます。

 少々値段が張りますが、PC上でのウィルスチェックソフトウェアの動作をチェックし、双方がOKの場合にのみネットワークへの接続を認める設定ができるなど豊富なポリシーで認証判断を行うことが可能です。


◆Swim Radius

 「SwimRadius」は、アライドテレシス(Allied Telesis)社製のRADIUS、およびIEEE 802.1X認証機能を提供するソフトウェアです。有料のソフトウェアですが、インストール後 30 日間のフリーライセンスで試すことができます。Windows XPへのインストールも可能です。

CentreCOM製品に限らずCisco製品でも、もちろん利用できます。

ここでは、以下のネットワークをRADIUSサーバに「SwimRadius」を使用して構築してゆきます。


 Switch_Aに繋がるPC_AをIEEE802.1Xで認証し、認証に合格したら、Switch_Aから先のLANへアクセスできるようにSwitchを設定してゆきます。

ここでは、まず、Switch_Aを設定してゆきます。

◆IEEE802.1Xの設定(Switch_A)

●AAAを有効にします。

Switch_A(config)#aaa new-model

●IEEE802.1X認証にRADIUSを指定します。

IEEE802.1X認証を指定します。「radius」、「tacacs+」などが指定できます。

Switch_A(config)#aaa authentication dot1x default group ?
  WORD     Server-group name
  radius   Use list of all Radius hosts.
  tacacs+  Use list of all Tacacs+ hosts.

IEEE802.1X認証には、RADIUSを指定します。

Switch_A(config)#aaa authentication dot1x default group radius

●IEEE802.1Xによる認証を有効にします。

Switch_A(config)#dot1x system-auth-control

●IEEE802.1Xによる認証を行うインタフェースの設定を行います。

今回は、PC_Aが接続する「f0/1」が認証ポートになります。

Switch_A(config)#interface fastEthernet 0/1

ポートで認証を行うには、「access」モードにしておく必要があります。

Switch_A(config-if)#switchport mode access

IEEE802.1X認証を「f0/1」ポートで有効にします。ここでは、「auto」を指定しておきます。

Switch_A(config-if)#dot1x port-control auto

●Switch_AにIPアドレスを設定します。

 Switch_Aは、オーセンティケータになります。RADIUSサーバと通信するためにIPアドレスの設定が必要になります。

Switch_A(config)#interface vlan 1
Switch_A(config-if)#ip address 192.168.1.50 255.255.255.0
Switch_A(config-if)#no shutdown
Switch_A(config-if)#exit

●RADIUSサーバとの通信設定

RADIUSサーバのIPアドレスを指定し、使用するポート番号を指定します。

Switch_A(config)#radius-server host 192.168.1.100 auth-port 1812 acct-port 1813 key cisco


●Switch_Aの設定
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch_A
!
aaa new-model
aaa authentication dot1x default group radius
enable password cisco
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
dot1x system-auth-control
!
interface FastEthernet0/1
 switchport mode access
 dot1x port-control auto
 spanning-tree portfast
!
 ・
(略)
 ・
!
interface Vlan1
 ip address 192.168.1.50 255.255.255.0
 no ip route-cache
!
ip http server
radius-server host 192.168.1.100 auth-port 1812 acct-port 1813 key cisco
radius-server retransmit 3
!
line con 0
line vty 0 4
 password cisco
line vty 5 15
 password cisco
!
end

次の「IEEE802.1X(SwimRadius編 その2)」では、サプリカントとなるPC_Aを設定してゆきます。

<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP) Switch演習  

Fast Ether Channel とは その1
Fast Ether Channel(固定 その1)
Fast Ether Channel(固定 その3)
Fast Ether Channel(LACP その1)
Fast Ether Channel(LACP その3)
Fast Ether Channel(PAgP その1)
Fast Ether Channel(PAgP その3)
SPAN(ミラーリング その1)
SPAN(ミラーリング その3)
IEEE802.1Xとは(その1)
IEEE802.1X(Windows XP・Vistaの設定)
VNCでLinuxを遠隔操作(その1)
IEEE802.1X(Linux編 基本設定 その1)
IEEE802.1X(Linux編 基本設定 その3)
IEEE802.1X(Linux編 認証VLAN その1)
IEEE802.1X(Linux編 認証VLAN その3)
リモートデスクトップで遠隔操作(その1)
Server2003でRADIUSサーバ(その1)
Server2003でRADIUSサーバ(その3)
Server2003でRADIUSサーバ(その5)
Server2003でRADIUSサーバ(その7)
Server2003でRADIUSサーバ(その9)
Server2003でRADIUSサーバ(その11)
IEEE802.1X(Server2003編 その1)
IEEE802.1X(Server2003編 その3)
IEEE802.1X(Server2003編 その5)
IEEE802.1X(SwimRadius編 その1)
IEEE802.1X(SwimRadius編 その3)
Fast Ether Channel とは その2
Fast Ether Channel(固定 その2
Fast Ether Channel(固定 その4)
Fast Ether Channel(LACP その2)
Fast Ether Channel(LACP その4)
Fast Ether Channel(PAgP その2)
Fast Ether Channel(PAgP その4)
SPAN(ミラーリング その2)
SPAN(ミラーリング その4)
IEEE802.1Xとは(その2)
LinuxでRADIUS構築(FreeRADIUS)
VNCでLinuxを遠隔操作(その2)
IEEE802.1X(Linux編 基本設定 その2)
IEEE802.1X(Linux編 基本設定 その4)
IEEE802.1X(Linux編 認証VLAN その2)
IEEE802.1X(Linux編 認証VLAN その4)
リモートデスクトップで遠隔操作(その2)
Server2003でRADIUSサーバ(その2)
Server2003でRADIUSサーバ(その4)
Server2003でRADIUSサーバ(その6)
Server2003でRADIUSサーバ(その8)
Server2003でRADIUSサーバ(その10)
Server2003でRADIUSサーバ(その12)
IEEE802.1X(Server2003編 その2)
IEEE802.1X(Server2003編 その4)
IEEE802.1X(Server2003編 その6)
IEEE802.1X(SwimRadius編 その2)
IEEE802.1X(SwimRadius編 その4)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.