@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > VRRP(その3)

 Amazon
@network Cisco・アライド実機で学ぶ
◆VRRP(その3)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。



VRRP(その2)     
前へ  次へ
VRRP(その4)

◆VRRP(その3)

ここでは、VRRPを設定してゆきます。

使用するネットワークは、下の構成になります。

※検証には、IOS12.4を搭載しているCisco1710使用しています。HSRPは、割と多くのCiscoルータで使用することができますが、VRRPをサポートしていないものもありますので、注意して下さい。

Router_Cには、S0/0のダウンを検知して、プライオリティ値を下げるようにトラッキングの設定を行います。

●Router_BのVRRPの設定

Router_B(config)#interface f0
Router_B(config-if)#vrrp 1 ip 192.168.1.254

●Router_CのVRRPの設定

Router_C(config)#track 1 interface e0 line-protocol
Router_C(config-track)#exit

Router_C(config)#interface f0
Router_C(config-if)#vrrp 1 ip 192.168.1.254
Router_C(config-if)#vrrp 1 priority 200
Router_C(config-if)#vrrp 1 track 1 decrement 150

Router_B、Router_Cにおいて、VRRPグループ1に「192.168.1.254」の仮想IPアドレスを設定します。
Router_Bのプライオリティ値は設定しないので、デフォルト値の「100」になります。
 Router_Cのプライオリティ値は、「200」を設定し、S0/0がダウンした場合には、150を減算して「50」になるようにします。

インタフェーストラッキングの設定は、HSRPとは、設定のアプローチが異なります。

HSRPでは、「standby」コマンドで直接、下のように監視するインタフェースの指定ができました。

Router_C(config-if)#standby 1 track s0/0 200

しかし、VRRPでは、監視の対象となるオブジェクトを指定してか「track」オプションで指定する必要があります。

各ルータの設定は、以下のようになります。

●Router_Aの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 10.0.0.1 255.0.0.0
!
interface Ethernet0
 ip address 172.16.0.2 255.255.0.0
!
interface Ethernet1
 ip address 172.17.0.2 255.255.0.0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_B
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
 half-duplex
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
 vrrp 1 ip 192.168.1.254
!
router ospf 1
 log-adjacency-changes
 passive-interface FastEthernet0
 network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Cの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_C
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
track 1 interface Ethernet0 line-protocol
!
interface Ethernet0
 ip address 172.17.0.1 255.255.255.0
 half-duplex
!
interface FastEthernet0
 ip address 192.168.1.2 255.255.255.0
 speed auto
 vrrp 1 ip 192.168.1.254
 vrrp 1 priority 200
 vrrp 1 track 1 decrement 150
!
router ospf 1
 log-adjacency-changes
 passive-interface FastEthernet0
 network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

これで、VRRPの基本的な設定は、完了です。

設定したVRRPの検証は、「VRRP(その4)」〜「」VRRP(その6)で行ってゆきます。


VRRP(その2)     
前へ  次へ
VRRP(その4)

<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
VRRP(その1)
VRRP(その2)
VRRP(その3)
VRRP(その4)
VRRP(その5)
VRRP(その6)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.