@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > BGP(複数のルートリフレクタの設定)

スポンサードリンク

@network Cisco・アライド実機で学ぶ
◆BGP(複数のルートリフレクタの設定)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。

◆BGP(複数のルートリフレクタの設定)

BGP(複数のルートリフレクタ)」の続きです。

 下のネットワークにおいて、2台のルートリフレクタを配置して、ルートリフレクションの設定を行ってゆきます。

 ちなみに、このネットワークをルートリフレクタを使用せずに構築した場合は、

(5×4)/2 = 10

10のピア接続が必要になります。

 ここでは、2台のルートリフレクタを配置するので、7つのピア接続で済みます。

 それでは、Router_A、Router_Bをルートリフレクタにして設定してゆきます。


◆複数のルートリフレクタの設定

 2台のルータで、ルートリフレクションの設定を行います。各ルータで、ルートリフレクタ・クライアントになるピアの数だけ以下のコマンドで指定します。

Router#(config-router)#neighbor {peer_address} route-reflector-client

 ルートリフレクタを複数用意するので、ルートリフレクタにするBGPスピーカーに同一のクラスタIDを割り当てる必要があります。

クラスタIDを割り当てるコマンドは、以下のコマンドになります。

Router#(config-router)#bgp cluster-id {cluster ID}
cluster ID : クラスタID

ルートリフレクタ・クライアントの設定に変わりはありません。通常のBGPの設定を行います。


ルートリフレクタにするRouter_A、Router_Bの設定は、以下のようになります。

●Router_Aの設定

Router_A(config)#router bgp 100
Router_A(config-router)#no synchronization
Router_A(config-router)#bgp cluster-id 1
Router_A(config-router)#neighbor 172.16.0.2 remote-as 100
Router_A(config-router)#neighbor 172.17.0.2 remote-as 100
Router_A(config-router)#neighbor 172.17.0.2 route-reflector-client
Router_Aconfig-router)#neighbor 172.19.0.2 remote-as 100
Router_A(config-router)#neighbor 172.19.0.2 route-reflector-client
Router_A(config-router)#neighbor 172.21.0.2 remote-as 100
Router_A(config-router)#neighbor 172.21.0.2 route-reflector-client

●Router_Bの設定

Router_B(config)#router bgp 100
Router_B(config-router)#no synchronization
Router_B(config-router)#bgp cluster-id 1
Router_B(config-router)#neighbor 172.16.0.1 remote-as 100
Router_B(config-router)#neighbor 172.18.0.2 remote-as 100
Router_B(config-router)#neighbor 172.18.0.2 route-reflector-client
Router_B(config-router)#neighbor 172.20.0.2 remote-as 100
Router_B(config-router)#neighbor 172.20.0.2 route-reflector-client
Router_B(config-router)#neighbor 172.22.0.2 remote-as 100
Router_B(config-router)#neighbor 172.22.0.2 route-reflector-client

それでは、各ルータを設定してゆきます。各ルータの設定は、以下のようになります。

 強制的にインタフェースをUPさせるために、Router_AのE0インタフェースで「no keepalive」コマンドを設定しておきます。

 また、Router_D、Router_EのLoopback0では、以下のコマンドを入力して、OSPFでLoopbackインタフェースに設定されたマスク長で経路を通知させるようにします。

Router_D(config-if)#ip ospf network point-to-point

Router_E(config-if)#ip ospf network point-to-point

●Router_Aの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 172.19.0.1 255.255.0.0
!
interface Ethernet1
 ip address 172.21.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
!
interface Serial1
 ip address 172.16.0.1 255.255.0.0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
 no synchronization
 bgp cluster-id 1
 neighbor 172.16.0.2 remote-as 100
 neighbor 172.17.0.2 remote-as 100
 neighbor 172.17.0.2 route-reflector-client
 neighbor 172.19.0.2 remote-as 100
 neighbor 172.19.0.2 route-reflector-client
 neighbor 172.21.0.2 remote-as 100
 neighbor 172.21.0.2 route-reflector-client
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0/0
 ip address 172.20.0.1 255.255.0.0
!
interface Serial0/0
 ip address 172.16.0.2 255.255.0.0
 clockrate 64000
!
interface Ethernet0/1
 ip address 172.22.0.1 255.255.0.0
!
interface Serial0/1
 ip address 172.18.0.1 255.255.0.0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
 no synchronization
 bgp cluster-id 1
 neighbor 172.16.0.1 remote-as 100
 neighbor 172.18.0.2 remote-as 100
 neighbor 172.18.0.2 route-reflector-client
 neighbor 172.20.0.2 remote-as 100
 neighbor 172.20.0.2 route-reflector-client
 neighbor 172.22.0.2 remote-as 100
 neighbor 172.22.0.2 route-reflector-client
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


●Router_Cの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_C
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 clockrate 64000
!
interface Serial1
 ip address 172.18.0.2 255.255.0.0
 clockrate 64000
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
 no synchronization
 network 10.10.10.0 mask 255.255.255.0
 neighbor 172.17.0.1 remote-as 100
 neighbor 172.18.0.1 remote-as 100
 no auto-summary
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Dの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_D
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
interface Loopback0
 ip address 20.20.20.1 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 172.19.0.2 255.255.0.0
 half-duplex
!
interface FastEthernet0
 ip address 172.20.0.2 255.255.0.0
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.0 mask 255.255.255.0
 neighbor 172.19.0.1 remote-as 100
 neighbor 172.20.0.1 remote-as 100
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Eの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_E
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
interface Loopback0
 ip address 30.30.30.1 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 172.21.0.2 255.255.0.0
 half-duplex
!
interface FastEthernet0
 ip address 172.22.0.2 255.255..0
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 30.30.30.0 mask 255.255.255.0
 neighbor 172.21.0.1 remote-as 100
 neighbor 172.22.0.1 remote-as 100
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


これで、各ルータの設定は、完了しました。

それでは、2台のルートリフレクタが正しく機能しているかを確認してゆきます。

続きは、次の「BGP(複数のルートリフレクタの確認)」で、検証してゆきます。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

BGPとは
BGP(基本設定 その1)
BGP(基本設定 iBGP・eBGP確認 その3)
BGP(基本設定 iBGPの設定 その5)
BGP(基本設定 iBGPの設定 その7)
BGP(基本設定 ループバックでピア その9)
BGP(基本設定 iBGPとIGP その11)
BGP(経路決定プロセスの確認 その1)
BGP(同期化とは)
BGP(同期化の設定 その2)
BGP(eBGPマルチホップ その2)
BGPルートの生成(IGPから再配送 その1)
BGPルートの生成(経路集約 その1)
BGPルートの生成(経路集約 その3)
iBGPで学習した経路は他のiBGPへ流さない
BGP(ルートリフレクションとは)
BGP(ルートリフレクションの確認)
BGP(複数のルートリフレクタの設定)
BGP(コンフェデレーションとは)
BGP(コンフェデレーションの確認 その1)
BGP(コミュニティとは)
BGP(コミュニティの確認)
BGP(バックドア その1)
BGP(バックドア その3)
BGP(ピアグループの設定 その1)
BGP(ピアグループの確認)
BGP(Local Preferenceの設定 その1)
BGP(Local Preferenceの確認)
BGP(MED属性の設定 その1)
BGP(MED属性の確認)
BGP(AS_PATH属性 その1)
BGP(AS_PATH属性 その3)
BGP(AS_PATHフィルタ・filter-list その2)
BGP(配布リスト・distribute-list その1)
BGP(配布リスト・distribute-list その3)
BGP(PREFIXフィルタ その2)
BGP(近隣関係の形成)
BGP(基本設定 ベストパスの確認 その2)
BGP(基本設定 next-hop-self その4)
BGP(基本設定 iBGPの設定 その6)
BGP(基本設定 ループバックでピア その8)
BGP(基本設定 iBGPとIGP その10)
BGP(経路決定プロセス)
BGP(経路決定プロセスの確認 その2)
BGP(同期化の設定 その1)
BGP(eBGPマルチホップ その1)
BGPルートの生成(networkコマンド)
BGPルートの生成(IGPから再配送 その2)
BGPルートの生成(経路集約 その2)
BGPルートの生成(経路集約 その4)
BGP(iBGPはフルメッシュでピアを張る)
BGP(ルートリフレクションの設定)
BGP(複数のルートリフレクタ)
BGP(複数のルートリフレクタの確認)
BGP(コンフェデレーションの設定)
BGP(コンフェデレーションの確認 その2)
BGP(コミュニティの設定)
BGP(ORIGINアトリビュート)
BGP(バックドア その2)
BGP(ピアグループとは)
BGP(ピアグループの設定 その2)
BGP(Local Preference属性とは)
BGP(Local Preferenceの設定 その2)
BGP(MED属性とは)
BGP(MED属性の設定 その2)
BGP(帯域幅・bandwidthを設定する)
BGP(AS_PATH属性 その2)
BGP(AS_PATHフィルタ・filter-list その1)
BGP(AS_PATHフィルタ・filter-list その3)
BGP(配布リスト・distribute-list その2)
BGP(PREFIXフィルタ その1)
BGP(PREFIXフィルタ その3)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.