@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > BGPルートの生成(経路集約 その3)

スポンサードリンク

@network Cisco・アライド実機で学ぶ
◆BGPルートの生成(経路集約 その3)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。

◆BGPルートの生成(経路集約 その3)

 ここでは、複数のAS内の経路をBGPで集約して通知させる演習を行います。

 「BGPルートの生成(経路集約 その1)」では、下のネットワークをBGPで構築し、BGPによる経路集約の設定を行いました。

 ここでは、このネットワークにAS300を新設して追加します。

 その際、AS100内のループバックアドレスを変更しネットワーク構成を若干変更します。


今回、AS300を追加したネットワークは、下図になります。

AS100の経路、AS300の経路をRouter_Bで集約してRouter_Cに通知するように設定してゆきます。


まずは、上のネットワークをBGPで構築します。

ここでは、まだ、経路集約に関しての設定は行いません。


それでは、各ルータを設定してゆきます。

●Router_Aの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 192.168.8.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.9.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.10.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.11.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.0.0
 clockrate 64000
!
router bgp 100
 no synchronization
 network 192.168.8.0
 network 192.168.9.0
 network 192.168.10.0
 network 192.168.11.0
 neighbor 172.16.0.2 remote-as 200
 no auto-summary
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0
 ip address 172.16.0.2 255.255.0.0
!
interface Serial1
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
router bgp 200
 no synchronization
 neighbor 172.16.0.1 remote-as 100
 neighbor 172.17.0.2 remote-as 200
 neighbor 172.17.0.2 next-hop-self
 neighbor 172.18.0.1 remote-as 300
 no auto-summary
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Cの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_C
!
enable password cisco
!
ip subnet-zero
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
!
router bgp 200
 no synchronization
 neighbor 172.17.0.1 remote-as 200
 no auto-summary
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Dの設定
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_D
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 192.168.12.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.13.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.14.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.15.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.18.0.2 255.255.0.0
!
router bgp 300
 no synchronization
 network 192.168.12.0
 network 192.168.13.0
 network 192.168.14.0
 network 192.168.15.0
 neighbor 172.18.0.2 remote-as 200
 no auto-summary
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


Router_CのBGPテーブルを確認してみます。

Router_C#show ip bgp
BGP table version is 18, local router ID is 172.17.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop          Metric LocPrf Weight Path
*>i192.168.8.0      172.17.0.1             0    100      0 100 i
*>i192.168.9.0      172.17.0.1             0    100      0 100 i
*>i192.168.10.0     172.17.0.1             0    100      0 100 i
*>i192.168.11.0     172.17.0.1             0    100      0 100 i
*>i192.168.12.0     172.17.0.1             0    100      0 300 i
*>i192.168.13.0     172.17.0.1             0    100      0 300 i
*>i192.168.14.0     172.17.0.1             0    100      0 300 i
*>i192.168.15.0     172.17.0.1             0    100      0 300 i

AS100、AS300から経路情報が伝わってきていることが確認できます。

Router_Cのルーティングテーブルも確認してみます。

Gateway of last resort is not set

B    192.168.8.0/24 [200/0] via 172.17.0.1, 00:34:09
B    192.168.9.0/24 [200/0] via 172.17.0.1, 00:34:10
B    192.168.10.0/24 [200/0] via 172.17.0.1, 00:34:10
B    192.168.11.0/24 [200/0] via 172.17.0.1, 00:34:10
B    192.168.12.0/24 [200/0] via 172.17.0.1, 00:33:17
B    192.168.13.0/24 [200/0] via 172.17.0.1, 00:33:17
B    192.168.14.0/24 [200/0] via 172.17.0.1, 00:33:17
B    192.168.15.0/24 [200/0] via 172.17.0.1, 00:33:17
C    172.17.0.0/16 is directly connected, Serial0

それでは、これらの経路情報をRouter_Bで、「192.168.8.0/21」に集約して通知するように設定してゆきます。

AS100の経路 集約経路
192.168.8.0/24 
192.168.9.0/24 
192.168.10.0/24
192.168.11.0/24
192.168.12.0/24
192.168.13.0/24
192.168.14.0/24
192.168.15.0/24
192.168.8.0/21

この続きは、「BGPルートの生成(経路集約 その4)」で紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

BGPとは
BGP(基本設定 その1)
BGP(基本設定 iBGP・eBGP確認 その3)
BGP(基本設定 iBGPの設定 その5)
BGP(基本設定 iBGPの設定 その7)
BGP(基本設定 ループバックでピア その9)
BGP(基本設定 iBGPとIGP その11)
BGP(経路決定プロセスの確認 その1)
BGP(同期化とは)
BGP(同期化の設定 その2)
BGP(eBGPマルチホップ その2)
BGPルートの生成(IGPから再配送 その1)
BGPルートの生成(経路集約 その1)
BGPルートの生成(経路集約 その3)
iBGPで学習した経路は他のiBGPへ流さない
BGP(ルートリフレクションとは)
BGP(ルートリフレクションの確認)
BGP(複数のルートリフレクタの設定)
BGP(コンフェデレーションとは)
BGP(コンフェデレーションの確認 その1)
BGP(コミュニティとは)
BGP(コミュニティの確認)
BGP(バックドア その1)
BGP(バックドア その3)
BGP(ピアグループの設定 その1)
BGP(ピアグループの確認)
BGP(Local Preferenceの設定 その1)
BGP(Local Preferenceの確認)
BGP(MED属性の設定 その1)
BGP(MED属性の確認)
BGP(AS_PATH属性 その1)
BGP(AS_PATH属性 その3)
BGP(AS_PATHフィルタ・filter-list その2)
BGP(配布リスト・distribute-list その1)
BGP(配布リスト・distribute-list その3)
BGP(PREFIXフィルタ その2)
BGP(近隣関係の形成)
BGP(基本設定 ベストパスの確認 その2)
BGP(基本設定 next-hop-self その4)
BGP(基本設定 iBGPの設定 その6)
BGP(基本設定 ループバックでピア その8)
BGP(基本設定 iBGPとIGP その10)
BGP(経路決定プロセス)
BGP(経路決定プロセスの確認 その2)
BGP(同期化の設定 その1)
BGP(eBGPマルチホップ その1)
BGPルートの生成(networkコマンド)
BGPルートの生成(IGPから再配送 その2)
BGPルートの生成(経路集約 その2)
BGPルートの生成(経路集約 その4)
BGP(iBGPはフルメッシュでピアを張る)
BGP(ルートリフレクションの設定)
BGP(複数のルートリフレクタ)
BGP(複数のルートリフレクタの確認)
BGP(コンフェデレーションの設定)
BGP(コンフェデレーションの確認 その2)
BGP(コミュニティの設定)
BGP(ORIGINアトリビュート)
BGP(バックドア その2)
BGP(ピアグループとは)
BGP(ピアグループの設定 その2)
BGP(Local Preference属性とは)
BGP(Local Preferenceの設定 その2)
BGP(MED属性とは)
BGP(MED属性の設定 その2)
BGP(帯域幅・bandwidthを設定する)
BGP(AS_PATH属性 その2)
BGP(AS_PATHフィルタ・filter-list その1)
BGP(AS_PATHフィルタ・filter-list その3)
BGP(配布リスト・distribute-list その2)
BGP(PREFIXフィルタ その1)
BGP(PREFIXフィルタ その3)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.