@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > BGPルートの生成(networkコマンド)

スポンサードリンク

@network Cisco・アライド実機で学ぶ
◆BGPルートの生成(networkコマンド)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。

◆BGPルートの生成(networkコマンド)

BGPでルートを生成するには、静的な方法、動的な方法のどちらかで行うようになります。

 静的な方法では、ルーティングプロトコルではなく、手動でBGP経路を作成します。動的な方法では、RIP、IGRP、OSPFなどのIGPから経路情報をBGPへ再配送します。

 BGPでは、以下の3通りの方法で、ルートを生成します。

●networkコマンド
aggregate-addressコマンド(経路集約)
AS内のIGPから再配送

 BGPルートを生成するのに、静的、動的のどちらの方法が良いのかは、BGPへ再配送する経路の数が1つの目安になります。

 数本の経路をBGPへ注入するのであれば、静的な方法が楽で良い方法ですし、たくさんの経路をBGPへ注入するのであれば、IGPから再配送する動的な方法が楽です。

IGPから再配送する場合には、他にも考慮しなければならないことがあります。

それは、IGP側で不安定な状態が続くとBGPプロセスへも影響するということです。

以上のようなことを考慮して、BGPでは、ルートを生成してゆきます。


ここでは、「network」コマンドを使った静的にBGPルートの生成する方法を説明してゆきます。

・動的にルートを生成する方法については、「BGPルートの生成(IGPから再配送 その1)」で紹介します。
・集約した経路を作成する方法については、「BGPルートの生成(経路集約 その1)」で紹介します。

使用するネットワークは、下図になります。このネットワークを使用して、BGPへ静的再配送を行います。


●ネットワーク構成図の補足

Router_A ・・・ BGPは動作させません。
Router_B ・・・ BGPを動作させる。
Router_C ・・・ BGPを動作させる。

 Router_B〜Router_C間は、BGPでルーティングを行います。所属するASが異なりますから、eBGPでルーティングが行われることになります。また、ピアを張るにお互いのループバックアドレスを使用しますので、eBGPマルチホップの設定が必要になります。

Router_B〜Router_C間は、ループバックIPアドレスへは静的ルートで到達させます。
Router_A ・・・ Router_Bへのデフォルトルートを設定します。


◆静的にBGPルートを生成するには

 静的にBGPルートを生成するには「network」コマンドを使用します。このコマンドは、ルート情報を生成するコマンドで、指定したルート情報をBGPテーブルに載せてベストパスにします。

 一度に1つのBGPルートしか生成できませんが、複数生成する場合は、自律システム内のネットワークを列挙するだけなので、設定は単純です。

構文は以下のようになります。

Router(config-router)#network [ネットワークアドレス] mask [サブネットマスク]


それでは、ネットワークの構成とコマンドが理解できたところで、各ルータの設定を行ってゆきます。

各ルータのルーティングの設定

●Router_A

Router_A(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.2

●Router_B

Router_B(config)#router bgp 100
Router_B(config-router)#no synchronization
Router_B(config-router)#network 10.10.10.0 mask 255.255.255.0
Router_B(config-router)#network 172.16.0.0 mask 255.255.0.0
Router_B(config-router)#neighbor 2.2.2.2 remote-as 200
Router_B(config-router)#neighbor 2.2.2.2 ebgp-multihop
Router_B(config-router)#neighbor 2.2.2.2 update-source Loopback0
Router_B(config-router)#no auto-summary
Router_B(config-router)#exit
Router_B(config)#ip route 2.2.2.2 255.255.255.255 172.17.0.2
Router_B(config)#ip route 10.10.10.0 255.255.255.0 172.16.0.1

Router_Bに直接接続されていない「10.10.10.0./24」をBGPで指定しています。


 この「network 10.10.10.0 mask 255.255.255.0」という指定の仕方は、RIPは、IGRPなどのディスタンスベクタルーティングプロトコルの指定の仕方をイメージすると馴染みにくいと感じるかもしれません。

●Router_C

Router_C(config)#router bgp 200
Router_C(config-router)#no synchronization
Router_C(config-router)#network 20.20.20.0 mask 255.255.255.0
Router_C(config-router)#neighbor 1.1.1.1 remote-as 100
Router_C(config-router)#neighbor 1.1.1.1 ebgp-multihop
Router_C(config-router)#neighbor 1.1.1.1 update-source Loopback0
Router_C(config-router)#no auto-summary
Router_C(config-router)#exit
Router_C(config)#ip route 1.1.1.1 255.255.255.255 172.17.0.1


各ルータの設定は、以下のようになります。

 強制的にインタフェースをUPさせるために、Router_A、Router_CのE0インタフェースで「no keepalive」コマンドを設定しておきます。

●Router_Aの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.0.1 255.255.0.0
 clockrate 64000
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.2
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0
 ip address 172.16.0.2 255.255.0.0
!
interface Serial1
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
router bgp 100
 no synchronization
 network 10.10.10.0 mask 255.255.255.0
 network 172.16.0.0
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!
ip classless
ip route 2.2.2.2 255.255.255.255 172.17.0.2
ip route 10.10.10.0 255.255.255.0 172.16.0.1
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Cの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_C
!
enable password cisco
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0
 ip address 20.20.20.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
!
interface Serial1
 ip address 172.18.0.1 255.255.0.0
 clockrate 64000
!
router bgp 200
 no synchronization
 network 20.20.20.0 mask 255.255.255.0
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 ebgp-multihop 255
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary
!
ip classless
ip route 1.1.1.1 255.255.255.255 172.17.0.1
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


Router_Bのルーティングテーブルを確認してみます。

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
S       2.2.2.2 [1/0] via 172.17.0.2
     10.0.0.0/24 is subnetted, 1 subnets
S       10.10.10.0 [1/0] via 172.16.0.1
     20.0.0.0/24 is subnetted, 1 subnets
B       20.20.20.0 [20/0] via 2.2.2.2, 00:03:44
C    172.16.0.0/16 is directly connected, Serial0
C    172.17.0.0/16 is directly connected, Serial1

Router_Cから「20.20.20.0/24」の経路をBGPで学習していることが確認できます。

Router_Cのルーティングテーブルを確認してみます。

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
S       1.1.1.1 [1/0] via 172.17.0.1
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.10.0 [20/0] via 1.1.1.1, 00:01:15
     20.0.0.0/24 is subnetted, 1 subnets
C       20.20.20.0 is directly connected, Ethernet0
B    172.16.0.0/16 [20/0] via 1.1.1.1, 00:01:15
C    172.17.0.0/16 is directly connected, Serial0

Router_Bから「10.10.10.0/24」、「172.16.0.0/16」の経路をBGPで学習していることが確認できます。

次の「BGPルートの生成(IGPから再配送 その1)」では、IGPを使ってBGPへ経路を注入する方法を紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

BGPとは
BGP(基本設定 その1)
BGP(基本設定 iBGP・eBGP確認 その3)
BGP(基本設定 iBGPの設定 その5)
BGP(基本設定 iBGPの設定 その7)
BGP(基本設定 ループバックでピア その9)
BGP(基本設定 iBGPとIGP その11)
BGP(経路決定プロセスの確認 その1)
BGP(同期化とは)
BGP(同期化の設定 その2)
BGP(eBGPマルチホップ その2)
BGPルートの生成(IGPから再配送 その1)
BGPルートの生成(経路集約 その1)
BGPルートの生成(経路集約 その3)
iBGPで学習した経路は他のiBGPへ流さない
BGP(ルートリフレクションとは)
BGP(ルートリフレクションの確認)
BGP(複数のルートリフレクタの設定)
BGP(コンフェデレーションとは)
BGP(コンフェデレーションの確認 その1)
BGP(コミュニティとは)
BGP(コミュニティの確認)
BGP(バックドア その1)
BGP(バックドア その3)
BGP(ピアグループの設定 その1)
BGP(ピアグループの確認)
BGP(Local Preferenceの設定 その1)
BGP(Local Preferenceの確認)
BGP(MED属性の設定 その1)
BGP(MED属性の確認)
BGP(AS_PATH属性 その1)
BGP(AS_PATH属性 その3)
BGP(AS_PATHフィルタ・filter-list その2)
BGP(配布リスト・distribute-list その1)
BGP(配布リスト・distribute-list その3)
BGP(PREFIXフィルタ その2)
BGP(近隣関係の形成)
BGP(基本設定 ベストパスの確認 その2)
BGP(基本設定 next-hop-self その4)
BGP(基本設定 iBGPの設定 その6)
BGP(基本設定 ループバックでピア その8)
BGP(基本設定 iBGPとIGP その10)
BGP(経路決定プロセス)
BGP(経路決定プロセスの確認 その2)
BGP(同期化の設定 その1)
BGP(eBGPマルチホップ その1)
BGPルートの生成(networkコマンド)
BGPルートの生成(IGPから再配送 その2)
BGPルートの生成(経路集約 その2)
BGPルートの生成(経路集約 その4)
BGP(iBGPはフルメッシュでピアを張る)
BGP(ルートリフレクションの設定)
BGP(複数のルートリフレクタ)
BGP(複数のルートリフレクタの確認)
BGP(コンフェデレーションの設定)
BGP(コンフェデレーションの確認 その2)
BGP(コミュニティの設定)
BGP(ORIGINアトリビュート)
BGP(バックドア その2)
BGP(ピアグループとは)
BGP(ピアグループの設定 その2)
BGP(Local Preference属性とは)
BGP(Local Preferenceの設定 その2)
BGP(MED属性とは)
BGP(MED属性の設定 その2)
BGP(帯域幅・bandwidthを設定する)
BGP(AS_PATH属性 その2)
BGP(AS_PATHフィルタ・filter-list その1)
BGP(AS_PATHフィルタ・filter-list その3)
BGP(配布リスト・distribute-list その2)
BGP(PREFIXフィルタ その1)
BGP(PREFIXフィルタ その3)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.