@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > BGP(同期化の設定 その1)

スポンサードリンク

@network Cisco・アライド実機で学ぶ
◆BGP(同期化の設定 その1)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。

◆BGP(同期化の設定 その1)

ここでは、下図のネットワークを使用してBGP同期を検証してゆきます。

BGP同期とは

BGPで経路情報を受信しても、その経路情報をIGPで学習するまで有効にしない。

iBGPとIGPの両方で、同じルートのアドバタイズを受けた時のみ、ルーティングテーブルに載せる。

機能のことです。

下図のネットワークをBGPで構築してゆきますが、

Router_A、Router_B ・・・ BGP同期を無効
Router_C ・・・ BGP同期を有効

にしておきます。


上図のネットワークをBGPで構築してゆきますが、

Router_A、Router_B ・・・ BGP同期を無効
Router_C ・・・ BGP同期を有効

にしておきます。

●ルータの設定

 また、ルーティングを簡素化するために、Router_Aでは、AS200へのルートをデフォルトルートで到達させるようにします。

Router_A(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.2

Router_Bで次の設定を追加します。

Router_B(config-router)#neighbor 172.17.0.2 next-hop-self

 このコマンドを追加することで、Router_B が、eBGPで学習した「10.10.10.0/24」経路の「Next Hop」を自分のインタフェースで通知するようになります。

Router_A、Router_Bで、BGP同期を無効にします。

BGP同期を無効にするには、「no synchronization」コマンドを使います。

Router(config-router)#no synchronization

それでは、各ルータを設定してゆきます。

 強制的にインタフェースをUPさせるために、Router_AのE0インタフェースで「no keepalive」コマンドを設定しておきます。

●Router_Aの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.0.1 255.255.0.0
 clockrate 64000
!
router bgp 100
 no synchronization
 network 10.10.10.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 200
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.2
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Serial0
 ip address 172.16.0.2 255.255.0.0
!
interface Serial1
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
router bgp 200
 no synchronization
 neighbor 172.16.0.1 remote-as 100
 neighbor 172.17.0.2 remote-as 200
 neighbor 172.17.0.2 next-hop-self
 no auto-summary
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Cの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_C
!
enable password cisco
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
!
router bgp 200
 neighbor 172.17.0.1 remote-as 200
 no auto-summary
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


Router_CのBGPテーブルを確認してみます。

Router_C#show ip bgp
BGP table version is 2, local router ID is 172.17.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop          Metric LocPrf Weight Path
*>i10.10.10.0/24    172.17.0.1             0    100      0 100 i

「10.10.10.0/24」の経路が、「>」よりベストパスになっているのが確認できます。

ところが、

Router_Cのルーティングテーブルを確認してみると

Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0

 iBGPで、「10.10.10.0/24」の経路を学習し、ベストパスになっているにも関わらず、ルーティングテーブルに載せられていません。

それは、Router_Cで、BGP同期が有効になっているからです。

BGP同期では、次のルールがありました。

iBGPとIGPの両方で、同じルートのアドバタイズを受けた時のみ、ルーティングテーブルに載せる。

というルールです。

その為、Router_Cで、「10.10.10.0/24」経路が反映されなかったのです。

「10.10.10.0/24」経路が反映させるには、Router_CでBGP同期を無効にする必要があります。

Router_CでBGP同期を無効にします。

Router_C(config-router)#no synchronization

ルーティングテーブルへの反映を早めるために次のコマンドを入力します。

Router_C(config)#clear ip bgp *

Router_Cで、再度ルーティングテーブルを確認してみます。

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.10.0 [200/0] via 172.17.0.1, 00:00:06
C    172.17.0.0/16 is directly connected, Serial0

「10.10.10.0/24」経路がルーティングテーブルに反映されました。

 次の「BGP(同期化の設定 その2)」では、このネットワークをさらに拡張し、AS200を通過ASにして、BGP同期を検証してゆきます。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

BGPとは
BGP(基本設定 その1)
BGP(基本設定 iBGP・eBGP確認 その3)
BGP(基本設定 iBGPの設定 その5)
BGP(基本設定 iBGPの設定 その7)
BGP(基本設定 ループバックでピア その9)
BGP(基本設定 iBGPとIGP その11)
BGP(経路決定プロセスの確認 その1)
BGP(同期化とは)
BGP(同期化の設定 その2)
BGP(eBGPマルチホップ その2)
BGPルートの生成(IGPから再配送 その1)
BGPルートの生成(経路集約 その1)
BGPルートの生成(経路集約 その3)
iBGPで学習した経路は他のiBGPへ流さない
BGP(ルートリフレクションとは)
BGP(ルートリフレクションの確認)
BGP(複数のルートリフレクタの設定)
BGP(コンフェデレーションとは)
BGP(コンフェデレーションの確認 その1)
BGP(コミュニティとは)
BGP(コミュニティの確認)
BGP(バックドア その1)
BGP(バックドア その3)
BGP(ピアグループの設定 その1)
BGP(ピアグループの確認)
BGP(Local Preferenceの設定 その1)
BGP(Local Preferenceの確認)
BGP(MED属性の設定 その1)
BGP(MED属性の確認)
BGP(AS_PATH属性 その1)
BGP(AS_PATH属性 その3)
BGP(AS_PATHフィルタ・filter-list その2)
BGP(配布リスト・distribute-list その1)
BGP(配布リスト・distribute-list その3)
BGP(PREFIXフィルタ その2)
BGP(近隣関係の形成)
BGP(基本設定 ベストパスの確認 その2)
BGP(基本設定 next-hop-self その4)
BGP(基本設定 iBGPの設定 その6)
BGP(基本設定 ループバックでピア その8)
BGP(基本設定 iBGPとIGP その10)
BGP(経路決定プロセス)
BGP(経路決定プロセスの確認 その2)
BGP(同期化の設定 その1)
BGP(eBGPマルチホップ その1)
BGPルートの生成(networkコマンド)
BGPルートの生成(IGPから再配送 その2)
BGPルートの生成(経路集約 その2)
BGPルートの生成(経路集約 その4)
BGP(iBGPはフルメッシュでピアを張る)
BGP(ルートリフレクションの設定)
BGP(複数のルートリフレクタ)
BGP(複数のルートリフレクタの確認)
BGP(コンフェデレーションの設定)
BGP(コンフェデレーションの確認 その2)
BGP(コミュニティの設定)
BGP(ORIGINアトリビュート)
BGP(バックドア その2)
BGP(ピアグループとは)
BGP(ピアグループの設定 その2)
BGP(Local Preference属性とは)
BGP(Local Preferenceの設定 その2)
BGP(MED属性とは)
BGP(MED属性の設定 その2)
BGP(帯域幅・bandwidthを設定する)
BGP(AS_PATH属性 その2)
BGP(AS_PATHフィルタ・filter-list その1)
BGP(AS_PATHフィルタ・filter-list その3)
BGP(配布リスト・distribute-list その2)
BGP(PREFIXフィルタ その1)
BGP(PREFIXフィルタ その3)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.