@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > BGP(基本設定 その1)

スポンサードリンク

@network Cisco・アライド実機で学ぶ
◆BGP(基本設定 その1)

※動作確認は、Cisco2500、Cisco1710、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。

◆BGP(基本設定 その1)

 ここでは、BGPを使って下図のネットワークを構築します。

 BGPの設定は、様々な属性を与えて経路選択を操作することができるため、少々設定が複雑です。

ここでは、BGPの基本的な設定を紹介します。

 今回、検証に使用したのは、Cisco2500シリーズのルータです。Cisco2500ルータは、中古で安く入手できるコストパフォーマンスに優れたルータです。

もちろん、BGPの動作確認も行えます。

使用するネットワークは、下図になります。


今回のBGPの基本設定では、以下のことを行います。

・AS100内の「10.10.10.0/24」のルートをAS200に通知する。

 AS100内では、AS200へはデフォルトルート「0.0.0.0」を使って到達するようにします。これは、BGPの設定を簡略化するためです。今回、AS100では、AS200内のルートを扱いません。BGPでは、BGPで経路を学習しても、IGPで学習するまで有効にしないBGP同期という機能があるためです。


◆BGPの設定の流れ

1.BGPプロセスを有効にする。

Router(config)#rotuer bgp [AS番号]

2.ピアを確立する近接ルータを指定する。

IGPのように自動でネイバーの登録は、行われません。管理者がネイバーの登録を行います。

Router(config-router)#neighbor [ピアを張るルータのIP] remote-as [AS番号]

3.通知する経路を指定する。

Router(config-router)#network [ネットワークIP] mask [サブネットマスク]


◆BGP同期の設定

 BGPでは、『たとえBGPで経路情報を学習してもIGPで学習するまでは、その経路情報を有効にしない。』というBGP同期という機能があります。

 このBGP同期の機能は、IOS12.2(8)以前のバージョンでは、デフォルトで有効になっています。ここでは、この機能を無効にしておきます。

Router(config-router)#no synchronization


●Router_Aの設定

Router_AのBGPルーティングの設定は、以下のようになります。

Router_Aが所属するASは、100です。BGPのプロセスを100で指定します。

Router_A(config)#router bgp 100

次に、ピアを張るBGPスピーカーのIPアドレスを指定し、そのBGPスピーカーが所属するAS番号を指定します。

Router_A(config-router)#neighbor 172.16.0.2 remote-as 200

最後に、BGPで通知する経路情報を指定します。

Router_A(config-router)#network 10.10.10.0 mask 255.255.255.0
Router_A(config-router)#no auto-summary

●Router_Bの設定

Router_B(config)#router bgp 200
Router_B(config-router)#neighbor 172.16.0.1 remote-as 100
Router_B(config-router)#neighbor 172.17.0.2 remote-as 200
Router_B(config-router)#no auto-summary

●Router_Cの設定

Router_B(config)#router bgp 200
Router_B(config-router)#neighbor 172.17.0.1 remote-as 200
Router_B(config-router)#no auto-summary


●各ルータの設定

それでは、ルータを設定してゆきます。各ルータの設定は、下のようになります。

 強制的にインタフェースをUPさせるために、Router_AのE0インタフェースで「no keepalive」コマンドを設定しておきます。

●Router_Aの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 172.16.0.1 255.255.0.0
 clockrate 64000
!
router bgp 100
 no synchronization
 network 10.10.10.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 200
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.2
!
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Serial0
 ip address 172.16.0.2 255.255.0.0
!
interface Serial1
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
router bgp 200
 no synchronization
 neighbor 172.16.0.1 remote-as 100
 neighbor 172.17.0.2 remote-as 200
 no auto-summary
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end


●Router_Cの設定
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_C
!
enable password cisco
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
!
router bgp 200
 no synchronization
 neighbor 172.17.0.1 remote-as 200
 no auto-summary
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end


各ルータのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is 172.16.0.2 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
C    172.16.0.0/16 is directly connected, Serial0
S*   0.0.0.0/0 [1/0] via 172.16.0.2

●Router_Bのルーティングテーブル
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.10.0 [20/0] via 172.16.0.1, 00:13:22
C    172.16.0.0/16 is directly connected, Serial0
C    172.17.0.0/16 is directly connected, Serial1

●Router_Cのルーティングテーブル
Gateway of last resort is not set

C    172.17.0.0/16 is directly connected, Serial0

ここで、もう一度、設定したことを確認してみます。

Router_Aでは、デフォルトルートでAS200に到達するように設定しました。

Router_Bでは、BGPのルート「10.10.10.0」のルートがあります。

Router_Cでは、BGPによる「10.10.10.0」のルートがありません。


 今まで、RIP、IGRP、EIGRP、OSPFなどのルーティングプロトコルを設定してきましたが、BGPでは、ちょっと勝手が違います。

この続きは、「BGP(基本設定 ベストパスの確認 その2)」で、説明します。

BGPの基本設定 1011



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
◆Cisco実機で学ぶ(CCNP)

BGPとは
BGP(基本設定 その1)
BGP(基本設定 iBGP・eBGP確認 その3)
BGP(基本設定 iBGPの設定 その5)
BGP(基本設定 iBGPの設定 その7)
BGP(基本設定 ループバックでピア その9)
BGP(基本設定 iBGPとIGP その11)
BGP(経路決定プロセスの確認 その1)
BGP(同期化とは)
BGP(同期化の設定 その2)
BGP(eBGPマルチホップ その2)
BGPルートの生成(IGPから再配送 その1)
BGPルートの生成(経路集約 その1)
BGPルートの生成(経路集約 その3)
iBGPで学習した経路は他のiBGPへ流さない
BGP(ルートリフレクションとは)
BGP(ルートリフレクションの確認)
BGP(複数のルートリフレクタの設定)
BGP(コンフェデレーションとは)
BGP(コンフェデレーションの確認 その1)
BGP(コミュニティとは)
BGP(コミュニティの確認)
BGP(バックドア その1)
BGP(バックドア その3)
BGP(ピアグループの設定 その1)
BGP(ピアグループの確認)
BGP(Local Preferenceの設定 その1)
BGP(Local Preferenceの確認)
BGP(MED属性の設定 その1)
BGP(MED属性の確認)
BGP(AS_PATH属性 その1)
BGP(AS_PATH属性 その3)
BGP(AS_PATHフィルタ・filter-list その2)
BGP(配布リスト・distribute-list その1)
BGP(配布リスト・distribute-list その3)
BGP(PREFIXフィルタ その2)
BGP(近隣関係の形成)
BGP(基本設定 ベストパスの確認 その2)
BGP(基本設定 next-hop-self その4)
BGP(基本設定 iBGPの設定 その6)
BGP(基本設定 ループバックでピア その8)
BGP(基本設定 iBGPとIGP その10)
BGP(経路決定プロセス)
BGP(経路決定プロセスの確認 その2)
BGP(同期化の設定 その1)
BGP(eBGPマルチホップ その1)
BGPルートの生成(networkコマンド)
BGPルートの生成(IGPから再配送 その2)
BGPルートの生成(経路集約 その2)
BGPルートの生成(経路集約 その4)
BGP(iBGPはフルメッシュでピアを張る)
BGP(ルートリフレクションの設定)
BGP(複数のルートリフレクタ)
BGP(複数のルートリフレクタの確認)
BGP(コンフェデレーションの設定)
BGP(コンフェデレーションの確認 その2)
BGP(コミュニティの設定)
BGP(ORIGINアトリビュート)
BGP(バックドア その2)
BGP(ピアグループとは)
BGP(ピアグループの設定 その2)
BGP(Local Preference属性とは)
BGP(Local Preferenceの設定 その2)
BGP(MED属性とは)
BGP(MED属性の設定 その2)
BGP(帯域幅・bandwidthを設定する)
BGP(AS_PATH属性 その2)
BGP(AS_PATHフィルタ・filter-list その1)
BGP(AS_PATHフィルタ・filter-list その3)
BGP(配布リスト・distribute-list その2)
BGP(PREFIXフィルタ その1)
BGP(PREFIXフィルタ その3)
<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.