@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > セカンダリアドレスの設定(secondary)

 Amazon

@network Cisco・アライド実機で学ぶ
◆セカンダリアドレスの設定(secondary)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆セカンダリアドレスの設定(secondary)

 ルータにインストールされているインタフェースの数は、有限です。モジュールを追加してインタフェースを増やすこともできますが、それでも数に限界がありますし、コストもかかります。

 実機で演習を行う上で、単純な演習であれば、少ないインタフェースで事足りますが、より高度で複雑な演習になってくると、それなりにインタフェースが、必要になってきます。

そこで、役立つのが、セカンダリアドレスです。

 セカンダリアドレスを使うと1つの物理インターフェース、または、Loopbackインタフェースに、複数のIPアドレスを持たせることができます。

構文は、以下の通りです。

Router(config)#interface [タイプ] [スロット番号]/[ポート番号]
Router(config-if)# ip address ip-address netmask secondary

セカンダリアドレスを設定する際は、Loopbackインタフェースと併用すると設定が、シンプルになります。

 ここでは、「ルートフィルタ設定(標準アクセスリスト)」で設定した内容を、そのまま、セカンダリアドレスを使用して設定してみます。

 ルートフィルタの設定を行います。ここでは、標準アクセスリストを使ってフィルタを作成し、インタフェースの受信時にフィルタを仕掛けてみます。

◆ルートフィルタ設定(標準アクセスリスト)

 ルートフィルタの設定を行います。ここでは、標準アクセスリストを使ってフィルタを作成し、インタフェースの受信時にフィルタを仕掛けてみます。「ルートフィルタ設定(標準アクセスリスト)」では、ループバックアドレスのみで設定を行いましが、ループバックアドレスと、セカンダリアドレスを併用して設定してゆきます。

まずは、フィルタを作成しないで下のRIPv2によるネットワークを構築します。


※ルート集約しないように「no auto-summary」コマンドを使用します。

●Router_Aの設定
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
ip cef
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
interface Serial0
 ip address 10.0.0.1 255.0.0.0
 clockrate 64000
 no fair-queue
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
!
ip classless
no ip http server
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
enable password cisco
!
memory-size iomem 25
ip subnet-zero
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.192
 ip address 192.168.1.65 255.255.255.192 secondary
 ip address 192.168.1.129 255.255.255.224 secondary
 ip address 192.168.1.161 255.255.255.224 secondary
 ip address 172.16.1.1 255.255.255.0 secondary
 ip address 172.16.2.1 255.255.255.0 secondary
!
interface Serial0
 ip address 10.0.0.2 255.0.0.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router rip
 version 2
 network 10.0.0.0
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary
!
ip classless
no ip http server
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


Router_Aのルーティングテーブルを表示します。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
R       172.16.1.0 [120/1] via 10.0.0.2, 00:00:09, Serial0
R       172.16.2.0 [120/1] via 10.0.0.2, 00:00:09, Serial0
C    10.0.0.0/8 is directly connected, Serial0
     192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
R       192.168.1.64/26 [120/1] via 10.0.0.2, 00:00:09, Serial0
R       192.168.1.0/26 [120/1] via 10.0.0.2, 00:00:09, Serial0
R       192.168.1.160/27 [120/1] via 10.0.0.2, 00:00:09, Serial0
R       192.168.1.128/27 [120/1] via 10.0.0.2, 00:00:10, Serial0

全てのルートが表示されています。


◆フィルタの作成と適用

 Router_Bから送信されるルート情報のうち、Router_Aで、192.168.1.0/26、192.168.1.64/26、192.168.1.128/27、192.168.1.160/27のルートのみを受信するようにします。

Router_Aで標準アクセスリストを使ってフィルタを作成し、S0の『IN』にフィルタを配置します。




●フィルタの作成

Router_A(config)#access-list 1 permit 192.168.1.0 0.0.0.255

 4つのルートは、先頭の「192.168.1.」が共通です。ワイルドカードマスクを「0.0.0.255」と指定すると4つのルートを許可するようになります。


●フィルタの配置

フィルタの配置は、ルーティングプロセスで指定します。

Router_A(config)#router rip
Router_A(config-router)#distribute-list 1 in s0

 Router_Aで、標準アクセスリストによるフィルタをS0の「IN」に適用することにより、Router_Bから送られてくる経路のうち、192.168.1.0/26、192.168.1.64/26、192.168.1.128/27、192.168.1.160/27の4つのルートのみを受信するようになります。

Router_Aのルーティングテーブルを表示してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    10.0.0.0/8 is directly connected, Serial0
     192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
R       192.168.1.64/26 [120/1] via 10.1.12.2, 00:00:04, Serial0
R       192.168.1.0/26 [120/1] via 10.1.12.2, 00:00:04, Serial0
R       192.168.1.160/27 [120/1] via 10.1.12.2, 00:00:04, Serial0
R       192.168.1.128/27 [120/1] via 10.1.12.2, 00:00:04, Serial0

R 172.16.1.0 [120/1] via 10.1.12.2, 00:00:05, Serial0
R 172.16.2.0 [120/1] via 10.1.12.2, 00:00:05, Serial0

のルートを受信しなくなりました。これは、Router_A側で、「172.16.1.0」「172.16.2.0」のルートをフィルタしたからです。

 セカンダリアドレス(secondary)を使用すると、このようなたくさんのインタフェースを使用する演習ができるようになります。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
ルートフィルタとは
ルートフィルタ(不適切なルーティング例)
ルートフィルタ設定(フィルタの作成)
ルートフィルタ設定(フィルタの適用)
ルートフィルタ設定(標準アクセスリスト)
ルートフィルタ設定(プレフィクスリスト)
ルートフィルタ設定(ルート再配送時)
ルートフィルタ設定(ルートマップ)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.