@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNP) > OSPF(ループバックインタフェースの活用)

 Amazon

@network Cisco・アライド実機で学ぶ
◆OSPF(ループバックインタフェースの活用)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆OSPF(ループバックインタフェースの活用)

 ある程度の大きさのネットワークを実機で演習するとなると、必要なルータの数も増えてきますし、ルータにモジュールを追加して、インタフェースを増さなければなりません。

 特にルーティングの演習では、ルート集約やアクセスリスト、再配送などを行います。たくさんの経路がないと十分な演習が行えません。

 ルータをたくさん購入するのは、とてもお金がかかりますし、モジュールといっても結構な値段がします。そこで重宝するのが、ループバックインタフェースです。

 ループバックインタフェースは仮想的なインタフェースで、ループバックインタフェース宛に送信されたパケットは、ルータ内部で折り返すようになっています。

 このループバックインタフェースにIPアドレスを割り振れば、ネットワークを増やすことができます。ループバックインタフェースは、数の上限を気にすることなく作成することができます。たくさん作成できます。

ちなみに、Cisco1710で、「interface loopback ?」コマンドで確認してみると以下のように出力されます。

Router(config)#interface loopback ?
<0-2147483647> Loopback interface number

0〜2,147,483,647まで設定できるみたいです。

それでは、下のネットワークをOSPFで構築してみましょう。


Router_A上でループバックインタフェースを作成し、以下のIPアドレスを割り当てます。

Loopback0:192.168.1.1/24
Loopback1:192.168.2.1/24
Loopback2:192.168.3.1/24
Loopback3:192.168.4.1/24

各ルータの設定は、以下のようになります。

●Router_Aの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
enable password cisco
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.3.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0
 ip address 172.16.0.1 255.255.0.0
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


●Router_Bの設定
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_B
!
enable password cisco
!
interface FastEthernet0
 ip address 172.16.0.2 255.255.0.0
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

それでは、ルーティングテーブルを確認してみます。

 Router_Bは、「192.168.1.0/24」「192.168.2.0/24」「192.168.3.0/24」「192.168.4.0/24」の経路をちゃんと学習してくれると思いますよね!

ところが、

Router_Bのルーティングテーブルを確認してみます。

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, FastEthernet0
     192.168.4.0/32 is subnetted, 1 subnets
O       192.168.4.1 [110/2] via 172.16.0.1, 00:01:46, FastEthernet0
     192.168.1.0/32 is subnetted, 1 subnets
O       192.168.1.1 [110/2] via 172.16.0.1, 00:01:46, FastEthernet0
     192.168.2.0/32 is subnetted, 1 subnets
O       192.168.2.1 [110/2] via 172.16.0.1, 00:01:46, FastEthernet0
     192.168.3.0/32 is subnetted, 1 subnets
O       192.168.3.1 [110/2] via 172.16.0.1, 00:01:46, FastEthernet0

 「192.168.1.1/32」「192.168.2.1/32」「192.168.3.1/32」「192.168.4.1/32」という経路情報になっています。

Router_A上で設定したループバックインタフェース上に設定されたサブネットマスクが反映されていません。

 OSPFでは、ループバックインタフェースは、ホストルートと見なされて、「/32」としてアドバタイズされるのです。

これでは、十分な演習が行えません。ループバックインタフェースの魅力が半減してしまいますよね。

そこで、ループバックインタフェース上に設定されたサブネットでアドバタイズさせるコマンドが用意されています。

続きは、「OSPF(ip ospf network point-to-point)」で設定してゆきます。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
OSPF(ループバックインタフェースの活用)
OSPF(ip ospf network point-to-point)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.