@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > VLAN間ルーティング

 Amazon

@network Cisco・アライド実機で学ぶ
◆VLAN間ルーティング

※動作確認は、Catalyst2950スイッチで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

※動作確認は、Catalyst2950スイッチで確認しています。

◆VLAN間ルーティング

異なるVLAN間で通信を行うには、レイヤ3の機能が必要になってきます。つまり、ルータが必要になります。

異なるVLANを接続すするには、以下のような方法があります。

●VLANと同じ数のリンクで各VLANを接続する方法

VLANと同じ数のだけ、ルータのEthernetのポートが必要になります。



●サブインタフェースにVLANカプセル化を指定しトランク接続する方法

 RouterとSwitch間をトランクで接続する方法です。VLANごとにサブインタフェースを作成し、VLANのカプセル化を行います。



それでは、下の図のようにネットワークを構成し、VLAN間通信の設定を行ってゆきます。

ルータには、サブインタフェースを作成し、VLANカプセル化にはIEEE802.1Qを指定します。



※ちなみに、ルータはサブインタフェースとVLANカプセル化が利用可能なCisco1721を使用します。

 Router_Aの設定の「f0」に3つのサブインタフェースを作成し、次のIPアドレスを割り当て、VLANカプセル化には、「dot1q」を指定します。

・f0.10 ・・・ 192.168.10.254/24
・f0.20 ・・・ 192.168.20.254/24
・f0.20 ・・・ 192.168.30.254/24


●サブインタフェースの作成

サブインタフェースを作成するには、グローバル設定モードで、次のよう指定します。

Router(config)#interface FastEthernet <ポート番号>.<サブインタフェース番号>

※サブインタフェースの番号に「0」は使用できません。「0」は物理インタフェース用に予約されています。


●VLANカプセル化の指定

 スイッチがサポートするVLANカプセル化は以下のようになります。ルータ側とスイッチ側で、カプセル化の指定を合わせておく必要があります。

「VLAN ID」には、サブインタフェースに接続するVLAN番号を指定します。

Catalyst1900 ・・・ ISLのみサポート
Catalyst2900XL ・・・ ISL、IEEE802.1Q
Catalyst2950 ・・・ IEEE802.1Qのみサポート

Router(config-subif)#encapsulation { isl | dot1q} {VLAN ID}


●Router_Aの設定

RouterA#config t
Router_A(config)#hostname Router_A
Router_A(config)#int f0
Router_A(config-if)#no shutdown
Router_A(config-if)#int f0.10
Router_A(config-subif)#encapsulation dot1q 10
Router_A(config-subif)#ip address 192.168.10.254 255.255.255.0
Router_A(config-subif)#int f0.20
Router_A(config-subif)#encapsulation dot1q 20
Router_A(config-subif)#ip address 192.168.20.254 255.255.255.0
Router_A(config-subif)#int f0.30
Router_A(config-subif)#encapsulation dot1q 30
Router_A(config-subif)#ip address 192.168.30.254 255.255.255.0
Router_A(config-subif)#end
Router_A#


●Switch_Aの設定

Switch#conf t
Switch(config)#hostname Switch_A
Switch_Aconfig)#exit
Switch_A#vlan database
Switch_A(vlan)#vlan 10 name vlan10
Switch_A(vlan)#vlan 20 name vlan20
Switch_A(vlan)#vlan 30 name vlan30
Switch_A(vlan)#exit
Switch_A#config t
Switch_A(config)#int f0/1
Switch_A(config-if)#switchport mode access
Switch_A(config-if)#switchport access vlan 10
Switch_A(config-if)#int f0/2
Switch_A(config-if)#switchport mode access
Switch_A(config-if)#switchport access vlan 20
Switch_A(config-if)#int f0/3
Switch_A(config-if)#switchport mode access
Switch_A(config-if)#switchport access vlan 30
Switch_A(config-if)#int f0/9
Switch_A(config-if)#switchport mode trunk


●VLAN間通信を検証する



 VLAN間、通信ができているかどうか、PC1からPC2へPingします。正しく設定が行えていれば、Pingは届くはずです。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
VLANとは
VLANの設定
VLANデータベースの削除(delete vlan.dat)
複数スイッチにまたがるVLANの作成
トランクとタギング(ISL、IEEE802.1Q)
トランクの設定(switchport mode trunk)
VTPとは
VTPの設定(vtp domain)
VTPの確認(show vtp status)
VTPプルーニング(vtp pruning)
VLAN間ルーティング

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.