@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > PPP認証(ppp atuthentication chap)

 Amazon

@network Cisco・アライド実機で学ぶ
◆PPP認証(ppp atuthentication chap)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆PPP認証(ppp atuthentication chap)

ここでは、PPPのCHAPによる認証を紹介します。

 CHAPによる認証は、ユーザ名とパスワードを基にした暗号化処理で認証が行われるので、PAPよりもセキュリティが高い認証方式です。認証の流れは、次の図のように3ウェイハンドシェイクで行われます。



◆PPPの認証設定

●認証データベースの作成

認証を設定するには、まず、認証用のデータベースを作成しなければなりません。

Router(config)#username <ユーザ名> password <パスワード>

ユーザ名には、相手のホスト名を指定します。

パスワードは、相手ルータと同じでなければ、認証が失敗するので同じ文字列にして下さい。


●CHAPの設定

Router(config-if)#encapsulation ppp
Router(config-if)#ppp authentication chap


●PAPとCHAPの同時設定

PAP認証と、CHAP認証を同時に行いたい場合は、次のコマンドを使用します。

Router(config-if)#ppp authentication {pap chap| chap pap}

 このコマンドで指定した最初の認証方式で、まずは試されます。認証で拒否された場合は、次の認証方式が試されます。

それでは、
下のネットワークをRIPで構築しPAP認証を設定してみましょう!


Router_A、Router_Bで次の設定を行います。

●Router_A

Router_A(config)#username Router_B password ccna

Router_A(config-if)#encapsulation ppp
Router_A(config-if)#ppp authentication chap

●Router_B

Router_A(config)#username Router_A password ccna

Router_A(config-if)#encapsulation ppp
Router_A(config-if)#ppp authentication chap

●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
username Router_B password 7 ccna
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 encapsulation ppp
 clockrate 64000
 ppp authentication chap
!
interface Serial1
 no ip address
 shutdown
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
hostname Router_B
!
enable password cisco
!
username Router_A password 0 ccna
!
interface Ethernet0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 encapsulation ppp
 no fair-queue
 ppp authentication chap
!
router rip
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line vty 0 4
 password cisco
 login
!
end


●PPPネゴシエーションの確認

PPPのネゴシエーションを確認するには、「debug ppp negotiation」コマンドを使用します。

Router#debug ppp negotiation

●「debug ppp negotiation」コマンドの出力
ppp: sending CONFREQ, type = 3 (CI_AUTHTYPE), value = 0xC223/5
ppp: sending CONFREQ, type = 5 (CI_MAGICNUMBER), value = 0xE0B907F1
PPP Serial0: state = REQsent fsm_rconfack(0xC021): rcvd id 18
ppp: config ACK received, type = 3 (CI_AUTHTYPE), value = 0xC223
ppp: config ACK received, type = 5 (CI_MAGICNUMBER), value = 0xE0B907F1
ppp: sending CONFREQ, type = 3 (CI_AUTHTYPE), value = 0xC223/5
ppp: sending CONFREQ, type = 5 (CI_MAGICNUMBER), value = 0xE0B907F1
PPP Serial0: state = REQsent fsm_rconfack(0xC021): rcvd id 19
ppp: config ACK received, type = 3 (CI_AUTHTYPE), value = 0xC223
ppp: config ACK received, type = 5 (CI_MAGICNUMBER), value = 0xE0B907F1
PPP Serial0: received config for type = 3 (AUTHTYPE) value = 0xC223 digest = 5 acked
PPP Serial0: received config for type = 5 (MAGICNUMBER) value = 0x10842AEF acked
ipcp: sending CONFREQ, type = 3 (CI_ADDRESS), Address = 172.17.0.1
ppp Serial0: Negotiate IP address: her address 172.17.0.2 (ACK)
ppp: ipcp_reqci: returning CONFACK.
ppp: cdp_reqci: returning CONFACK
PPP Serial0: state = ACKsent fsm_rconfack(0x8021): rcvd id 4
ipcp: config ACK received, type = 3 (CI_ADDRESS), Address = 172.17.0.1
Serial0: install route to 172.17.0.2
PPP Serial0: state = ACKsent fsm_rconfack(0x8207): rcvd id 4
ppp: cdp_reqci: received CONFACK



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
PPPの特徴
PPPの設定(encapsulation ppp)
PPP認証(ppp atuthentication pap)
PPP認証(ppp atuthentication chap)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.