@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > DNS(ip domain-lookup)

 Amazon

@network Cisco・アライド実機で学ぶ
◆DNS(ip domain-lookup)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆DNS(ip domain-lookup)

 Ciscoルータでは、 ホスト名とIPアドレスとの対応を「ip host」コマンドで定義することができます。しかし、この方法では、各ルータでホスト名とIPアドレスとの対応を「ip host」コマンドで定義する必要があり、規模の大きなネットワークでは、向いているとは言えません。

 ホスト名とIPアドレスを対応させる仕組みにDNS(Domain Naming System)がありますが、Ciscoルータでは、DNSサーバを使用して名前解決が行えるようになっています。

ここでは、CiscoルータのDNSサーバ機能を有効にする方法を紹介して行きます。

使用するネットワークは、下図になります。

※ブロードバンドルータのDNSフォワード機能を有効にして、加入しているISPのDNSサーバのIPアドレスを設定しておきます。

まずは、Router_Aに基本的な設定を行います。

◆基本設定

Router#conf t
Router(config)#hostname Router_A
Router_A(config)#int f0
Router_A(config-if)#ip address 192.168.1.1 255.255.255.0
Router_A(config-if)#no shutdown
Router_A(config-if)#exit
Router_A(config)#line vty 0 4
Router_A(config-line)#password cisco
Router_A(config-line)#login
Router_A(config-line)#exit
Router_A(config)#enable password cisco


◆DNS機能を有効にする

ルータのDNS機能を有効にするには、グローバル設定モードで、「ip domain-lookup」コマンドを使用します。

ちなみに、このコマンドを設定しなくともデフォルトでDNS機能を有効になっています。

Router_A(config)#ip domain-lookup

ちなみに「show run」コマンドで確認すると「ip domain-lookup」コマンドがないことが確認できます。

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 25
!
ip cef
!
interface Ethernet0
 no ip address
 shutdown
 half-duplex
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

◆デフォルトルートを追加する

Router_Aにデフォルトルートを追加します。

Router_A(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.254

これで、設定は全て完了です。

Router_Aのコンソールからpingコマンドを実行します。

Router_A#ping www.yahoo.co.jp

●Router_Aの「ping」の出力
Router_A#ping www.yahoo.co.jp

Translating "www.yahoo.co.jp"...domain server (255.255.255.255) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 124.83.139.192, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms

「www.yahoo.co.jp」が名前解決され、pingが成功します。

 DNSサーバのIPアドレスを指定しなくとも、Router_Aと同じセグメントにDNSサーバが存在すれば、名前解決は成功します。

次の「DNS(no ip domain-lookup)」では、DNS機能を無効にする方法を紹介します。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
DNS(ip domain-lookup)
DNS(no ip domain-lookup)
DNSサーバの指定(ip name-server)その1
DNSサーバの指定(ip name-server)その2

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.