@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > DHCPリレーの設定(ip helper-address)

 Amazon

@network Cisco・アライド実機で学ぶ
◆DHCPリレーの設定(ip helper-address)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆DHCPリレーの設定(ip helper-address)

 IPアドレスを自動取得に設定した端末は、自分の所属するセグメント上でDHCPサーバを探すために、IPブロードキャストを使用します。

 DHCPサーバと同じセグメントに端末が存在すれば、IPアドレスなどのパラメータを取得できますが、同じセグメントに存在しない場合は、どうなるのでしょうか?

 ルータは、ブロードキャストを転送しないということを思い出して下さい。下の図のようなネットワークの場合、端末はIPアドレスをDHCPサーバから取得できません。


ルータを超えてDHCPサーバへアクセスするには、以下の方法があります。

・全てのセグメントにDHCPサーバを用意する方法
・OSのDHCPリレーエージェントを使って転送する方法
・ルータのDHCPリレーエージェント機能を使う方法

 「全てのセグメントにDHCPサーバを用意する方法」は、セグメントの数だけDHCPサーバを用意することになるので、管理の手間がかかってしまいます。

 「OSのDHCPリレーエージェントを使って転送する方法」は、OS側でDHCPリレーエージェントのサービスを有効にしてDHCP要求を別のネットワーク上にあるDHCPサーバへ転送する方法です。この方法も、DHCPリレーエージェントをセグメントごとに用意しなければなりません。この方法も管理の手間がかかります。

 「ルータのDHCPリレーエージェント機能を使う方法」は、ブロードキャスト要求をリレーする方法です。Cisco IOSのヘルパーアドレスという機能を使用するとUDPの主要サービスへのブロードキャストをリレーすることができます。

 ネットワークの境界に位置するルータでこの機能が利用できると、DHCPサーバの配置にもよりますが、設置するDHCPサーバの台数、DHCPリレーエージェントの数を削減することができます。

Ciscoルータでブロードキャスト要求をリレーするには、「ip helper-address」コマンドを使用します。

それでは、下の図のネットワークを構成してDHCPリレーを検証してみましょう!

以下のルータを使用します。

Router_A ・・・ Cisco 2500シリーズ、もしくは、1720(Cisco 1721)
Router_B ・・・ Cisco 1720(Cisco 1721)



●ip helper address

 「ip helper address」コマンドを使うと、ブロードキャストパケットを特定のサーバにユニキャストすることができます。

Route(config)#ip helper-address {転送先IPアドレス}


●Router_Aの設定

 Router_A上で、 「ip helper address」コマンドを使ってDHCPのブロードキャストパケットをDHCPサーバへ転送するように設定します。インタフェース設定モードで、コマンドを入力します。

Router_A(config)#int e0
Router_A(config-if)#ip helper-address 10.1.1.2


●Router_Bの設定

Router_B(config)#ip dhcp excluded-address 172.16.1.1 172.16.1.10
Router_B(config)#ip dhcp pool sales
Router_B(dhcp-config)#network 172.16.1.0 255.255.255.0
Router_B(dhcp-config)#default-router 172.16.1.1
Router_B(dhcp-config)#dns-server 172.16.1.2

Router_B(config)#ip route 172.16.1.0 255.255.255.0 10.1.1.1


●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 ip helper-address 10.1.1.2
!
interface Serial0
 ip address 10.1.1.1 255.255.255.0
 clockrate 64000
!


●Router_Bの設定
!
hostname Router_B
!
ip subnet-zero
ip dhcp excluded-address 172.16.1.1 172.16.1.10
!
ip dhcp pool sales
   network 172.16.1.0 255.255.255.0
   default-router 172.16.1.1
   dns-server 172.16.1.2
!
interface Serial0
 ip address 10.1.1.2 255.255.255.0
 no fair-queue
!
ip classless
ip route 172.16.1.0 255.255.255.0 10.1.1.1
no ip http server
!

 PC1から、「10.1.1.2」へPingをしてみます。Pingは成功するはずです。DHCPサーバを探すためのIPブロードキャストが、Router_AによりRouter_Bに転送され、PCが、IPアドレスを取得できていることがを確認できます。



<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
DHCPの設定
DHCPリレーの設定(ip helper-address)

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.