@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > RIPの設定1

 Amazon

@network Cisco・アライド実機で学ぶ
◆RIPの設定1

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク

◆RIPの設定1

 RIPは、ディスタンスベクタ型のルーティングプロトコルです。ルーティングテーブルを30秒ごとに交換しています。CiscoのRIPでは、変更を検出するたびにトリガード更新も行われます。メトリックは、ホップカウントのみを採用しています。つまり、最良のルートを経由するルータの数で判断しています。

それでは、下の図のような、RIPネットワークを構築してみましょう!


◆RIPの設定

ripの設定は、以下のようになります。

1.ルーティングプロトコルを選択する。

Router(config)#router rip

2.ネットワークアドレスを指定する。

直接接続しているネットワークをクラスフルで指定します。

Router(config-router)#network {ネットワーク番号}

 上のネットワークの場合、Router_Aは、「172.16.0.0/16」ネットワークと、「172.17.0.0/16」ネットワークに直接接続しているので、RIPの設定は、以下のようになります。

Router(config)#router rip
Router(config-router)#network 172.16.0.0
Router(config-router)#network 172.17.0.0

ネットワークの指定にサブネットマスクは、必要ありませんので、注意して下さい。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router rip
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
interface Ethernet0
 ip address 172.18.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router rip
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, Ethernet0
C    172.17.0.0/16 is directly connected, Serial0
R    172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:02, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:24, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

「R」で表示されているルートは、RIPによって学習したことを意味します。

Router_Aでは、「172.18.0.0/16」のルート
Router_Bでは、「172.16.0.0/16」のルート

を学習していることが分かります。

それでは、設定したRIPネットワークを検証コマンドを使って確認してみましょう。

続きは、「RIPの検証コマンド」で紹介しています。

スポンサードリンク


<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ>
RIPの設定例1
RIPの検証コマンド
RIPの設定例2
RIP(passive-interface)
RIP(debugコマンド)
RIP(等コストロードバランシング_その1)
RIP(等コストロードバランシング_その2)
RIPとスタティックルートの混在時
RIPとフローティングスタティック その1
RIPとフローティングスタティック その2
RIP(不連続サブネットにおける問題)
RIP Version2
RIP V1、RIP V2の混在時
RIPv2(平文認証)その1
RIPv2(平文認証)その2
RIPv2(MD5認証)その1
RIPv2(MD5認証)その2

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.