@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > EIGRPとIGRPの混在時(自動再配布)

 Amazon

@network Cisco・アライド実機で学ぶ
◆EIGRPとIGRPの混在時(自動再配布)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク


◆EIGRPとIGRPの混在時(自動再配布)

 異なるルーティングプロトコル間で経路情報を共有するには、再配布の設定が必要になります。その設定は、少々難しいのですが、EIGRPとIGRP間では、再配布は自動的に行われます。

下の図のようにネットワークを構成してみます。



 EIGRPとIGRPは、同じCisco Systems独自のプロトコルで相性がよく、AS番号が一致していれば、自動的に、ルートを再配布してくれます。

上の図の場合、Router_Bの場合下のように設定するだけで、自動的にIGRP、EIGRP間でルート情報を再配布してくれるようになります。

Router_B(config)#router igrp 1
Router_B(config-router)#network 172.17.0.0
Router_B(config-route)#exit
Router_B(config)#router eigrp 1
Router_B(config-router)#network 172.18.0.0


●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
!
interface Ethernet0
 ip address 172.16.0.1 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 bandwidth 64
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router igrp 1
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
 bandwidth 64
 no fair-queue
!
interface Serial1
 ip address 172.18.0.1 255.255.0.0
 bandwidth 64
 clockrate 64000
 no fair-queue
!
router igrp 1
 network 172.17.0.0
router eigrp 1
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Cの設定
!
version 11.2
service udp-small-servers
service tcp-small-servers
!
hostname Router_C
!
enable password cisco
!
!
interface Ethernet0
 ip address 172.19.0.1 255.255.0.0
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 ip address 172.18.0.2 255.255.0.0
 bandwidth 64
!
router eigrp 1
 network 172.18.0.0
 network 172.19.0.0
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


Router_A、Router_Cのルーティングテーブルを表示します。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, Ethernet0
C    172.17.0.0/16 is directly connected, Serial0
I    172.18.0.0/16 [100/160250] via 172.17.0.2, 00:00:41, Serial0
I    172.19.0.0/16 [100/160350] via 172.17.0.2, 00:00:42, Serial0

●Router_Cのルーティングテーブル
Gateway of last resort is not set

D EX 172.16.0.0/16 [170/41049600] via 172.18.0.1, 00:11:39, Serial1
D EX 172.17.0.0/16 [170/40512000] via 172.18.0.1, 00:11:39, Serial1
C    172.18.0.0/16 is directly connected, Serial1
C    172.19.0.0/16 is directly connected, Ethernet0

 EIGRPでは、IGRPや外部から学習したルートに外部(EXTERNAL)とタグ付けを行って、EIGRPのルートと識別します。IGRPでは、内部ルートと外部ルートの区別が行われません。

 上の「show ip route」の出力を見ると、Router_Cでは、IGRPによる外部ルートに「EX」というフラグが付けられています。EIGRPは、IGRPから再配布されたルートを外部ルートとして識別しています。

 一方、Router_Aでは、EIGRPよる外部ルートを識別できず相変わらず、IGRPで学習したものとして扱っていることが分かります。

 次の「EIGRPの設定例2」では、トポロジテーブルを確認してサクセサとフィージブルサクセサについて確認してみます。





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ
EIGRPの特徴
EIGRP(サクセサ・フィジブルサクセサ)
EIGRPの設定例1
EIGRP(検証コマンド)
EIGRP(debugコマンド)
EIGRP(ハロー間隔・ホールドタイム)
EIGRPとIGRPの混在時(自動再配布)
EIGRPの設定例2
EIGRP(show ip eigrp topology)
EIGRP(自動集約の問題)
EIGRP(no suto-summary)
EIGRP(MD5認証)その1
EIGRP(MD5認証)その2
EIGRP(手動経路集約)その1
EIGRP(手動経路集約)その2
EIGRP(手動経路集約)その3
EIGRP(手動経路集約)その4

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.