@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > EIGRP(MD5認証)その1

 Amazon

@network Cisco・アライド実機で学ぶ
◆EIGRP(MD5認証)その1

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク


◆EIGRP(MD5認証)その1

 EIGRPでは、認証をサポートしています。アップデートを交換する際に認証を行うことができます。認証は、RIPv2やOSPFなどでもサポートされています。

 この認証を行うことで、不正なルータからのアップデートの偽造や改ざんによるネットワークの混乱を防御することができます。認証の設定をしているルータ同士のみがアップデートを交換するようになります。

 RIPの場合は認証モードで「text」または、「md5」を指定することができましたが、EIGRPでは「md5」 にみ指定することができます。

それでは、まず、下のネットワーク構成を認証なしで、設定してゆきます。

EIGRPによる自動集約は、無効にしておきます。



●Router_Aの設定
!
hostname Router_A
!
ip subnet-zero
!
interface Serial0
 ip address 10.0.0.2 255.255.255.0
 clockrate 64000
!
interface Serial1
 ip address 20.0.0.1 255.255.255.0
 clockrate 64000
!
router eigrp 100
 network 10.0.0.0
 network 20.0.0.0
 no auto-summary
!
ip classless
!

●Router_Bの設定
!
hostname Router_B
!
ip subnet-zero
!
interface Loopback0
 ip address 172.16.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial1
 ip address 30.0.0.1 255.255.255.0
 clockrate 64000
!
router eigrp 100
 network 10.0.0.0
 network 30.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip classless
!

●Router_Cの設定
!
hostname Router_C
!
ip subnet-zero
!
interface Loopback0
 ip address 172.17.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.17.1.1 255.255.255.0
!
interface Serial0
 ip address 20.0.0.2 255.255.255.0
!
interface Serial1
 ip address 30.0.0.1 255.255.255.0
!
router eigrp 100
 network 20.0.0.0
 network 30.0.0.0
 network 172.17.0.0
 no auto-summary
!
ip classless
!

Router_A、Router_B、Router_Cのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0
     20.0.0.0/24 is subnetted, 1 subnets
C       20.0.0.0 is directly connected, Serial1
     30.0.0.0/24 is subnetted, 1 subnets
D       30.0.0.0 [90/2681856] via 10.0.0.1, 00:00:53, Serial0
                 [90/2681856] via 20.0.0.2, 00:00:53, Serial1
     172.16.0.0/24 is subnetted, 2 subnets
D       172.16.0.0 [90/2297856] via 10.0.0.1, 00:00:53, Serial0
D       172.16.1.0 [90/2297856] via 10.0.0.1, 00:00:53, Serial0
     172.17.0.0/24 is subnetted, 2 subnets
D       172.17.1.0 [90/2297856] via 20.0.0.2, 00:00:53, Serial1
D       172.17.0.0 [90/2297856] via 20.0.0.2, 00:00:53, Serial1

●Router_Bのルーティングテーブル
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0
     20.0.0.0/24 is subnetted, 1 subnets
D       20.0.0.0 [90/2681856] via 10.0.0.2, 00:15:11, Serial0
     30.0.0.0/24 is subnetted, 1 subnets
C       30.0.0.0 is directly connected, Serial1
     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.0.0 is directly connected, Loopback0
C       172.16.1.0 is directly connected, Loopback1
     172.17.0.0/24 is subnetted, 2 subnets
D       172.17.1.0 [90/2809856] via 10.0.0.2, 00:15:08, Serial0
D       172.17.0.0 [90/2809856] via 10.0.0.2, 00:15:08, Serial0

●Router_Cのルーティングテーブル
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
D       10.0.0.0 [90/2681856] via 20.0.0.1, 00:17:32, Serial0
     20.0.0.0/24 is subnetted, 1 subnets
C       20.0.0.0 is directly connected, Serial0
     30.0.0.0/24 is subnetted, 1 subnets
C       30.0.0.0 is directly connected, Serial1
     172.16.0.0/24 is subnetted, 2 subnets
D       172.16.0.0 [90/2809856] via 20.0.0.1, 00:17:32, Serial0
D       172.16.1.0 [90/2809856] via 20.0.0.1, 00:17:32, Serial0
     172.17.0.0/24 is subnetted, 2 subnets
C       172.17.1.0 is directly connected, Loopback1
C       172.17.0.0 is directly connected, Loopback0

「MD5」による認証の設定は、次の「EIGRP(MD5認証)その2」で行います。





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ
EIGRPの特徴
EIGRP(サクセサ・フィジブルサクセサ)
EIGRPの設定例1
EIGRP(検証コマンド)
EIGRP(debugコマンド)
EIGRP(ハロー間隔・ホールドタイム)
EIGRPとIGRPの混在時(自動再配布)
EIGRPの設定例2
EIGRP(show ip eigrp topology)
EIGRP(自動集約の問題)
EIGRP(no suto-summary)
EIGRP(MD5認証)その1
EIGRP(MD5認証)その2
EIGRP(手動経路集約)その1
EIGRP(手動経路集約)その2
EIGRP(手動経路集約)その3
EIGRP(手動経路集約)その4

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.