@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > EIGRP(no suto-summary)

 Amazon

@network Cisco・アライド実機で学ぶ
◆EIGRP(no suto-summary)

※動作確認は、Cisco2500、Cisco1720、Cisco1721、Cisco2611、Cisco2650、Cisco3620シリーズのルータ、Catalyst2900、Catalyst2950シリーズのスイッチなどで確認しています。コマンド、出力結果、動作は、機種、IOSのバージョンで異なる場合があります。
 資格取得が就職、転職、派遣に有利なのは確かですが、「資格=即戦力」とは言えません。実機を操作して資格取得と同時に就職・転職・派遣後に求められるエンジニア(仕事・ジョブ・ワークの達人)としての即戦力を養いましょう。

スポンサードリンク


◆EIGRP(no suto-summary)

 前の「EIGRP(自動集約の問題)」で確認したようにEIGRPによる自動集約が、必ずしも望ましい結果にならない場合があることを確認しました。

ここでは、このような場合に自動集約を無効にして手動で要約する方法を紹介します。

引き続き、ネットワークは、下の構成図を使ってルータを設定してゆきます。


●自動集約を無効にするコマンド

自動集約を無効にするコマンドは、下のコマンドになります。

Router(config-router)#no auto-summary


●手動で要約ルートを定義するコマンド

 手動で要約ルートを定義するには、インターフェースコンフィグレーションモードで「ip summary-address eigrp」コマンドで設定します。

Router(config-if)#ip summary-address eigrp {AS番号} {IPアドレス} {サブネットマスク} {アドミニストレーティブディスタンス}

 アドミニストレーティブディスタンスの値は、デフォルトで5に設定されています。変更する必要がなければ省略できます。変更する場合は、1〜255の範囲で設定することができます。

 「EIGRP(自動集約の問題)」で設定した内容に加えて、Router_A、Router_Bで以下の設定が追加で必要になります。


●Router_Aの追加設定

Router_A(config)#router eigrp 1
Router_A(config-router)#no auto-summary
Router_A(config-router)#exit
Router_A(config)#interface serial 0
Router_A(config-if)#ip summary-address eigrp 1 172.16.1.0 255.255.255.0

●Router_Aの追加設定

Router_B(config)#router eigrp 1
Router_B(config-router)#no auto-summary
Router_B(config-router)#exit
Router_B(config)#interface serial 0
Router_B(config-if)#ip summary-address eigrp 1 172.16.3.0 255.255.255.0


以上のコマンドを追加設定し、これで、ちゃんとEIGRPでルーティングできるか検証してみます。

●Router_Aの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 ip address 192.168.1.1 255.255.255.0
 ip summary-address eigrp 1 172.16.1.0 255.255.255.0
 bandwidth 64
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 1
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
!
interface Ethernet0
 ip address 172.16.3.1 255.255.255.0
!
interface Serial0
 ip address 192.168.1.2 255.255.255.0
 ip rip authentication mode 0
 ip summary-address eigrp 1 172.16.3.0 255.255.255.0
 bandwidth 64
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 1
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


Router_A、Router_Bのルーティングテーブルを確認してみます。

●Router_Aのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0
     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, Ethernet0
D       172.16.3.0 [90/40537600] via 192.168.1.2, 00:00:18, Serial0

●Router_Bのルーティングテーブル
Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0
     172.16.0.0/24 is subnetted, 2 subnets
D       172.16.1.0 [90/40537600] via 192.168.1.1, 00:03:13, Serial0
C       172.16.3.0 is directly connected, Ethernet0


 「172.16.0.0/16」という経路が消え、Router_Aでは「172.16.3.0/24」が、Router_Bでは「172.16.1.0/24」という経路が追加されました。

 EIGRPによる自動集約が望ましい結果にならない場合があるので、ネットワークの状況に合わせて、自動集約を無効にし、手動で要約しなければならないケースがあることも覚えておきましょう!





<ネットワーク資格の練習問題に挑戦>
CCNA練習問題に挑戦!(650問)
Network+練習問題に挑戦!(393問)
テクニカルエンジニア(ネットワーク)試験
◆Cisco実機で学ぶ(CCNAルータ編)

ルータの概要・基本操作・設定1 (17項目)
ルータの概要・基本操作・設定3 (22項目)
IGRP・EIGRPの設定 (18項目)
アクセスリスト・ACLの設定 (14項目)
NAT・DHCPの設定 (8項目)
ルータの概要・基本操作・設定2 (17項目)
RIPv1・RIPv2の設定 (14項目)
OSPFの設定・デフォルトルートの伝播(16項目)
WANの設定 (10項目)
◆Cisco実機で学ぶ(CCNAスイッチ編)

スイッチの基本操作・設定 (14項目)
VTP・スパニングツリーの設定 (12項目)
MACアドレスの管理・VLANの設定 (12項目)

◆アライドテレシス実機で学ぶ

基本操作・設定 (11項目)
OSPFの設定 (9項目)
ポリシールーティング・VRRPなど (12項目)
VLAN・マルチホーミング・RIPの設定 (10項目)
STP・ポートトランキングなど (14項目)
<関連コンテンツ
EIGRPの特徴
EIGRP(サクセサ・フィジブルサクセサ)
EIGRPの設定例1
EIGRP(検証コマンド)
EIGRP(debugコマンド)
EIGRP(ハロー間隔・ホールドタイム)
EIGRPとIGRPの混在時(自動再配布)
EIGRPの設定例2
EIGRP(show ip eigrp topology)
EIGRP(自動集約の問題)
EIGRP(no suto-summary)
EIGRP(MD5認証)その1
EIGRP(MD5認証)その2
EIGRP(手動経路集約)その1
EIGRP(手動経路集約)その2
EIGRP(手動経路集約)その3
EIGRP(手動経路集約)その4

<関連メニュー>
CCNA実機で学ぶ
CCNP実機で学ぶ
アライドテレシス実機で学ぶ
TCP/IP入門・無料ネットワークツール

Copyright(c)2006- @network Cisco・アライド実機で学ぶ All rights reserved.